LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-17-2013, 12:24 PM   #1
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware
Posts: 175

Rep: Reputation: 19
Fluxbox configuration question


I'm using fluxbox and am trying to stop the screen on my laptop from going to sleep. Does anyone have any ideas how I can do this?
 
Old 11-17-2013, 01:12 PM   #2
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 174
Blog Entries: 1

Rep: Reputation: 36
either edit file /etc/X11/xorg.conf or find it in /etc/X11/xorg.conf.d/10-serverflag.conf
Section "ServerFlags"
Option "BlankTime" "17"
Option "StandbyTime" "20"
Option "SuspendTime" "25"
Option "OffTime" "30"
EndSection

or find DPMS in Section "Monitor" or "Device" in /etc/X11/xorg.conf.d/10-monitor.conf etc.
Option "DPMS" "no"

Last edited by number22; 11-17-2013 at 01:16 PM.
 
Old 11-17-2013, 01:15 PM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,231

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Either put something like this in your xorg.conf
Code:
Section "ServerFlags"
    Option         "BlankTime" "20"
    Option         "StandbyTime" "0"
    Option         "SuspendTime" "0"
    Option         "OffTime" "30"
EndSection
... set time values as required, 0 to disable.

Or use the "xset s off" to disable it from the command line (or add that to your ~.xsession file.
"man xset" for details/options.
 
Old 11-17-2013, 04:19 PM   #4
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware
Posts: 175

Original Poster
Rep: Reputation: 19
I tried editing /etc/X11/xorg.conf.d/10-serverflag.conf and set all to 0, but that didn't seem to stop the screen from shutting off after a while.

I then tried editing /etc/X11/xorg.conf and it seemed to make my internet connection go all funky... didn't disable it, but every page I went to was having problems loading.

Now both of those files were blank when I started editing them, so I just deleted everything that I had entered.
 
Old 11-17-2013, 05:48 PM   #5
BlackRider
Member
 
Registered: Aug 2011
Distribution: Slackware
Posts: 261

Rep: Reputation: 82
[...]find DPMS in Section "Monitor" or "Device" in /etc/X11/xorg.conf.d/10-monitor.conf etc.
Option "DPMS" "no"


I thumb up this one.

You can also manually disable DPMS each session:

xset -dpms
 
Old 11-17-2013, 08:25 PM   #6
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,903

Rep: Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284
Before you do any of that, check the power management settings in xscreensaver, if you haven't already done so.
 
Old 11-17-2013, 08:25 PM   #7
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware
Posts: 175

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by BlackRider View Post
[...]find DPMS in Section "Monitor" or "Device" in /etc/X11/xorg.conf.d/10-monitor.conf etc.
Option "DPMS" "no"


I thumb up this one.

You can also manually disable DPMS each session:

xset -dpms
manually setting DPMS seems to work just fine, thanks for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox configuration help???? t1nm@n Linux - Newbie 17 03-21-2010 06:27 PM
Fluxbox Configuration JMJ_coder Linux - General 2 09-18-2007 02:46 PM
Fluxbox configuration Piedrunov Linux - Newbie 4 04-21-2004 03:53 AM
Fluxbox configuration Jonatoon Linux - Software 2 03-18-2004 09:57 AM
Fluxbox Configuration AceTech747 Linux - Software 40 01-28-2004 12:47 PM


All times are GMT -5. The time now is 09:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration