-   Slackware (
-   -   floppy boot failing (

globaltree 03-13-2010 02:23 AM

floppy boot failing
Howdy LQ:

I have an external 500gb usb drive with a bootable full install of slackware 12.2, and it also contains all the sets, patches, and extras for 12.2 in /usr/src, along with some other non slackware packages, like gparted, and I use it for rescue, backup, installation, etc.

I used this disk with no errors, setting up 12.2 on my mother's dell, a pentium 4.

However, my mom has an older gateway as well (a pentium 2) that she keeps around because it has M$ Publisher on it, and sometimes a student emails her a Publisher document, and she has to use her old sluggish beast to open it up.

I have not found an open source solution to open Publisher docs in Linux, so I have been trying to follow to migrate the her xp installation on her old box to a vdi to use with virtualbox.

My first obstacle is that the cd drive in the old machine is non-functioning. My second obstacle is that her machine dates back to the days before the bios supported booting from usb.

I have never had the time to mess with network booting, and don't know how to set up a bootp server, so sticking with what I know, I thought I could install lilo on a floppy, and have it configured to boot my external usb.

Originally, lilo was installed on the mbr of the usb, but for this project, I went ahead, using the pentium 4, and reinstalled the lilo boot loader on a floppy. I did this by mounting my external usb drive (which shows up as /dev/sda) and then binding /sys, /proc, and /dev to it, and chrooting into the external usb install. Then I modified lilo.conf and reran lilo.

It worked, and now the external hard drive only boots on the pentium 4 when I have the floppy inserted into /dev/fd0.

However, when I plug the external drive into the pentium 2's usb, and insert the floppy and try to boot, it never makes it to the lilo prompt, and just displays 10 lines of L 07 07 07 07 07 07 07 07 07...

The boot order is correctly set in bios to try the floppy first. I thought I might have problems with the smp kernel on such an old system, and thought I might have to go back to huge.s, but I'm not even making it to the prompt...

Does anyone have any advice as to how to hurdle these obstacles?

MS3FGX 03-13-2010 01:22 PM

Well if I am understanding the problem correctly, it seems like the most logical thing would be to simply take the drive out of the machine and make an image of it with an IDE to USB adapter, which are all of $8 online.

Though I am not sure why you are going through the trouble in the first place. Why wouldn't you just install Publisher on her new computer? I don't understand the reasoning behind keeping such an old computer around to do something her main computer could do much better and just as easilly. It isn't as if it is running some ancient DOS software that would need to be emulated on a modern machine.

globaltree 03-13-2010 07:34 PM

Hehe, I didn't even know that ide-to-usb adapters existed... that of course would solve everything... thanks!

As far as installing Publisher is concerned, it's simply been so long since it was orignally installed, that she cannot find the disks, and she suspects they may have disappeared with one of the many exchange students that she periodically hosts...

But, as far as just understanding slackware, I still don't know why the p2 won't boot from the floppy like like the p4 does... if it had, I wouldn't have to buy anything at all...

thanks again.

MS3FGX 03-13-2010 09:55 PM

A Pentium 2 is fairly ancient hardware, I would not be surprised if modern software has problems running on it. Especially trying to initialize such an ancient USB controller.

globaltree 03-15-2010 03:32 PM

Ah. At last. I finally have some closure to this, and can now take my mom's old pentium 2 to the recycling center. I couldn't find a retail shop with the ide2usb converter, and couldn't get one shipped before I leave tomorrow (only visiting for spring break), so I ended up taking the cd drive out of the pentium 4 and temporarily installing in the pentium 2 just to boot up off of the cd and dd her drive.

Ironically, when I tried to boot the huge.s kernel it failed, but the smp kernel was successful... go figure.

Thanks MS3FGX for your help. I'll be getting one of those adapters anyways, just to have it on hand...

All times are GMT -5. The time now is 12:37 PM.