LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-20-2017, 10:29 AM   #1
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 553

Rep: Reputation: 148Reputation: 148
flashplayer slackbuild in 'extra' does not retrieve version


Hi, the flashplayer.Slackbuild in 'extra' does not work as before.

The latest version on http://www.adobe.com/software/flash/about/(25.0.0.171) was not downloaded:
Code:
bash-4.4# sh flashplayer-plugin.SlackBuild
Source 'flash_player_npapi_linux..x86_64.tar.gz' not available yet...
The version was not retrieved by the looks of it; it worked by hardcoding this directly with
Code:
VERSION=${VERSION:-"25.0.0.171"}
Is an update like last December's one needed now version 25 is here?

From changelog/current:
Quote:

Tue Dec 13 22:14:13 UTC 2016
...
extra/source/flashplayer-plugin/flashplayer-plugin.SlackBuild: Updated.
Fixed filename and URL for new version 24. Thanks to alienBOB.
+--------------------------+
Rob
 
Old 05-20-2017, 10:43 AM   #2
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 969

Rep: Reputation: 460Reputation: 460Reputation: 460Reputation: 460Reputation: 460
I use the slackbuild and I always have to hit "Retry" to get it to download in sbopkg.
 
Old 05-20-2017, 10:57 AM   #3
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 553

Original Poster
Rep: Reputation: 148Reputation: 148
Sorry, this is not about an SBo slackbuild (managed via sbopkg), but the slackbuild in 'current/extra/flashplayer-plugin/' of the developmental Slackware distribution
 
Old 05-20-2017, 10:59 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,592

Rep: Reputation: 6010Reputation: 6010Reputation: 6010Reputation: 6010Reputation: 6010Reputation: 6010Reputation: 6010Reputation: 6010Reputation: 6010Reputation: 6010Reputation: 6010
I always have a package for the latest flashplayer-plugin (i.e. the NPAPI plugin), usually the same day Adobe releases it; http://www.slackware.com/~alien/slac...player-plugin/

Same goes for the PPAPI plugin: http://www.slackware.com/~alien/slac...rflash-plugin/

Easier than fighting with SlackBuild scripts that fail to download the plugin.
 
1 members found this post helpful.
Old 05-20-2017, 11:03 AM   #5
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 553

Original Poster
Rep: Reputation: 148Reputation: 148
Thanks. With all available sources, should 'flashplayer-plugin' be removed from 'current/extra/' ??
 
Old 05-20-2017, 11:07 AM   #6
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 969

Rep: Reputation: 460Reputation: 460Reputation: 460Reputation: 460Reputation: 460
Quote:
Originally Posted by brobr View Post
Sorry, this is not about an SBo slackbuild (managed via sbopkg), but the slackbuild in 'current/extra/flashplayer-plugin/' of the developmental Slackware distribution
I read you correctly. The problem is on Adobe's end.
 
Old 05-20-2017, 11:20 AM   #7
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 553

Original Poster
Rep: Reputation: 148Reputation: 148
Replacing

Code:
VERSION=${VERSION:-"$(wget -O - http://www.adobe.com/software/flash/about/ 2>/dev/null | sed -n "/Firefox - NPAPI/{N;p}" | tr -d ' '| tail -1 | tr '<>' '  ' | cut -f3 -d ' ')"}
as described above works, the wget|sed-command yields as download "flash_player_npapi_linux.x86_64.tar.gz"; without version, so that the build stops.
 
Old 05-23-2017, 06:44 AM   #8
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 553

Original Poster
Rep: Reputation: 148Reputation: 148
Quote:
extra/source/flashplayer-plugin/flashplayer-plugin.SlackBuild: Updated.
Fixed retrieving version number.
from Current Changelog Mon May 22 20:58:20 UTC 2017
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 14.1 Adobe Flashplayer version? stf92 Slackware 9 07-03-2015 12:13 PM
flashplayer//ERROR: failed to get upstream version blankanieves Linux - Newbie 2 06-20-2014 09:37 AM
[SOLVED] Claws Mail extra plugins Slackbuild error Gerard Lally Slackware 2 11-03-2011 08:14 PM
How to remove old version flashplayer in Firefox ? wlaw Linux - Software 6 12-20-2007 09:24 AM
How to install Macromedia Flashplayer 8.0+ Version Ongeboren Ubuntu 4 11-14-2006 05:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration