-   Slackware (
-   -   Flash Player Refusing to Play Videos (

business_kid 10-24-2012 05:26 AM

Flash Player Refusing to Play Videos
The site in question is my local tv channel
I believe it is open to the world. I can't play it on Slackware-14.0, w/Flash Plugin 11.2.r202.238(latest) and firefox-16.0.1

I tried the station, who said
This is an issue with the latest flash player in Linux, the second response in this thread on Adobe's forum may help you resolve this issue:
The advice here is to install libhal in Ubuntu. Some other urls referenced in the thread:
Which is a thread on, mainly talking about SuSE, and making this point

If the Hardware Abstraction Layer module is missing, Flash Player still functions. However, it cannot play protected content that requires the Adobe Flash Access DRM (Digital Rights Management) module.

This I believe, is the material point, as Slackware has dropped hal. You guys must have seen this one coming . . . didn't you?? I need a clever trick here and now on this one please :-D. Pleease?
Adobe's testing flash player And the url to paste into it is

Finally, the video I was trying to watch

business_kid 10-24-2012 02:55 PM

Further to this, I found they had updated flashplayer-11.2 r202.238 to 11.2 r202.243 and updated. I had to go past a very ugly notice on

NOTE: Adobe Flash Player 11.2 will be the last version to target Linux as a supported platform. Adobe will continue to provide security backports to Flash Player 11.2 for Linux.

Hmmph! Anyhow, it's a bummer - Uncaught error 2203. Libflashplayer is linked against 55 other libs (all present) not including the only other supplied lib /usr/lib64/kde4/ That one is linked against 70 libraries - all there. Putting that into the system gets me nowhere.

Can anyone on flash 11 play that video? Have you hal installed?

ljb643 10-24-2012 03:42 PM


You guys must have seen this one coming .
Looks like the same issue as

ponce 10-24-2012 04:14 PM

if you want to do a test, you can try building hal yourself: I tried it, to say the truth forcing my will (I don't like HAL, neither DRM and to debug Adobe's proprietary stuff too - if they like it closed, they can clean their messes themselves), but the flash plugin crashed when opening the drm test content (note that I haven't started hald).
Your local tv channel is not visible from my country.

I haven't gone further but hope the report can help.

business_kid 10-25-2012 04:44 AM

Thanks for the replies; @ljb643: Yes, it looks the same, to go by the page title, but the content is gone.

@ponce: I think Slackware-13.0 had hal - I remember a mouse issue at the time. So I can download a package. But I'd like to kick someone in Adobe where the sun doesn't shine first. They have Flash, have left it as a lousy platform for programmers to work with, and they are killing it.

EDIT: I've now tried in the following systems
1. Slackware64-14.0
2. Slackware-13.37 32 bit w/flash player 11
3. Fedora-17.0 with their alternative plugins
4. (Spit!) Windows Vista Business 64 w/

Of those, I get furthest in Slackware64 (as described).

business_kid 10-25-2012 09:19 AM

Well I installed hal-0.5.14 from Slackware-13.1, checking carefully that it wasn't stomping on anything important. It did overwrite /etc/dbus-1/system.d/hal.conf, but it overwrote it with the same file:).

I closed X, started rc.hald and restarted X and stuff just plays. Using Hal is just about the worst way anyone could choose for getting a library, when there's dozens of dependencies already coming in. Hal was for hardware, not software.

Flash needs hal for encrypted stuff. Case Closed.

What concerns me now is that if Adobe don't update this piece of <expletive deleted> like they have threatened, We'll be stuck with that as the system moves ahead in the 21st century.

cwizardone 10-25-2012 09:22 PM

hal-0.5.14-x86_64-3.txz and hal-info-20091130-noarch-1.txz from Slackware64 13.37 work well with Slackware64 14.0, and don't appear to interfere with anything else.

business_kid 10-26-2012 04:35 AM

How long are we going to be stuck installing that old failed project for a flash plugin that's probably buggy anyhow? Nothing gives more problems than flash.

cwizardone 10-31-2012 12:10 AM


Originally Posted by business_kid (Post 4814595)
...started rc.hald and restarted X and stuff just plays....

...Flash needs hal for encrypted stuff. Case Closed....

Yep. Since installing Hal from 13.37 (as previously mentioned) all my flash problems have disappeared. As you said, "...stuff just plays."

All times are GMT -5. The time now is 01:09 AM.