-   Slackware (
-   -   Flash Player Plugin 11 takes ages to load at some occasions (

VolvoxNo9 06-06-2012 11:40 AM

Flash Player Plugin 11 takes ages to load at some occasions

This is about the flash-player-plugin.
I am running Slackware32 13.37 on a Samsung R510-Aura T5750 Melroi laptop.
uname -a says #2 SMP Sat Apr 9 23:39:07 CDT 2011 i686 Intel(R) Core(TM)2 Duo CPU T5750 @ 2.00GHz GenuineIntel GNU/Linux

I built and installed the SlacklBuilds package of the flash-player-plugin for version, which is the newest this day.

The problem is, that this version sometimes starts to load for app. 20 seconds which it shouldn't. For example before playing a video or after playing a video or when resizing a video etc.
During this load time the whole opera/seamonkey browser is stuck and sometimes all other processes are stuck as well. Then I am forced to wait until it goes on.
Other problems: Sometimes after some key actions (which I couldn't figure out yet) the colors are somehow swapped too (like red-blue or something). Then when I open a terminal I can see the contents of the flash-plugin in front of the black terminal, which is wrong.

So obviously the whole flash plugin is broken. I had this with older versions of flash-player-plugin 11 already.

What can I do against this?
I don't want to install version 10 because there are security flaws.

Do you have this problem and how do you handle it?

If you need more information, I'm glad to help out!

Thanks in advance :)

T3slider 06-06-2012 08:07 PM

I googled quickly and it looks like your laptop has nVidia graphics, which was my guess. If it does *not* have an nVidia graphics card then ignore everything I say. A recent Flash 11 update broke hardware acceleration on nVidia cards so people looked like smurfs and videos would cover everything. You can disable hardware acceleration entirely by placing the following in /etc/adobe/mms.cfg:


Or see here which supplies a patch for the nVidia drivers (or more specifically libvdpau). This is really Adobe's fault, not nVidia's, and the requirement to patch vdpau is frankly insulting; however, since Adobe has proudly declared it is abandoning Linux, you have few options available. I don't know how the patch affects other applications but you can try it and hope for the best if you want to maintain hardware acceleration of Flash content (which would be a good idea on a laptop).

VolvoxNo9 06-07-2012 12:39 PM


Thank you for your help, but I'm afraid, I did something wrong, because all errors are still there.
I tried editing /etc/adobe/mms.cfg, but it didn't exist, so I created it freshly being root and rebooted.

Are the rights okay?

drwxr-xr-x 2 root root 4096 Jun 7 19:01 adobe

-rw-r--r-- 1 root root 55 Jun 7 19:02 mms.cfg

Is the content okay?

PHP Code:

bash-4.1# cat /etc/adobe/mms.cfg 


I have the feeling, that my new file was not looked up at all.

What did I do wrong?

EDIT: Yes, my graphics cards is a GeForce 9200M GS.

T3slider 06-07-2012 07:08 PM

I don't see anything wrong but just in case right-click on a flash video and make sure hardware acceleration is turned off in the settings. If it still doesn't work there's always the patch to try, but the above solution did work for me in Slackware 13.37 using Alien Bob's flashplayer-plugin package.

mats_b_tegner 06-08-2012 11:41 AM

On my system with a GeForce 9300M GS and nVidia 295.53, I have the following in /etc/adobe/mms.cfg:

in .bash_profile:

If I disable Hardware acceleration I get blue skin in flash videos

wadsworth 06-08-2012 01:11 PM

1 Attachment(s)
I also have the blue-tinted videos with Flashplayer 11.2.
(9600 GT and the 295.49 proprietary driver)

There's a good thread on the issue over at the Arch forums.

I used the work-around first mentioned in post #119...

I also modified the libvdpau script from
to apply a patch from git to bring libvdpau-0.4.1 up to commit 426251,
then apply the "fix" from the libvdpau mailing list.

I'll attach the SlackBuild. In case someone might find it useful.

It adds a configuration file (/etc/vdpau_wrapper.cfg) that shouldn't need any editing,
and requires the libvdpau-0.4.1 source tarball.

All times are GMT -5. The time now is 10:37 PM.