LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
 
Search this Thread
Old 08-01-2014, 06:22 AM   #1
WhiteHotLoveTiger
Member
 
Registered: Jun 2012
Location: NB, Canada
Distribution: Slackware
Posts: 71

Rep: Reputation: 2
Flash Debugger on Slackware64


Has anyone ever installed the Flash content debugger plugin on Slackware64 with either firefox or chrome?

I've got it running on 32-bit Slackware without too much trouble, but I'm having a heck of a time understanding how to get it working with nspluginwrapper. This stackexchange question is kind of helpful, but I'm getting stuck with the error:
Code:
nspluginwrapper: no appropriate viewer found
 
Old 08-01-2014, 07:15 AM   #2
ml4711
Member
 
Registered: Aug 2012
Location: Ryomgård, Danmark
Distribution: Slackware64
Posts: 101

Rep: Reputation: 61
Try using the -v option, and you see what is wrong!

Code:
nspluginwrapper -v -i /usr/local/src/libflashplayer.so
*** NSPlugin Viewer  *** ERROR: libssl3.so: cannot open shared object file: No such file or directory
*** NSPlugin Viewer  *** ERROR: libssl3.so: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/local/src/libflashplayer.so
For slackware64 14.1
You need at least seamonkey-solibs-compat32-2.26.1-x86_64-1_slack14.1compat32

And you also need to set up the library search path in /etc/ld.so.conf

/usr/lib/seamonkey

(remember to run ldconfig afterwards)

Code:
nspluginwrapper -v -i /usr/local/src/libflashplayer.so 
Install plugin /usr/local/src/libflashplayer.so
  into /home/morten/.mozilla/plugins/npwrapper.libflashplayer.so
Enjoy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] monodevelop-debugger-mdb (2.4) (Slackware64) bassplayer69 Slackware 1 10-09-2011 06:00 PM
[SOLVED] Slackware64 13.37 No Flash Sound marnold Slackware 1 04-28-2011 01:44 PM
slackware64 13.0 flash in konqueror without mozilla tjwoosta Slackware 8 05-27-2010 09:09 PM
32-bit firefox + flash on slackware64 zvzi Slackware 6 09-26-2009 12:55 PM
Flash Player 10 in Slackware64 gabim Slackware 20 06-02-2009 10:41 AM


All times are GMT -5. The time now is 09:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration