LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   First time using SBo-git - Dependency questions (https://www.linuxquestions.org/questions/slackware-14/first-time-using-sbo-git-dependency-questions-4175693214/)

firefli 04-06-2021 11:35 AM

First time using SBo-git - Dependency questions
 
Hi

I want to install darktable from Ponce's repository at https://github.com/Ponce/slackbuilds...darktable.info but I am getting issues with packages not being available when trying to process
the queue file generated with sqf. A couple of the packages are in the slackpkg reposiory and the rest are in Ponce's github. I am running Slackware current and have the sbopkg.conf file set up with the two variables needed (
### REPO_BRANCH=${REPO_BRANCH:-14.2}
### REPO_NAME=${REPO_NAME:-SBo}
REPO_BRANCH=${REPO_BRANCH:-current}
REPO_NAME=${REPO_NAME:-SBo-git}
)

Any hints to fix or point out what I am doing wrong?

Thanks!

Here is what I did.

sqf -p darktable

Doing a cat of the queue gives this:
---------------------------------------------------------
cat /var/lib/sbopkg/queues/darktable.sqf
pugixml
lensfun
json-glib
darktable

---------------------------------------------------------




But when I try to process the queue file I get this:
---------------------------------------------------------
sbopkg -k -i darktable
Both a queuefile and a package were found with the name "darktable".

Use (Q)ueuefile, (P)ackage, or (A)bort?: q

The following packages cannot be found
in the currently active repository
(SBo-git/current) and have been skipped:

lensfun
json-glib

(Y)es to continue processing or (N)o to stop?:
---------------------------------------------------------

However the two packages lensfun and json-glib are already installed but not by sbopkg but by slackpkg

---------------------------------------------------------

slackpkg file-search lensfun

Looking for lensfun in package list. Please wait... DONE

The list below shows the packages that contains "lensfun" file.

[ installed ] - lensfun-0.3.95-x86_64-3

You can search specific packages using "slackpkg search package".

slackpkg file-search json-glib

Looking for json-glib in package list. Please wait... DONE

The list below shows the packages that contains "json-glib" file.

[ installed ] - vala-0.52.0-x86_64-1
[ installed ] - json-glib-1.6.2-x86_64-2

You can search specific packages using "slackpkg search package".
---------------------------------------------------------

drumz 04-06-2021 11:44 AM

I'm not a user of -current, but I think I can answer your question:

Some of the dependencies included by sqf (lensfun and json-glib) are now a part of Slackware. Thus, you need to manually remove them from the sqf file. Honestly I can't remember if Ponce's repository is supposed to remove deps from REQUIRES when they are added to Slackware-current or not.

ponce 04-06-2021 11:46 AM

it's explained in the wiki's homepage

https://github.com/Ponce/slackbuilds/wiki

bassmadrigal 04-06-2021 12:48 PM

Quote:

Originally Posted by drumz (Post 6237820)
Honestly I can't remember if Ponce's repository is supposed to remove deps from REQUIRES when they are added to Slackware-current or not.

As stated in the wiki that ponce linked to, he doesn't remove dependencies that have been added to -current from the REQUIRES line. The reason, as has been stated in his thread a few times, is that it would require a much larger effort to update the unofficial repo each week as SBo's public updates are pushed.

firefli 04-06-2021 12:50 PM

Hi drumz

Ok, removing the packages from the queue file worked. I'll reread Ponce's wiki in a bit.

@bassmadrigal OK, Thanks - makes sense now.

Thanks!


All times are GMT -5. The time now is 02:30 AM.