LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-24-2017, 02:11 PM   #1
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 302

Rep: Reputation: 53
Firefox won't start after upgrade Slackware64 current


After the latest upgrade slackware64 current Firefox will not start.

I did the normal slackware update. then install-new, then upgrade- all. This is the error when I ran it from terminal.

XPCOMGlueLoad error for file /usr/lib64/firefox-52.1.2/libxul.so:
/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.23' not found (required by /usr/lib64/firefox-52.1.2/libxul.so)
Couldn't load XPCOM.

I have searched the net for a couple of days with no success so far. there are several problems with this
error on Ubuntu64 but no info on slackware.

Last edited by zrdc28; 05-24-2017 at 02:16 PM. Reason: addon
 
Old 05-24-2017, 02:20 PM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,837

Rep: Reputation: Disabled
I think you haven't done a full upgrade: if you got multilib be sure to upgrade that too and check /etc/slackpkg/blacklist
 
Old 05-24-2017, 06:07 PM   #3
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 969

Rep: Reputation: 460Reputation: 460Reputation: 460Reputation: 460Reputation: 460
What mirror did you use?
 
Old 05-24-2017, 06:19 PM   #4
hitest
Guru
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 5,813

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
Everything working fine here on Slackware64-current. I suggest that you try out the ideas listed by the previous posters.
Attached Thumbnails
Click image for larger version

Name:	firefox.png
Views:	28
Size:	137.9 KB
ID:	25102  
 
Old 05-24-2017, 08:11 PM   #5
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 302

Original Poster
Rep: Reputation: 53
I have this same problem on 2 different machines. I am using the multilib from alien and do not know how to upgrade it, I did not uncomment the last 13 on the list below due to the fact that I got them from alien. Will it upgrade from sbo if I uncomment them or do I need to go back and upgrade from alien?


http://ftp.osuosl.org/.2/slackware/slackware64-current/ was the mirror i used 2 times and the ga
mirror one time.

Blacklist below
kernel-firmware
kernel-generic
kernel-generic-smp
kernel-headers
kernel-huge
kernel-huge-smp
kernel-modules
kernel-modules-smp
kernel-source
[0-9]+_alien
[0-9]+compat32
glibc
gcc

glibc
glibc-i18n
glibc-profile
glibc-solibs
glibc-zoneinfo
gcc
gcc-g++
gcc-gfortran
gcc-gnat
gcc-go
gcc-java
gcc-objc
 
Old 05-24-2017, 08:28 PM   #6
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 969

Rep: Reputation: 460Reputation: 460Reputation: 460Reputation: 460Reputation: 460
You need slackpkg+
https://github.com/zuno/slackpkgplus/

Then in /etc/slackpkg/slackpkgplus.conf put:
PKGS_PRIORITY=( multilib )
MIRRORPLUS['multilib']=http://bear.alienbase.nl/mirrors/people/alien/multilib/current/

Then:
slackpkg update gpg

Then you will have to remove/comment the blacklisted files and update.
 
Old 05-24-2017, 11:04 PM   #7
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,837

Rep: Reputation: Disabled
Quote:
Originally Posted by zrdc28 View Post
I am using the multilib from alien and do not know how to upgrade it
you can follow the same instructions that you have followed for installing it

http://www.slackware.com/~alien/multilib/
 
Old 05-25-2017, 11:37 AM   #8
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 302

Original Poster
Rep: Reputation: 53
At about 3 am this morning I got the first one to upgrade and everything seems to be working,
Firefox and Thunderbird both work as they should. I followed the guide from RadicalDreamer above
and everything is working on both computers. I sure appreciate the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] slackware64-current, recently Firefox won't play most HTML5 video af7567 Slackware 2 10-03-2016 09:02 AM
[SOLVED] Slackware64-current and Firefox-48.0 3rensho Linux - Software 5 08-10-2016 01:36 AM
[SOLVED] libtdb.so.1 No such file or directory, PulseAudio won't start slackware64-current adennis Slackware 10 03-28-2016 03:09 PM
VirtualBox won't run after upgrade to slackware64 current Ook Slackware 9 06-18-2011 07:13 AM
[SOLVED] X Fails To Start After Upgrade to Slackware64-current hkothari Slackware 7 03-06-2010 09:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration