-   Slackware (
-   -   firefox update problem -- sw13.37 (

worsel 03-30-2013 09:09 PM

firefox update problem -- sw13.37
I've been working this for some time now. I use SW14.0 most of the time, so
firefox not working on 13.37 is not a high priority. Still, some software
does not run on 14.0 (can you spell xtrkcad?) :)

Problem: The original firefox on 13.37 works fine. After 14.0 came out and a new update
on 13.37, the new version of firefox would come up on the screen, but would time out
on any URL (except files on the system). No error messages except the time out message.

Curiously seamonkey works just fine and firefox appears to be link to seamonkey.
Also thunderbird works ok.

Googling gives no clue and I've found nothing in the manual. Would someone be so kind as
to give me a clue as to what is going on here?


camorri 03-31-2013 08:38 AM

I'm running FF version 19.0.2 from the slack mirrors. It works just fine.

How did you install the new version of FF on 13.37? How many versions of FF do you have on the system?

I just ran an update, no new FF version, so I believe 19.0.2 is the latest on the mirrors.

worsel 04-02-2013 04:43 PM

I run just one version of firefox at a time. I install another version by downloading from a Slackware repository patch directory and
doing "upgrade *.txz". The original firefox is, of course, available from the installation disk. 19.02 is currently installed.

By the way, I forgot to mention that I use the 32 bit Slackware.

camorri 04-03-2013 08:15 AM

I don't know what the differences might be between the patch directory, and updating 'slackpkg update-all'.

FWIW, I'm running FF 19.0.2 on both 64 bit Slack 13.37 and 32 bit Slack 14.0. No issues on either.

Have you tried disabling all extensions? Have you created a new profile for FF and tried that? Just some thoughts.

worsel 04-05-2013 09:23 PM

The problem seems to be in my bookmarks. I removed them completely and firefox started working again.
I'm now in the process of rebuilding them. Thanks for the suggestions, Cliff.

onebuck 04-06-2013 09:51 AM

Member response

Firefox version 20 is the up to date version for Slackware. Look in the 'slackware64-version/patches/packages/' or for x86_32 'slackware-version/patches/packages/'directory for the mozilla Firefox & Thunderbird packages.

worsel 04-11-2013 08:40 PM

I'm marking this as solved, even though I can't imagine why the bookmarks would cause the problem.
Thanks for the suggestions and pointers.


All times are GMT -5. The time now is 04:37 AM.