LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-13-2020, 08:09 PM   #1
The_Dark_Passenger
Member
 
Registered: Apr 2018
Distribution: Slackware64 14.2 & -Current
Posts: 78

Rep: Reputation: Disabled
Firefox interface performance issues with NVIDIA


Hello,

I recently purchased a workstation that included an NVIDIA Quadro P2000. I've installed Slackware64 -current on it, and ensured it is up to date. I installed the latest, short-lived NVIDIA proprietary driver from their site. The NVIDIA DRM module fails to build. However, I proceeded to install it with the --no-drm option.

The driver seems to be working and is providing OpenGL acceleration via the nvidia driver in X. I see everything appears ok in the NVIDIA driver settings.

However, I'm having an issue with Firefox's interface performance. And I'm also having an odd issue where my forward/back mouse buttons don't work all the time.

Regardless of if I force enable OpenGL or WebRender hardware acceleration or not, the Firefox interface is very laggy. The transistion animations begin, but essentially stop, and it just transitions to the next menu in the FF interface in a jerky way.

This does not effect the page content. Web pages are very smooth, and even more so with OpenGL force enabled.

Also, the forward and back buttons on my mouse only intermittently work in Firefox. If I press the software back button in Firefox, then try to use the mouse buttons they work navigating between the two pages. However, if I navigate to a new page, they only sometimes work after hitting the back button on the mouse 5-10 times.

The Firefox version is the latest 78esr included with Slackware64 -current.

What could be causing this, and is there a solution?

Any help is appreciated?
 
Old 09-14-2020, 01:18 AM   #2
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 3,011

Rep: Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075
You might want to experiment with the options "Force Composition Pipeline" or "Force Full Composition Pipeline" available in the "nvidia-settings" app.

It might be worthwhile to learn if and how these options might apply to you (quoted from my xorg.conf file)

Code:
## excerpt from xorg.conf
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1070 Ti"
    Option         "Coolbits" "13"
   # Option     "UseEdidDpi"   "false"
    Option          "TripleBuffer" "On"
    Option     "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1"
EndSection
As for your mouse, mice also can benefit from specifics in xorg.conf, especially the number of buttons in use. BTW the order in which they are listed is somewhat critical. Buttons #4 and #5 MUST be listed at the end of the sequence for proper, stable behaviour.

Example - Option "ButtonMapping" "1 2 3 6 7 8 9 4 5"
 
Old 09-14-2020, 02:41 AM   #3
The_Dark_Passenger
Member
 
Registered: Apr 2018
Distribution: Slackware64 14.2 & -Current
Posts: 78

Original Poster
Rep: Reputation: Disabled
Thank you for your reply! I have ensured that force full composition is enabled across all displays. However, the issue persists. I had used this mouse without issue on my previous workstation without having to add any entry to the X config. However, I will check into it. Thanks again!
 
Old 09-14-2020, 12:21 PM   #4
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 3,011

Rep: Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075
It may be important to remember that Xorg is something of a hodge-podge patchwork quilt and some would add "doomed" as an adjective. We really can't judge function by past iterations because it is always changing as are the sub-routines underneath it such as mouse control. It may help to spend some time analyzing Xorg.0.log. Depending on how you launch X it might be useful to increase verbosity thusly

Code:
  startx -- -logverbose 6
If you auto-log directly to X, you will either have to "killall X" or add a ":2" to the above command to start a new instance on TTY 2.
 
Old 09-14-2020, 01:15 PM   #5
GPGAgent
Member
 
Registered: Oct 2018
Location: Cornwall UK
Distribution: Mint 20 xfce 64bit
Posts: 468
Blog Entries: 2

Rep: Reputation: 57
Arm will sort this out! Hehehehe!
 
Old 09-15-2020, 04:29 AM   #6
The_Dark_Passenger
Member
 
Registered: Apr 2018
Distribution: Slackware64 14.2 & -Current
Posts: 78

Original Poster
Rep: Reputation: Disabled
Thank you everyone for your replies! After further tinkering around, I discovered that this issue was caused by the "Allow Flipping" option being enabled in the NVIDIA settings. Since disabling that, the Firefox interface performance has greatly improved! The mouse is also working better. However, I still sometimes have to hit the mouse button twice. This only seems to happen in Firefox. Other applications appear unaffected. What could be causing this?
 
Old 09-15-2020, 10:06 PM   #7
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 3,011

Rep: Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075
Quote:
Originally Posted by The_Dark_Passenger View Post
Thank you everyone for your replies! After further tinkering around, I discovered that this issue was caused by the "Allow Flipping" option being enabled in the NVIDIA settings. Since disabling that, the Firefox interface performance has greatly improved! The mouse is also working better. However, I still sometimes have to hit the mouse button twice. This only seems to happen in Firefox. Other applications appear unaffected. What could be causing this?



Smooth Scrolling in Preferences???
 
Old 09-17-2020, 03:44 AM   #8
Fat_Elvis
Member
 
Registered: Oct 2016
Distribution: FreeDOS 1.2
Posts: 299

Rep: Reputation: 90
Quote:
Originally Posted by The_Dark_Passenger View Post
However, I still sometimes have to hit the mouse button twice.
In what context?

You said that this only happens in Firefox, so I am assuming it is not a hardware, driver, or X11 problem.

Try the xev(1) program. Does it register your clicks every time?

Last edited by Fat_Elvis; 09-17-2020 at 03:46 AM.
 
Old 09-17-2020, 03:54 AM   #9
Fat_Elvis
Member
 
Registered: Oct 2016
Distribution: FreeDOS 1.2
Posts: 299

Rep: Reputation: 90
Firefox has been doing really well for a good long while, but it seems that they can't help but revert to the same old, same old. No matter how many programming languages they invent. Ugh.

I have switched to AMD on my main machine some years ago, but Nvidia drivers are usually very solid. However, the more commonplace your hardware, the better. Since you have a Quadro, I'd also check on the Nvidia specific forums.

Quote:
Originally Posted by enorbet View Post
You might want to experiment with the options "Force Composition Pipeline" or "Force Full Composition Pipeline" available in the "nvidia-settings" app.

It might be worthwhile to learn if and how these options might apply to you (quoted from my xorg.conf file)
I agree with the first two, but are you sure you want to force Triple Buffering?
 
Old 09-17-2020, 10:31 AM   #10
cwizardone
LQ Guru
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 5,879
Blog Entries: 1

Rep: Reputation: 3199Reputation: 3199Reputation: 3199Reputation: 3199Reputation: 3199Reputation: 3199Reputation: 3199Reputation: 3199Reputation: 3199Reputation: 3199Reputation: 3199
Did you try the latest "Long Lived" driver?
It is considerably newer than the "Short Lived" driver.

Quote:
Version: 450.66, Release Date: 2020.8.18
Version: 435.21, Release Date: 2019.8.29
https://www.nvidia.com/en-us/drivers/unix/

Last edited by cwizardone; 09-17-2020 at 10:43 AM.
 
Old 09-19-2020, 07:21 PM   #11
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 3,011

Rep: Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075Reputation: 3075
Quote:
Originally Posted by Fat_Elvis View Post
Firefox has been doing really well for a good long while, but it seems that they can't help but revert to the same old, same old. No matter how many programming languages they invent. Ugh.

I have switched to AMD on my main machine some years ago, but Nvidia drivers are usually very solid. However, the more commonplace your hardware, the better. Since you have a Quadro, I'd also check on the Nvidia specific forums.

I agree with the first two, but are you sure you want to force Triple Buffering?
Triple Buffering is indeed complicated and more importantly is use case sensitive but in most of what I do, a fairly high percentage of gaming, it works for me. It most often performs better than vsync though I'm sure I will have to reevaluate whenever I manage to get a "real" monitor. I'm currently using a cheap Vizio SmartTV that despite advertising lies (actual class action suit lies), only really does 60Hz refresh. I lust for a 144Hz

I should mention that I'm not upset with Vizio very much. I despise advertising deception but I got essentially what I paid for in the long run at base - long lasting high quality graphics with no camera or microphone surreptitiously wedged in, and TV apps that have proved surprisingly useful. It's good enough it's making it hard to justify the massive increase in bux for faster refresh, response time, and higher resolution than 1080p, but things have changed rather drastically since Covid19 and I spend more time on my PC

Oh yeah, here is a decent discussion on Triple Buffering in Nvidia forums >>>>>>>

https://www.nvidia.com/en-us/geforce...-can-anyone-e/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Performance issues in updating from Centos 7.2 to 7.4; plus performance monitoring issues! alex3857 Linux - Server 2 11-21-2017 06:23 AM
[SOLVED] Kdenlive performance issues on Fedora 26 Gnome with Nvidia Quadro K600 Superspeed500 Linux - Software 0 10-18-2017 06:45 AM
Driver fails using nvidia for OpenGL interface but works using Mesa OpenGL interface rrrssssss Gentoo 9 01-03-2010 10:19 AM
Nvidia GeForce 4 MX 440 poor performance nvidia glx drivers jollyjoice Linux - Hardware 7 06-07-2006 09:02 AM
Performance issues with Nvidia 6800 zhangmaike Linux - Hardware 8 11-01-2004 02:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration