-   Slackware (
-   -   firefox doesn't show up properly when run remotely through ssh -Y (

nass 04-03-2012 12:02 PM

firefox doesn't show up properly when run remotely through ssh -Y
1 Attachment(s)
Hello everyone,
I am trying to work on a remote firefox sessions but can't seem to load it properly.
the scenario is the following:
2 slack pc's 13.37 (not current!)
both are full installations.
both running in runlevel 3 (no X on startup).
both headless.

in one machine i am running a tightvnserver and connect to it.. this is as 'local' as this machines can become to me.
I am running blackbox on the vncserver of the local machine.
through that session, I can run properly the firefox binary from the local machine.

but if I ssh -Y to the remote machine and ask for firefox to show up on my local machine, I only get an empty window (see screenshot.

I have tried running firefox -no-remote but I get the same output.
I also have tried other WMs like xfce (the screen shot is from that) and kde, but I get the same problem.

xlogo of course shows up perfectly on my local machine, so it must be smth else.. some library perhaps?
anyone ever came across this?

thank you for your help

allend 04-03-2012 07:21 PM

Not actually an answer to your question, as I do not have one. This just works for me, although there can be long delays. Are you sure that there is a problem? Perhaps you need to be more patient.
However I have found that I get much better performance by running the browser locally using a SOCKS proxy.

nass 04-04-2012 08:05 AM

Thank you, but this is not what I am trying to do here (surf privately that is)

I merely wanted to pick up on a firefox session from another pc. I thought the easiest thing to do (instead of installing vnc server on that pc) was to get its window doing an ssh -Y on that pc..
but for some reason the window is not drawn properly...

It seems really odd, I mean if it was a library thing, I assume not even the local (to vnc server) firefox binary wouldn't run. but this one does run fine.

jmccue 04-04-2012 09:03 AM

Is one of the systems on a virtual machine ? If so doubt I can help, but between 'native' Linux and BSD machines I have no issues with executing Firefox via X forwarding. Usually I use ssh -X -Y.

But, is Firefox already executing on your local machine ? I have noticed odd things happen when you X forward a remote Firefox session. Seems it executes the local Firefox instead. Maybe with a VM running on windows (so I assume from your tag :)) strange things happen if the MS version of Firefox is already executing.


allend 04-04-2012 09:28 AM

Did you try the SOCKS proxy technique before you dismissed my answer as inappropriate? The technique has broader application than merely surfing privately. It is a cleaner and more efficient solution than using VNC.
I use it so regularly for connecting to a remote Slackware server so that I can then connect via VNC to clients on a LAN that I actually dedicate the SeaMonkey browser to the task.

mrclisdue 04-04-2012 09:37 AM

Do other remote X apps draw properly? Does Konqueror draw web pages properly? Is the remote firefox app proxied through squid, polipo, privoxy (ie something that might be slowing down the packet transfer?)


nass 04-04-2012 09:46 AM

what you see in the screnshot is a vncviewer session, john. not a virtual machine.

if i were sitting in front of a linux session in a local pc with its own kbd/mouse/screen, i can do ssh -Y and i won't have any problem.
but as im connecting from a win pc (through vnc) to a linux vnc server session. from there if i ssh -Y to a 3rd machine I can't get firefox to open up properly.

Also no, i don't open 2 sessions of firefox, one local to the vnc server and one remotely , so as to avoid complicating things in ways I can't control. - I know of the problem you are talking about, one way to avert that is to run your firefox sessions with the "-no-remote" option.

nass 04-05-2012 05:07 AM

mrclisdue, i tried a few applications.
konqueror, gimp, gwenview,gftp - they all show up fine.. only firefox does not.

there is a squid installation that might reduce speed but i've waited long enough for the windows to get drawn - besides i can't even see the firefox toolbars (its not only the webpage that is missing)..

So i take it I could call this a bug and contact mozilla?

EDIT: xlogo works too :P

nass 04-05-2012 07:24 AM

Allend , i have overlooked the post and missed you 2nd post.
Could you please explain what you do , because it was not very clear to meQ

you open a socks tunnel through ssh. I got this far.
what do you use this tunnel for?

It appears to me (according to alienBob's howto) that the socks tunnel is good for surfing through another node.

I am not sure how you connect to the remote pc (an X session) and from there connect toother computers in that LAN through vnc.

allend 04-05-2012 10:15 PM

The steps are:
1. 'ssh -Y -p<port number if not standard port 22> -D<SOCKS proxy port (8888 in the example)> <user>@<remote host>'
2. Start the browser on the local PC and configure the proxy settings. (In SeaMonkey: Edit -> Preferences -> Advanced -> Proxies and set Manual proxy configuration. Hit the Advanced... button and set the Generic Proxy settings).
3. In the browser address bar type 'http://<client IP address>:5800' or whatever port you are using for VNC if not 5800.

nass 04-06-2012 08:06 AM

Hm, i had completely forgot about the ability of vnc to show up on your browser.
I did try it (where I could) but the problem with the browser is still there..
Basically instead of using the vnc viewer I used your suggestion but this is just another way of accessing the same vnc server. so when tryingto access another slack server through that, (using ssh -Y) i still get the same problem.

If i were to replace the ssh -Y with a vnc session, then I'd have to setup the vnc server on that other computer. and I was trying to avoid that, since it's basically 2 slackware pc's talking to each other.

I'm curious though, you do what exactly. on your local pc (linux or win) you set up an ssh -D session to you remote slackserver. and you use local seamonkey (in the local computer that is) binary as a vnc viewer. once you connect to that serer, how do you access the rest of that server's local network?

allend 04-06-2012 10:57 AM

Perhaps I should describe my topology better.
Home desktop (local) running Slackware -> Remote server running Slackware -> Windows clients (running VNC server service)
The connection steps are as per post #10

I have also demonstrated that I can do
Laptop running Slackware -> Home desktop running Slackware -> Remote server running Slackware -> Windows clients (running VNC server service).
On the laptop I use 'ssh -Y -L<SOCKS proxy port>:<remote server>:<SOCKS proxy port> <home desktop>' and use the local browser configured to use the SOCKS proxy.

I think you need to understand that the SOCKS proxy is created at the other(remote) end of the SSH tunnel.

As to accessing the rest of the network, the SSH terminal window is available for use.

nass 04-06-2012 11:09 AM


I think you need to understand that the SOCKS proxy is created at the other(remote) end of the SSH tunnel.
Well this bit i know:)

it is clear to me now that you run vnc servers on all you win clients.

Of course if I do that I can use the socks tunneling to connect to the remote machine through a browser used as vncviewer.
But the catch is in avoiding to install vncservers in all the machines.

I tried utilising 1 vnc in an intranet to access another slack machine beghind the slack machine .
I had to options ssh -Y or Xnest ( there is no reason for the socks option if there is no vnc server running.. behind the vnc server i have already accessed, right? ).

It all boils down to having several ways to do what you want - thats linux. I raised the question not because i don't have a way to do what I want, but because one of these ways failed :)

All times are GMT -5. The time now is 11:04 PM.