LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Firefox, current and X locking? (https://www.linuxquestions.org/questions/slackware-14/firefox-current-and-x-locking-4175656912/)

garpu 07-05-2019 08:31 AM

Firefox, current and X locking?
 
I've had an issue recently with current, Firefox, and X locking (causing me to have to reset.) I'm using the nvidia blob (430.26.) It's happened twice in about 3 weeks. Both times I was doing nothing else than surfing with firefox. (No games or compilations in the background.) I've run memtest, and it was fine.

I haven't been able to reproduce it reliably, either. But I noticed that when mousing over web pages (using my logitech USB m705 mouse), sometimes firefox will not respond for a second or two or lock X altogether. Tabs open were tweetdeck, gmail, and discord's web client. This time this morning I had open a google document, as well.

1.) Did I screw something up? There's nothing in syslog, messages, dmesg, or debug.

2.) I've noticed tweetdeck in firefox is causing similar hangs lately, but usually not the kind that cause everything to hang. (usually the ublock add blocked count is over 2000.)

3.) I'm able to game without issues. I was having some stuttering in Path of Exile, but Firefox was open behind it and it does that from time to time. No stuttering or lags in Guild Wars 2, even on a world boss.

4.) Using chrome for a bit (I'd rather not...) in the interest of testing to see if the lockup happens there.

5.) I don't think I'm missing any updates. I ran install-new, and install multilib again just to make sure I hadn't missed anything.

garpu 07-05-2019 10:39 AM

I think the first lock up happened on 6/25, after the mesa update. I did uninstall/reinstall the Nvidia driver after updating, though. (Like I do after every kernel update, too.) Related?

cwizardone 07-05-2019 01:36 PM

That has happened to me twice while streaming video from Amazon in Firefox-esr. It has yet to happen with the most recent kernel, 4.19.57.

garpu 07-05-2019 01:58 PM

I'm on 4.19.57, and it just did it to me again. I was recording OBS (desktop and soffice, just to make sure a bug I was having with the keyboard and a game not working with OBS was a bug with the game, and not anything else.) I stopped the recording, alt-tabbed away from OBS, then alt-tabbed back, and everything locked up. I wasn't using Firefox, though. I had chrome (most recent version) open, soffice, and OBS.

Nvidia driver issue? I'm using 430.26.

Nothing in any logs again. No errors in Xorg.0.log, either.

I'll try dorking with OBS to try to reproduce.

garpu 07-05-2019 02:04 PM

Restored my browser and I had discord up when things crashed. 1st time I had this (6/25), I was using discord. This morning, I was chatting in discord (text) when things crashed.

TheRealGrogan 07-05-2019 02:23 PM

I don't really have an solution, but lockups are tricky. Often what we attribute to being the cause, is itself a symptom.

Case in point, some months ago I was blaming browsers (Vivaldi) for some black screen hangs (needing hard boot) I was having, but it was happening with Firefox too. I didn't have to be doing anything in the browsers. It never happened while gaming, while everything was juiced. What would be in use if I'm not gaming? That's right, web browers would be open. Then I started thinking it was line voltage drops causing the problem when the GPU was in low frequency. That was just a coincidence that I noticed a voltage drop on my UPS's voltmeter a few times, it wasn't causing a problem.

The real problem turned out to be gkrellm contantly probing sensors. I'm not sure if it was the amdgpu sensor, or those belonging to the legacy it87 driver I need for my board (which I heard was difficult to maintain these days). Anyway, on a hunch I learned to live without gkrellm and the problem immediately stopped and didn't happen again, not once. I can use it for CPU, memory, storage etc. but I don't let it poll temperature, fan or any voltage sensors anymore. I just type sensors occasionally if I want to instantaneously check.

Mentioning that just in case you are doing something like that too.

garpu 07-05-2019 02:29 PM

I thought about it being a video card issue. It and my sound card are the only two pieces of hardware from my old (now dead) computer. And, yeah, I was doing relatively little, comparatively speaking. In the past two weeks I've compiled an awful lot of things without an issue and done a lot of gaming. It's when I'm just surfing that there's an issue. It also looks like 430.26 is having some issues with lockups...

garpu 07-07-2019 12:07 AM

So I had another lock up tonight while doing relatively nothing. (Reading an article on firefox.)

I'm going with the assumption that it's a video card issue, so I read through the document on installing the Nvidia blob, and realized I'd never blacklisted the nouveau driver by installing xf86-video-nouveau-blacklist. I installed that, then reinstalled the Nvidia driver.

I thought failing to blacklist the nouveau driver would only make the Nvidia driver fail? I didn't think one could even have both installed?

TheRealGrogan 07-07-2019 03:21 PM

Sure both would be installed, if nouveau is enabled in kernel (which it would be in a distro kernel). Did you notice if the nouveau kernel module was loading (lsmod) before you blacklisted it? Always a step in the right direction to blacklist it, if using the nvidia driver though.

Now, you'll just have to wait and see if it happens again. That's another thing with that type of problem, often I'll think it is solved but it just hasn't happened again in that time :-)

garpu 07-07-2019 03:36 PM

I didn't notice if it were loaded...honestly, it's a task I only do once every few years when I reinstall Slackware, so it's easy to forget.

We'll see. It seems like problems with X crashing are usually a matter of waiting for something to fail, and then going "Yep, that's what caused it."

My partner's box was locking up, as well, but he's on Windows. ;)

frankbell 07-07-2019 07:51 PM

Have you looked in the log files? If it's the display locking up, I'd try /var/log/Xorg.0.log; if it's the computer, I'd start with /var/log/messages.

Because of logrotate, you may need to look back into older log files and grep for the date in question; it might also help to pipe the result into a file that you can look at in a text editor. For example:

Code:

cat /var/log/messages.1 | grep "Jul  6" > somefile.txt

garpu 07-08-2019 09:08 PM

OK, just happened again. AC wasn't running (thought maybe power shorting things out) Found this right before the crash:

Code:

Jul  7 00:56:08 zdeno dbus-daemon[5045]: [session uid=1000 pid=5043] Activating
service name='ca.desrt.dconf' requested by ':1.41' (uid=1000 pid=5840 comm="fire
fox ")
Jul  7 00:56:08 zdeno dbus-daemon[5045]: [session uid=1000 pid=5043] Successfull
y activated service 'ca.desrt.dconf'

Coincidence?

TheRealGrogan 07-08-2019 09:28 PM

Those won't cause your lockups, nor are they actual errors. It's informing you that it has to start the dconf service, probably because it has to write to the dconf database. That is something that is loaded on demand (only needed to write).

garpu 07-08-2019 09:47 PM

So, coincidence. :/ Guess tomorrow I swap out the video card to a spare and see if it still locks. Doesn't really make sense to me, if it is the card, that it would lock when nothing (relatively speaking) is going on, and not lock during graphically-intense things.

TheRealGrogan 07-08-2019 10:55 PM

It probably isn't a hardware fault on your video card itself (I'm guessing, hoping), though swapping it may change the behaviour if it's at all related.

Another thing to consider, is PCI Express link state power management (ASPM). You can try booting with that disabled.

To your kernel command line, try adding:

Code:

pcie_aspm=off


All times are GMT -5. The time now is 05:29 PM.