-   Slackware (
-   -   firefox 18.0.2 and flashplayer at slackware14 (

madslackw 02-10-2013 07:22 PM

firefox 18.0.2 and flashplayer at slackware14
hi everyone

i've installed Slackware 14 64 bits and i've installed also firefox 18.0.2. the problem is that firefox web pages keep complaining about flashplayer. i have at /usr/lib64/mozilla/plugins, but is it as libflashplayer was not there. By the way, i installed also opera, and it looks for libflashplayer at the "right place", so i have no problems there. Can anyone help me ?

Thanks in advance

jmccue 02-10-2013 08:00 PM

Assuming it is not a 64/32 bit mismatch seems firefox needs it executable so maybe do a chmod 555. You can use file(1) to determine type.

If that does not work try and copy it to ~/.mozilla/plugins and chmod it.


TommyC7 02-10-2013 08:14 PM

Hi madslackw,

Can you try this and tell us if it works:
(I'm also assuming it's not a 32/64 mismatch).

mkdir -p $HOME/.mozilla/plugins && ln -s /usr/lib64/mozilla/plugins/ $HOME/.mozilla/plugins
That's what I do with flash personally. I have it installed into /opt/adobe-flash/lib$BUILD_LIB_SUFFIX/ so I just symlink it to the proper $HOME directory depending on the browsers used by the individual users.

ml4711 02-11-2013 04:32 AM

I had to set this variable to get firefox find the plugins.


export MOZ_PLUGIN_PATH=/usr/lib64/mozilla/plugins/

madslackw 02-11-2013 07:01 PM

hi everybody

unfortunately, none of the solutions the way, i tried also opera, and everything seems ok, and the plugin was at the same location -> /usr/lib64/mozilla/plugins

madslackw 02-11-2013 07:21 PM

just one more thing

i think this problem is related just to firefox, because i have no problems with opera or seamonkey...because they also point to /usr/lib64/mpozilla/plugins and i have no problems; another thing is firefox isn't detecting java, but seamonkey and opera point it to the right path

barw 02-12-2013 12:34 AM

Howdy madslack.

Once you said that you installed the firefox and after what everyone said. I'm assuming that your firefox is 32.

Please check such opening the browser and typing: about:buildconfig

Below the Build Platform, you gonna see that target and it'll probably be i686.

Please download the x86_64 browser, you can find it on:

Or go the mozilla website download the 32, check the mirror and navigate 'till the x86_64 for another mirror.

My friend had similar issue and we solved downloading the 64version. Please follow the steps above and i'm pretty sure it'll help :)


madslackw 02-12-2013 04:48 AM

hi barw

i thought i mismatched the right vbersion of firefox, but after typing "about:buildconfig", the result was :

Build Machine


Built from
Build platform


Build tools
Compiler Version Compiler flags
/tools/gcc-4.5-0moz3/bin/gcc gcc version 4.5.2 (GCC) -pedantic -Wall -Wpointer-arith -Wdeclaration-after-statement -Werror=return-type -Wtype-limits -Wempty-body -Wno-unused -Wno-overlength-strings -Wcast-align -Wno-long-long -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe -DNDEBUG -DTRIMMED -g -fprofile-use -fprofile-correction -Wcoverage-mismatch -O3 -fomit-frame-pointer
/tools/gcc-4.5-0moz3/bin/g++ gcc version 4.5.2 (GCC) -pedantic -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Werror=conversion-null -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -Wno-long-long -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -fprofile-use -fprofile-correction -Wcoverage-mismatch -O3 -fomit-frame-pointer
Configure arguments

--enable-update-channel=release --enable-update-packaging --enable-official-branding --enable-stdcxx-compat --enable-warnings-as-errors

so, i'm trying to look for another cause to this problem...

anyway, thanks for your reply

madslackw 02-12-2013 07:03 AM

hi everyone

after a google search, i found a brasilian site , where the guy says to make a new directory named "plugins" inside the firefox, and put the plugin inside

So, as root, inside firefox directory i typed:

root@asus:cd /usr/lib64/firefox
root@asus:mkdir plugins
root@asus:ln -s /usr/lib64/mozilla/plugins/

i also typed , also inside /usr/lib64/firefox/plugins :

root@asus:ln -s /usr/lib64/java/jre/lib/amd64/

and i also solved my java problem, because firefox wasn't detecting java.

I don't know if it's a odd solution, but now everything it's working fine.

Thanks everyone for all your answers and tips.

brianL 02-12-2013 09:19 AM

Why don't you use the "official" Slackware Firefox 18.0.2? It was updated on the 6th of February. From the Changelog:

Wed Feb 6 07:14:25 UTC 2013
patches/packages/seamonkey-2.15.2-x86_64-1_slack14.0.txz: Upgraded.
This is a bugfix release.
patches/packages/seamonkey-solibs-2.15.2-x86_64-1_slack14.0.txz: Upgraded.
patches/packages/mozilla-firefox-18.0.2-x86_64-1_slack14.0.txz: Upgraded.
This is a bugfix release.
Flash works, no problem.

madslackw 02-12-2013 02:14 PM

brianL :

i had to find a 64 bits portuguese firefox version, is just that

thanks anyway

kingbeowulf 02-13-2013 12:40 AM

Be aware that FF now blocks flash content until you tell it not to.

brianL 02-13-2013 10:56 AM


Originally Posted by madslackw (Post 4890141)
brianL :

i had to find a 64 bits portuguese firefox version, is just that

thanks anyway

I think you can localize the stock Firefox. Look at this page (scroll down to find Firefox):

All times are GMT -5. The time now is 06:34 AM.