LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-29-2012, 06:11 AM   #1
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Rep: Reputation: 46
Firefox 12.0, cannot open "Profile Directory"


uname -a
Linux local 3.2.2 #2 Sun Jan 29 16:13:26 CST 2012 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz GenuineIntel GNU/Linux

firefox -v

Mozilla Firefox 12.0

cat /etc/slackware-version

Slackware 13.37.0


I am using the Firefox 12.0 binary from releases.mozilla.org because I have always had problems installing the official packages and I have extracted it onto /opt/firefox.
When I go into Help> Troubleshooting Information > Profile Directory and I click on "Open Directory" nothing happens. I have deleted the old profile and recreated one but to no avail.

It's a minor hassle but I wonder if anybody has had the same issue. Thanks
 
Old 04-29-2012, 07:54 AM   #2
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,301

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
If you start firefox from a command prompt, do you get error messages? If so what are they?

Quote:
firefox -ProfileManager
should start the profile manager from a command prompt.
 
Old 04-29-2012, 08:04 AM   #3
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Original Poster
Rep: Reputation: 46
Quote:
Originally Posted by camorri View Post
If you start firefox from a command prompt, do you get error messages? If so what are they?

should start the profile manager from a command prompt.
Code:
bash-4.1$ firefox -ProfileManager 

(firefox:4016): Gtk-WARNING **: Could not find the icon 'gtk-go-back-ltr'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases
 
Old 04-29-2012, 09:46 AM   #4
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,301

Rep: Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573Reputation: 573
Did you do a full install? I don't know what package the icons are in, however they are installed on my system.

Quote:
locate gtk-go-back-ltr
/usr/share/icons/gnome/16x16/actions/gtk-go-back-ltr.png
/usr/share/icons/gnome/256x256/actions/gtk-go-back-ltr.png
/usr/share/icons/gnome/22x22/actions/gtk-go-back-ltr.png
/usr/share/icons/gnome/48x48/actions/gtk-go-back-ltr.png
/usr/share/icons/gnome/24x24/actions/gtk-go-back-ltr.png
/usr/share/icons/gnome/32x32/actions/gtk-go-back-ltr.png
/usr/share/icons/Tango/16x16/actions/gtk-go-back-ltr.png
/usr/share/icons/Tango/22x22/actions/gtk-go-back-ltr.png
/usr/share/icons/Tango/scalable/actions/gtk-go-back-ltr.svg
/usr/share/icons/Tango/24x24/actions/gtk-go-back-ltr.png
/usr/share/icons/Tango/32x32/actions/gtk-go-back-ltr.pn
I did a locate for hicolor, the list is very long, so I did't post it.
 
Old 04-29-2012, 10:50 AM   #5
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 495

Rep: Reputation: Disabled
It seems you need the hicolor-icon-theme that's part of a default full Slackware install (which may be a part of the explanation as to why firefox from the Slackware repo's hasn't been working for you):

Code:
# slackpkg file-search gtk | grep hicolor
[ installed ] - hicolor-icon-theme-0.12-noarch-1
Although,
Code:
firefox -ProfileManager
Simply opens up firefox for me and no Profile Manager of some sort. Using the default gui method:

Help > Troubleshooting Information > Profile Directory > Open Directory also provides no results for me as well.
 
Old 04-29-2012, 07:03 PM   #6
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Original Poster
Rep: Reputation: 46
Quote:
Originally Posted by TommyC7 View Post
It seems you need the hicolor-icon-theme that's part of a default full Slackware install
Thanks. I have installed it now with slackpkg but no changes!
Quote:
Originally Posted by TommyC7 View Post
(which may be a part of the explanation as to why firefox from the Slackware repo's hasn't been working for you)
The last default installation I tried was FF 11.0 and I had this error:
Code:
XPCOMGlueLoad error for file /usr/lib/firefox-11.0/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory 
Couldn't load XPCOM
This is why I have defaulted to the pre-made binary, which otherwise is working quite well.
Quote:
Originally Posted by TommyC7 View Post
Using the default gui method:

Help > Troubleshooting Information > Profile Directory > Open Directory also provides no results for me as well.
Which version of FF are you using and where did you get it from? This looks like a [Mozilla] bug to me.
 
Old 04-29-2012, 08:25 PM   #7
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,055

Rep: Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078
I have the same behaviour (Help > Troubleshooting Information > Profile Directory > Open Directory also provides no results) on Debian using Nightly and Aurora builds under XFCE.
Can't check Slack right now but I suspect it would be the same.
 
Old 04-30-2012, 03:12 AM   #8
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 495

Rep: Reputation: Disabled
Quote:
Originally Posted by ottavio View Post
Thanks. I have installed it now with slackpkg but no changes!
I think you have to rebuild firefox after you get the library. I don't think it'll magically work right after you just build only the dependency.

Quote:
The last default installation I tried was FF 11.0 and I had this error:
Code:
XPCOMGlueLoad error for file /usr/lib/firefox-11.0/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory 
Couldn't load XPCOM
This is why I have defaulted to the pre-made binary, which otherwise is working quite well.
Code:
# slackpkg file-search libxpcom.so
Looking for libxpcom.so in package list. Please wait... DONE

The list below shows the packages that contains "libxpcom\.so" file.

[ installed ] - mozilla-firefox-12.0-x86_64-1
[ installed ] - mozilla-thunderbird-12.0-x86_64-1
[uninstalled] - seamonkey-2.9-x86_64-1

You can search specific packages using "slackpkg search package".
Looks like it's part of the mozilla-firefox package from your Slackware mirror. At least it seems to be a part of mine anyways. I'm using Firefox 12.
 
Old 04-30-2012, 08:07 AM   #9
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Original Poster
Rep: Reputation: 46
libxul.so: cannot open shared object file: No such file or directory

I have installed the latest FF 12.00 from the -current repo:

Code:
bash-4.1$ ls /var/log/packages/|grep mozilla
mozilla-firefox-12.0-i486-1
Now I have two binaries, one in /opt/firefox/firefox, linked from /usr/local/bin/firefox, and the other in /usr/bin/firefox.

Code:
bash-4.1$ which firefox
/usr/local/bin/firefox
bash-4.1$ ls -al /usr/local/bin/firefox 
lrwxrwxrwx 1 root root 20 Apr 28 08:57 /usr/local/bin/firefox -> /opt/firefox/firefox
This works fine, but:

Code:
bash-4.1$ ls -al /usr/bin/firefox 
lrwxrwxrwx 1 root root 29 Apr 30 12:31 /usr/bin/firefox -> /usr/lib/firefox-12.0/firefox
bash-4.1$ /usr/lib/firefox-12.0/firefox
XPCOMGlueLoad error for file /usr/lib/firefox-12.0/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM
bash-4.1$ su -c 'slackpkg file-search libxul.so'
Password: 

Looking for libxul.so in package list. Please wait... DONE

The list below shows the packages that contains "libxul\.so" file.

[ installed ] - mozilla-firefox-12.0-i486-1
[uninstalled] - mozilla-thunderbird-12.0-i486-1
[uninstalled] - seamonkey-2.9-i486-1

You can search specific packages using "slackpkg search package".
But I do have libxul:
Code:
bash-4.1$ find /usr -name libxul.so  
/usr/lib/firefox-12.0/libxul.so
Any clue?
 
Old 04-30-2012, 08:20 AM   #10
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,476

Rep: Reputation: Disabled
what does
Code:
ldd /usr/lib/firefox-12.0/libxul.so
says?

something's missing?

is there any reason why haven't you installed firefox-12.0 from the patches folder? I think you should use that and not the one built on -current...

Last edited by ponce; 04-30-2012 at 08:25 AM.
 
Old 04-30-2012, 08:42 AM   #11
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware
Posts: 573

Rep: Reputation: 59
On slackware you really need seamonkey or seamonkey-solibs installed for the shared mozilla libraries that firefox uses
 
Old 04-30-2012, 10:14 AM   #12
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Original Poster
Rep: Reputation: 46
Quote:
Originally Posted by ponce View Post
what does
Code:
ldd /usr/lib/firefox-12.0/libxul.so
says?

something's missing?
Code:
ldd /usr/lib/firefox-12.0/libxul.so|grep not
/usr/lib/firefox-12.0/libxul.so: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/firefox-12.0/libxul.so)
        libsmime3.so => not found
        libssl3.so => not found
        libnss3.so => not found
        libnssutil3.so => not found
        libmozsqlite3.so => not found
        libplds4.so => not found
        libplc4.so => not found
        libnspr4.so => not found
        libmozalloc.so => not found
        libstartup-notification-1.so.0 => not found


Quote:
Originally Posted by ponce View Post
is there any reason why haven't you installed firefox-12.0 from the patches folder? I think you should bash-4.1# upgradepkg /tmp/mozilla-firefox-12.0-i486-1_slack13.37.txz use that and not the one built on -current...
Code:
upgradepkg /tmp/mozilla-firefox-12.0-i486-1_slack13.37.txz

bash-4.1$ /usr/bin/firefox 
XPCOMGlueLoad error for file /usr/lib/firefox-12.0/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
Same problem.
 
Old 04-30-2012, 10:21 AM   #13
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Original Poster
Rep: Reputation: 46
Quote:
Originally Posted by Eternal_Newbie View Post
On slackware you really need seamonkey or seamonkey-solibs installed for the shared mozilla libraries that firefox uses
Code:
slackpkg install seamonkey-solibs

bash-4.1$ /usr/bin/firefox 
XPCOMGlueLoad error for file /usr/lib/firefox-12.0/libxpcom.so:
libxul.so: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
Ok, I'm giving up on this. I'll stick with the Mozilla binary.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Building Firefox 3.6 - A "Profile Guided Optimization" (PGO) Automated Build Script GrapefruiTgirl Linux - Software 6 10-28-2010 10:50 AM
Uneeded "/usr/lib64//firefox-3.6.10" directory in mozilla-firefox-4.0b6-x86_64-1.txz michelino Slackware 0 09-21-2010 06:20 AM
"Broken" envirnment variable (MANPATH) and "/etc/profile.d" question. ErV Slackware 3 03-20-2007 10:42 AM
Firefox crashed & now says my profile is "in use"?? BrianK Linux - Software 5 08-28-2006 03:52 PM
FireFox killing "User Profile" DdTComp Linux - Software 6 02-15-2005 04:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration