-   Slackware (
-   -   Finally got KDE 3.2.2 installed, but now have a font error when starting Konsole (

blk96gt 06-12-2004 04:50 PM

Finally got KDE 3.2.2 installed, but now have a font error when starting Konsole
After I had first installed KDE 3.2.2, I kept getting the error, and after some searching I got that fixed. I solved that problem by doing this:
d /usr/X11R6/lib
ld --whole-archive -share -o libXinerama.a
ln -s
Well now KDE comes up and everything, but whenever I open up konsole, I get this error:
Font '-misc-console-medium-r-normal--16-160-72-72-c-80-iso10646-1' not found. I didn't have this problem before when i was using KDE 3.1.4. Anyone have any suggestions?

Menestrel 06-12-2004 05:14 PM

I solved this problem by adding to /etc/fonts.conf the path /opt/kde/share/fonts in the part where you have all the paths to fonts.
after this I also edited XF86config and added the line FontPath "/usr/X11R6/lib/X11/fonts/local/" in the files section. After that I run fc-cache -v. In kde select linux fonts for konsole

blk96gt 06-12-2004 05:51 PM

It fixed it by adding the /opt/kde/share/fonts line to the /etc/fonts/fonts.conf file. The line in XF86Config was already there, so I just ran that command and opened up console and didn't have the error. But now I have another question. The prompt is different looking than it was before, and I have no colors when using ls. The prompt looks like this:
which to me looks like the default bash prompt when it doesnt load the .bashrc file, or one of those bash files. Am I on the right track? Thanks for the help.

blk96gt 06-12-2004 10:26 PM

Well I figured out the problem with the prompt and the colors after a quick search. All I had to do was when I call konsole ad the -ls switch to the end.

asmith 06-16-2004 01:27 PM

I've got the same problem and many more.:)
The konsole font is messed, even with the default for me option -ls
The run command doesn't work, I don't have right click menu on the desktop.
Can't you help me.
And where do you set the konsole font that you mentioned?

vdemuth 08-03-2004 01:29 AM

To cure this problem do the following:-
Copy all the fonts from /opt/kde/share/fonts to /usr/X11R6/lib/X11/fonts.
Run command /usr/X11R6/bin/fc-cache
Open KDE control centre and login to admin>fonts as administrator.
Log out again and you should find it is now OK

All times are GMT -5. The time now is 04:35 AM.