-   Slackware (
-   -   File managers for Window Maker (

w1k0 09-13-2009 02:07 PM

File managers for Window Maker

Originally Posted by easuter (Post 3681069)
w1k0, have you ever managed to build and use the WindowMaker FSViewer?
I vaguely remember using it when I first trying Linux and wmaker, but that was quite a while ago and I can't remember which distro it was.

File managers

As I know there were at least three file managers for Window Maker: FSViewer, WMfinder and GWorkspace.

FSViewer 0.2.5 is accessible here:

WMfinder 0.2.9 was accessible here: but now that site is dead. I found WMfinder 0.5 here: I donít know if version 0.5 is newer or older than 0.2.9.

GWorkspace 0.8.6 is accessible here: To compile it you have to compile and install first GNUstep Startup accessible here: Instead of compile it you can install binaries for your system accessible here:



I installed binaries for Slackware: gnustep-back-0.16.0-i486-1.tgz, gnustep-base-1.18.0-i486-1.tgz, gnustep-gui-0.16.0-i486-1.tgz and gnustep-make-2.0.8-i486-1.tgz. Unfortunately gnustep-make is invalid and doesnít contain script in /usr/GNUstep/System/Library/Makefiles/ directory so I had to put it in the system after extracting it from the sources. Then I compiled and installed GWorkspace. It works but on my machine (ThinkPad T60 with ATI Radeon X1300) it displays vertical stripes when I use scrolling (TrackPoint).


I tried to compile it but make displayed such error messages:


/usr/lib/gcc/i486-slackware-linux/4.3.3/../../../libWINGs.a(widgets.o): In function `WMCreateScreenWithRContext':
widgets.c:(.text+0x8cd): undefined reference to `XftDrawCreate'
collect2: ld returned 1 exit status
make[3]: *** [FSViewer] Error 1
make[3]: Leaving directory `/tmp/SBo/'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/SBo/'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/SBo/'
make: *** [all-recursive] Error 1


I tried to compile it but configure displayed such error message:


configure: error: It seems libqt is missing !


I managed to compile only GWorkspace but it works invalid when scrolling directories contents. I suppose FSViewer and WMfinder sources have to be customized to the contemporary libraries.

Personally I donít use such file managers. I like Midnight Commander opened in xterm window.

If you know where is accessible WMfinder 0.2.9 source let us know.

w1k0 09-13-2009 02:13 PM

If you like Window Maker you could look here: 15 applications for Window Maker. Especially interesting is post #9. I add to it from time to time some new information found on Window Maker mailing lists.

All times are GMT -5. The time now is 10:32 PM.