LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-05-2004, 10:19 AM   #1
steve_d555
Member
 
Registered: Apr 2004
Location: Massachusetts
Distribution: Debian, Slack 10, Gentoo!
Posts: 87

Rep: Reputation: 15
Fglrx and glx


Hi,
I have previously intalled Fglrx on Debian and have been very succesful, and i thought i would try out Slackware, as I have used it before and wnated to come back... My system has a Ak32VN Motherboard, with and Athlon XP 2400 and 512 RAM, I am trying to use my Radeon 9200 128mb, and needed some help... I have 2.6.7 running and have been trying to get fglrx working, it compiles and installes, and Gnome starts, but whenever i try to get glxinfo or glxgears, or even fglrxinfo, X Crashes and restarts... I will try to get my /var/log up, but I have a question, whenver Xorg startes there is this message _GLContext visual = -1 (-1) nprobe = 0 ( ill try to get exact message up after I get home)

Thanx
--Steve
 
Old 11-06-2004, 12:23 AM   #2
ViN86
LQ Newbie
 
Registered: Mar 2004
Distribution: Slackware 10.0
Posts: 25

Rep: Reputation: 15
i have it working on my system. im also using kernel 2.6.7. heres what i did to get it work.

1) get drivers from www.ati.com - use the newest drivers (3.14.1 as of this post)
use the 4.3.0 xfree86 version, and save the .rpm file on your hard drive

2) su
rpm2tgz fglrx-4.3.0-3.14.1.i386.rpm

3) installpkg fglrx-4.3.0-3.14.1.i386.tgz

4) cd /lib/modules/fglrx/build_mod

5) chmod a+x make.sh
./make.sh (when you run this, it should say something about using the 2.6.x kernel)

6) cd ..

7) chmod a+x make_install.sh
./make_install.sh

8) Now that the driver is installed, run:
fglrxconfig
(follow the instructions and answer the questions. when it asks you "Do you want to use an external GART driver/module, select yes. i use the nforce2 gart, which i compiled as a module in the 2.6.7 kernel)

9) once it is done, write the XF86Config-4 file and do the following
cd /etc/X11
cp xorg.conf xorg.conf.bak
cp XF86Config-4 xorg.conf
(basically, backup the xorg.conf file and cp the XF86Config-4 file over the existing xorg.conf file)

10) reboot, and startx
open a console and type "glxinfo" and you should see (if all works well):
Direct Rendering: Yes , along with lots of other information

if it doesnt work, then its probably something wrong with the GART driver/module. you should be able to see the GART module via using the lsmod cmd.

hope everything goes well for you and good luck

EDIT: if the module is loaded, fglrx should appear under the lsmod cmd.

Last edited by ViN86; 11-06-2004 at 12:52 AM.
 
Old 11-11-2004, 11:27 PM   #3
psx-dude
LQ Newbie
 
Registered: Mar 2003
Location: Thousand Oaks, California, USA, Earth, Solar System, Milky Way
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
I did all these steps and X loads, but i get:
(EE) fglrx(0): incompatible kernel module detected - HW acclerated OpenGL will not work

I did lsmod and i see both fglrx and agpgart listed, glx info returns direct rendering: no

any ideas on what to do? (glx gears runs, but fglr_glxgears or whatever doesn't.)


UPDATE: Well I did a rmmod and removed the fglrx entry and reinstalled it all, now it crashes with:
Fatal server error: caught signal 11. server aborting and doesn't exit from X, i have to ssh to my box to restart it.

Last edited by psx-dude; 11-12-2004 at 12:03 AM.
 
Old 11-12-2004, 10:21 AM   #4
steve_d555
Member
 
Registered: Apr 2004
Location: Massachusetts
Distribution: Debian, Slack 10, Gentoo!
Posts: 87

Original Poster
Rep: Reputation: 15
Did you enable DRI in your Kernel, that will certainly destroy FGLRX
 
Old 11-12-2004, 01:12 PM   #5
psx-dude
LQ Newbie
 
Registered: Mar 2003
Location: Thousand Oaks, California, USA, Earth, Solar System, Milky Way
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
How would i enable dri?
 
Old 11-12-2004, 08:15 PM   #6
steve_d555
Member
 
Registered: Apr 2004
Location: Massachusetts
Distribution: Debian, Slack 10, Gentoo!
Posts: 87

Original Poster
Rep: Reputation: 15
Its in the kernel. if you look under (in 2.6) Device Drivers and then under Character Devices you should see DRM. There are also many great Tutorials on the net (i.e. http://www.rage3d.com/content/articles/atilinuxhowto/)

--Steve
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no glx!! rmakers Linux - Hardware 1 02-22-2005 04:54 PM
Fglrx console=>X changing problem and fglrx resume zbychdm Linux - Hardware 2 09-21-2004 12:58 PM
ATI 9500, fglrx-glc22-4.1.0, fglrx-glc22-4.2.0, fglrx-glc22-4.3.0 ctrl_alt_delx Linux - Hardware 1 09-30-2003 05:48 AM
GLX problem ViralHex Linux - Software 3 06-29-2003 07:43 PM
(II) [GLX]: Initializing GLX extension - X wont go hydro Linux - Software 3 02-20-2003 06:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration