-   Slackware (
-   -   ffmpeg install error from SlackBuilds (

eraosso 11-05-2009 10:42 AM

ffmpeg install error from SlackBuilds
I am trying to install ffmpeg from SlackBuilds but it ends up with the following error message: FAAD Test failed.

I have already tried the latest version but it still gets the same error.
Any hints?


EricTRA 11-05-2009 10:49 AM


Did you install the 'faad2' package also? It's needed by ffmpeg, you can get it from

Kind regards,


Didier Spaier 11-05-2009 11:02 AM

If you do not want FAAD support, either run the SlackBuild like this:

FAAD=no ./ffmpeg.SlackBuild
or edit it accordingly.

If you want FAAD support, install FAAD2 first -- it's available on too.

eraosso 11-05-2009 06:47 PM

Thanks Didier and Eric!
The FAAD issue is solved but now I end up with another error:
ERROR: libx264 not found
How can I solve this one?

Thanks again!

slackass 11-05-2009 07:09 PM

by installing x264 witch requires yasm

BrZ 11-05-2009 07:10 PM should be a good start point. 'ffmpeg.SlackBuild' have one specific flag for libx264 (--enable-libx264).

If you don't need x264, disable it (--disable-libx264). When there, look around for other dependencies.

eraosso 11-05-2009 07:21 PM

Hi again! Problem solved! I did find the x264 library and successfully installed everything!

Learning and learning....


TSquaredF 11-05-2009 07:23 PM

All times are GMT -5. The time now is 05:36 AM.