-   Slackware (
-   -   FF & Swiftfox in Slack 12.2<solved> (

windtalker10 09-10-2009 12:04 PM

FF & Swiftfox in Slack 12.2<solved>
Not sure if this is the proper place or not beyond I'm running Slack 12.2/KDE.
The original Firefox that came with the install wouldn't allow plugins I wanted, so I tried to upgrade it.
Wrong answer.
I ended up downloading the newer Firefox and running it from the executable.
Things got confused when I kept doing this so I tracked down the original Firefox and rm'd it.
The newer Firefox version would crash taking X with it after a bit of use when I was typing furiously away, usually when typing into the address bar.
When I say taking X with it, I mean I have to go through the entire login process.
I then downloaded Swiftfox and installed it.
This fixed the problem for about two weeks now, until today.
I'm in the process of uploading/installing/configuring a rather complicated website and getting half of a url into the address bar, then having X crash is beginning to tick me off to no end.
Was in the process rather.
The crashing screwed the site up somehow so I had to remove the entire database and am waiting to start over.
I havn't a clue how to fix it and have googled my guts out looking.
I had thought about reinstalling / as I did set up a separate /home to see if that would fix things.
I've never done that with Slack but figure the process is the same as any other system and would give the same results.
Anyone have any ideas or have ran into this same type situation and have a fix?

edit: Duno if it would make a difference but I was using an "extreme" theme because it made everything easier to see and allow maximum workspace.
I just switched to the littlefox theme to see if it might have been that plugin, which might be possible but I doubt.
I've never had a crashing problem with Firefox before now.

bassmadrigal 09-10-2009 12:57 PM

Well as far as getting firefox fixed, you could just remove your newly downloaded one, and then just get the latest 3.0.x series (for 12.2) or you can get the 3.5.x series from Slack 13, but you would have to change your pkgtools and add a couple of packages for the new txz format. Patrick has the config patched so it uses /usr/lib/mozilla/plugins for any plugins which will also allow seamonkey and some other apps use them as well.

As far as X crashing, is there any info in your logs on why this happens? Check /var/log/Xorg.0.log

You could also temporarily create a new user and see if that fixes the problem. If so it could be related to your firefox/swiftfox or something you are loading on the desktop. If the problem persists, then you at least know it isn't anything with themes and the like on your browser.

windtalker10 09-10-2009 01:37 PM

Xorg.o.log only shows the loading and initializing process.
Shows nothing at all indicating anything is out of the ordinary.
So far changing the theme to Littlefox seems to have gone ok.
Won't really know anything until Godaddy finishes setting up the new database.
If the crashing continues I'll take your suggestion of reinstalling FireFox from slackbuilds for 12.2.
Learned the hard way that the Firefox I found at Slacky isn't in English.
As for going with the one for 13, I'll wait until I'm ready for upgrading, but the suggestion is a thought.
Appreciate the response.

Admin's: I'll mark post as solved if I get no crashes by tommorrow.

bassmadrigal 09-10-2009 04:55 PM

AFAIK, to upgrade to the 3.5.x version, you would just need to upgrade pkgtools and tar, and then install the xz package.


upgradepkg /root/slackware/a/pkgtools-*.tgz
upgradepkg /root/slackware/a/tar-*.tgz
installpkg /root/slackware/a/xz-*.tgz

You can download all these from any of the 13.0 mirrors. Then just download the new firefox from the xap folder on a 13.0 mirror and do an upgradepkg on that.

adriv 09-10-2009 05:01 PM

Have you tried a new profile?
That's usually a lot more effective than reinstalling/upgrading etc.

BTW, you can have FF (or Swiftfox) in any language you want. Just open about:config and set the general.useragent.locale to whatever you want. After that you install the xpi file for your locale (you can find them here).
Restart FF and everything is hunky dory. :)

windtalker10 09-10-2009 07:13 PM

Thx for that adriv.
It seems like the theme was the problem as I've been typing my guts out and uploading files.
788 folders uploaded, been configuring for about 3 hours and reliable old GoDaddy just crashed on me.
Swift Fox hasn't crashed yet so I'm going to say it was the theme I was using.
I was even having problems of when I opened my bookmarks a good many of the bookmarked sites wouldn't show until I scrolled over them.
That has even straightened out.

GrapefruiTgirl 09-10-2009 08:05 PM


Originally Posted by windtalker10 (Post 3678057)
I was even having problems of when I opened my bookmarks a good many of the bookmarked sites wouldn't show until I scrolled over them.
That has even straightened out.

Interesting that you mention that. I did experience a similar weirdness with my FF 3.5.2 for a few days or so, after installing a dark theme shortly after my initial installation.

I would open the bookmarks or history in my side-panel, and it would all be empty :O but then, after some mousing around, and maybe opening & closing the side-panel a few times, it would all work normally and everything would show up as it should..

I'm VERY certain that it was a Firefox issue alone, either directly, OR indirectly due to an FF addon or theme glitch.

Since the last couple updates to my addons & stuff, the problem has gone away entirely.

Anyhow, FYI in case you didn't know: once you're sure your issue is gone or solved, you can actually (officially ;) ) mark your thread solved, using "Thread Tools" near the top of the page.


windtalker10 09-10-2009 10:47 PM

I'm using SwiftFox 3.5.2 myself.
The theme I was using was Noia (2.0) eXtreme which made the address bar and everything else up there easy to see as well as left me with a lot of workspace.
I noticed if I allowed the entire page to load before opening the bookmarks tab, everything was fine.
I start working as soon as I see the page has opened and it evidently was to much for the theme and X to handle all at one time.
Everything I have on this box is up to date so I guess it's just that theme is still buggy.
Thx for the thread tools tip.
Never paid the gadget no mind until now.

All times are GMT -5. The time now is 06:36 PM.