LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-03-2004, 05:27 AM   #1
neverwhere
Member
 
Registered: Sep 2004
Distribution: Slackware 10
Posts: 34

Rep: Reputation: 15
fat32 permission problem


Hey all, running slack 10 full install, default kernel. My problem is, i have multiple fat32 partitions i share between win2k and slack. win2k has no problem writing to them and such. but when i load up slack, only root can read the drives, and when i try and change permissions on the drives to my user, or even under advanced permissions checking everything and clicking ok. it doesnt give me an error, but when i go back to the permissions window, its back to what it was, no changes were kept. even tried changing permissions with chmod +rwx /mnt/backup and chmod +rwx /dev/hda5. is there something i obviously dont know? from what i've read, the kernel has had built in rw abilities with vfat drives since 1.2.x i think. i have no experience with fat/vfat drives in linux, so any help would be appriciated. thanks.

- Neverwhere
 
Old 11-03-2004, 05:31 AM   #2
KMcD
Member
 
Registered: Jun 2003
Location: Dublin, Ireland
Distribution: Slack -- current
Posts: 354

Rep: Reputation: 30
post your fstab file. The line in my fstab for the fat partition on my pc is:

Code:
/dev/hda5        /mnt/fat-32      vfat        noauto,users,rw  0   0
this may help.
 
Old 11-03-2004, 07:19 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
that won't fix it, you need to set "umask=000" as an additional option for EVERYONE to be able to write to it.
 
Old 11-04-2004, 06:03 AM   #4
neverwhere
Member
 
Registered: Sep 2004
Distribution: Slackware 10
Posts: 34

Original Poster
Rep: Reputation: 15
cool, thanks alot guys, that fixed it

- Neverwhere
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 07:54 PM
cannot create symlinkoor change permission in a mounted fat32 drive Cii Linux - General 3 03-06-2005 01:44 PM
KNOPPIX does not recognize FAT32, also permission issues. Lechium Linux - Hardware 4 06-02-2004 06:16 PM
Fat32 permission tr0gd0O0r Linux - General 2 10-15-2003 12:32 AM
2 fat32 partitions on fbsd5/w2k dual. Can only access one fat32 so far.. mipia *BSD 1 10-06-2003 02:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration