-   Slackware (
-   -   fastboot problems Android-sdk (

Gee Man 09-18-2012 04:33 PM

fastboot problems Android-sdk
Hello all,

I have been a slacker for many years, yet I have never actually needed help that I couldn't find already posted on here. My issue is that since upgrading to current on my netbook, I can no longer use fastboot to flash my galaxy nexus. Adb works just fine, just not fastboot. Rolling back to 13.37 resolves the issue. I have the /etc/udev/rules.d/51-android.rules set the same on current and 13.37. I'm wondering if it is an issue with udev? I'm worried my beloved slackware 14 will release, and I have to stay with 13.37.

jdk-7u6-x86_64 built from extra slackbuild

When I type "fastboot devices" my prompt just returns. The bottom of my nexus says "FASTBOOT COMMAND READ ERROR -2147483647." My first thoughts were my cable is bad, but I tried three different cables before rolling back to 13.37. I also tried all three of the usb ports of my netbook.

Alien Bob 09-18-2012 04:47 PM

Errors? Other things you may want to add apart from "Adb works just fine, just not fastboot"? What version of Java do you use? What version of the Android SDK?


Gee Man 09-18-2012 05:44 PM

I would like to also mention that while the phone is on lsusb lists the device. While the phone is in fastboot mode lsusb also lists the device. I have made sure my android-rules are set up properly for both modes. I am at a loss. I'll keep digging around and see what I find. Once I figure it out I will make sure to report back, just in case it could help someone else:-)

edit 1: I just updated java to 7u7 and now adb does not work. It really seems to be a problem with java. When I get time I'm going to try openjdk. I was so worried it was my favorite OS!

edit 2: I'm an idiot:-) Use java 1.6 not 1.7. Thank you AlienBob

edit 3: running the command "android update sdk" solved all my issues.

All times are GMT -5. The time now is 11:29 PM.