LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-27-2008, 03:17 AM   #1
Muraii
Member
 
Registered: May 2006
Posts: 64

Rep: Reputation: 15
Fail to Mount iPod Nano Read-Write


Hi,

I've been scouring teh intarweb for a cure for my iPod issue. There are a few, albeit older, posts here at LQ, but they haven't helped. I'll reproduce my udev rule, then my fstab, then the error message, and the general behavior.

In

Code:
/etc/udev/rules.d/10-local.rules
I have this rule

Code:
BUS=="usb", ATTR{product}=="iPod", KERNEL=="sd?2",NAME="%k", SYMLINK="ipod",MODE="0664"
Here's the fstab entry I'm using.

Code:
/dev/sdb2   /media/ipod    auto    nodev,nosuid,user,rw,noauto    0  0
When firing up amaroK and attempting to connect to the iPod, I get this error.

Code:
Media Device: failed to create lockfile on iPod mounted at /media/ipod: Read-only file system
Generally, my system identifies the iPod Nano 3G when I plug it in. I mount it, then go to amaroK and receive the error above when attempting to connect to the iPod. I know it's mounted using hfsplus, and mount lists it as read-write.

Is there a udev thing I need to do? Wouldn't seem so, since it's recognized, but then again, there's no /dev/ipod entry created. I haven't tried any other app, assuming amaroK doesn't have a bug that's responsible.

Thanks for any pointers.

Daniel
 
Old 07-27-2008, 05:18 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Which desktop do you use? On my system, there isn't an entry for the device in /etc/fstab, but you can change some options in the properties of the desktop icon. If you use kde and right click on the icon; select properties; select the mounting tab and click the "mount as user" tab.
Some random notes: I made myself a member of polkituser. I don't know if that's important. I also enabled device icons in the desktop -> properties -> behavior setup.

It could be that your system is designed differently. In that case you might try using the "uid=" and "gid=" options. This will change the owner/group of the filesystem when it is mounted.

If you have a nano, or device with a solid state device, then I think you want to use the same options you would use for a pendrive:

rw,nosuid,nodev,noatime,flush,utf8,shortname=lower

This is how a pendrive is mounted on my system. The nosuid & nodev options enhance security somewhat. The noatime option is important to extend the life of the device by not updating access times, so reading a file won't cause a write.

Last edited by jschiwal; 07-27-2008 at 10:00 AM.
 
Old 07-28-2008, 11:50 AM   #3
Muraii
Member
 
Registered: May 2006
Posts: 64

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
Which desktop do you use? On my system, there isn't an entry for the device in /etc/fstab, but you can change some options in the properties of the desktop icon.
I use Xfce 4.4 on a Slackware 12.1 system. Mounting from the desktop icon fails.

Quote:
If you use kde and right click on the icon; select properties; select the mounting tab and click the "mount as user" tab.
Some random notes: I made myself a member of polkituser. I don't know if that's important.
I'm looking into that. When googling before posting here, I saw some people creating an "ipod" group. Maybe I'll try that.

Quote:
It could be that your system is designed differently. In that case you might try using the "uid=" and "gid=" options. This will change the owner/group of the filesystem when it is mounted.
I'll read up on that. Thank you.

Quote:
If you have a nano, or device with a solid state device, then I think you want to use the same options you would use for a pendrive:

rw,nosuid,nodev,noatime,flush,utf8,shortname=lower

This is how a pendrive is mounted on my system. The nosuid & nodev options enhance security somewhat. The noatime option is important to extend the life of the device by not updating access times, so reading a file won't cause a write.
I'll look into/try some different mounting options, but the problem just surrounds the write permission. I can look through the iPod file structure without a problem; I think I'm going to try copying something to it outside amaroK just to see if it's amaroK's problem (unlikely).

Thanks for your help.

Daniel
 
Old 07-29-2008, 12:30 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
When I've had problems updating the tags on an mp3, it was due to there not being write permissions for the group user. After the ipod's drive is mounted look at the permissions with "ls -l". I believe that you want to be the owner and group owner. That means using the "uid=" and "gid=" options. In any event, check the permissions and ownership of the mounted ipod drive.


==
P.S. I noticed that my double quotes were converted to &quot in my prior posts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't mount HD in read/write!! unilynx Debian 2 09-20-2007 10:07 PM
Ipod/Nano and 2.6.17 Kernal - unable to mount AnthonyM Linux - Hardware 2 12-26-2006 07:44 PM
ipod read/write on FC5 w/ gtkpod SD-user Linux - Hardware 2 08-07-2006 09:50 PM
ipod nano no mount chickenbowels Linux - General 1 04-24-2006 06:31 AM
I can mount my ipod but cant write anything to it FC2 weirdnumber Linux - Hardware 1 10-04-2005 05:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration