LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
 
Search this Thread
Old 11-15-2013, 02:40 PM   #1
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Rep: Reputation: 71
Even root is powerless with this...


I've got 14.1 installed (Yes, I caved and downloaded the 32bit iso...I'll buy the regular DVD next month or January). Everything seemed to go just fine, like it has for me with 13.37 and 14.0.

I spent about 8 hours yesterday rebuilding a butt-load of apps that I kept from the 14.0 sources. Finally got around to wanting to get the Brother HL2280DW all-in-one going like I did in 14.0 also.

The installation of the drivers went okay, I suppose, *but* every time I try to do the ./ on the brother cupswrapper.sh, I keep getting a 'permission denied'...and I'm doing this as root in konsole (getting to root I did, as I have for the past three years, su<space>-).

Okay, I'll log in as root in roots own kde. Same thing...permission denied.

I can't even do a Chmod + x /etc/rc.d/rc.cups - permission denied!

I can't restart cups even! If I try to go to http://localhost:631/ I'm told it can't connect. It seems anything and everything to do with cups and root is off-limits.

Does anyone have any ideas what the hell is going on? I can, as root, do an scanimage -L and it shows my printer connected via usb, but that's it.

How do I even know if cups or cups daemon is even running?

Any help with this greatly appreciated, as I've never seen root get told it can't do what it wants, heh.
 
Old 11-15-2013, 03:13 PM   #2
GNU/Linux
Member
 
Registered: Sep 2012
Distribution: Slackware-14
Posts: 117

Rep: Reputation: Disabled
What's the result of:
Code:
# lsattr /etc/rc.d/rc.cups
 
Old 11-15-2013, 07:55 PM   #3
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + Xmonad
Posts: 302

Rep: Reputation: 99
Quote:
How do I even know if cups or cups daemon is even running?
Run nmap on yourself:
Code:
nmap 127.0.0.1
Among other things, you should see "631/tcp open ipp" if cups is running.
 
1 members found this post helpful.
Old 11-15-2013, 08:19 PM   #4
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Original Poster
Rep: Reputation: 71
Quote:
Originally Posted by GNU/Linux View Post
What's the result of:
Code:
# lsattr /etc/rc.d/rc.cups
I got this, whatever it means:

lsattr: Inappropriate ioctl for device While reading flags on /etc/rc.d/rc.cups
 
Old 11-15-2013, 08:22 PM   #5
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Original Poster
Rep: Reputation: 71
Quote:
Originally Posted by STDOUBT View Post
Run nmap on yourself:
Code:
nmap 127.0.0.1
Among other things, you should see "631/tcp open ipp" if cups is running.
I did this as user, and got the same answer as root...

Code:
bash-4.2$ nmap 127.0.0.1

Starting Nmap 6.40 ( http://nmap.org ) at 2013-11-15 20:19 CST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00032s latency).
Not shown: 997 closed ports
PORT     STATE SERVICE
37/tcp   open  time
113/tcp  open  ident
3551/tcp open  apcupsd

Nmap done: 1 IP address (1 host up) scanned in 0.17 seconds
 
Old 11-15-2013, 08:47 PM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,770

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Quote:
lsattr: Inappropriate ioctl for device While reading flags on /etc/rc.d/rc.cups
This suggests a problem with extended attributes.
What is the output of 'cat /etc/mtab'?
 
Old 11-15-2013, 09:40 PM   #7
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Original Poster
Rep: Reputation: 71
Quote:
Originally Posted by allend View Post
This suggests a problem with extended attributes.
What is the output of 'cat /etc/mtab'?
This is what I got...

Code:
bash-4.2$ cat /etc/mtab
/dev/sdb1 / reiserfs rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
/dev/sda1 /boot reiserfs rw 0 0
/dev/sda2 /home reiserfs rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
gvfsd-fuse /home/john/.gvfs fuse.gvfsd-fuse rw,nosuid,nodev,user=john 0 0
I need to mention now, that I did an
Code:
/etc/sbin/cupsd
and at least the printer now is recognized at http://localhost:631/admin, though neither root nor user can print and root still has some problems doing admin things with the printer. I tried to delete the printer to try and add it again/differently and a small window pops up wanting a 'name' and 'password'...unfortunately root and roots password don't work nor does users name and password.

Also, here is what I get now from nmap...

Code:
bash-4.2$ nmap 127.0.0.1

Starting Nmap 6.40 ( http://nmap.org ) at 2013-11-15 21:34 CST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00026s latency).
Not shown: 996 closed ports
PORT     STATE SERVICE
37/tcp   open  time
113/tcp  open  ident
631/tcp  open  ipp
3551/tcp open  apcupsd

Nmap done: 1 IP address (1 host up) scanned in 0.16 seconds
What's 'ipp'? Shouldn't that be 'lp'?

Last edited by irgunII; 11-15-2013 at 09:42 PM.
 
Old 11-15-2013, 11:02 PM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,770

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Quote:
/dev/sdb1 / reiserfs rw 0 0
Try changing /etc/fstab to include user_xattr
Code:
/dev/sdb1 / reiserfs defaults,user_xattr 0 0
Quote:
What's 'ipp'? Shouldn't that be 'lp'?
ipp is Internet Printing Protocol http://en.wikipedia.org/wiki/Internet_Printing_Protocol
and is often used in printing URIs.

BTW - Have you seen this SlackDocs page about installing Brother printers? http://docs.slackware.com/howtos:har...r_installation

Last edited by allend; 11-15-2013 at 11:24 PM.
 
Old 11-16-2013, 02:47 AM   #9
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Original Poster
Rep: Reputation: 71
Quote:
Originally Posted by allend View Post
Try changing /etc/fstab to include user_xattr
Code:
/dev/sdb1 / reiserfs defaults,user_xattr 0 0

ipp is Internet Printing Protocol http://en.wikipedia.org/wiki/Internet_Printing_Protocol
and is often used in printing URIs.

BTW - Have you seen this SlackDocs page about installing Brother printers? http://docs.slackware.com/howtos:har...r_installation
Are you sure I should change 'fstab' to that? My current fstab looks like this:

Code:
/dev/sdb2        swap             swap        defaults         0   0
/dev/sdb1        /                reiserfs    defaults         1   1
/dev/sda1        /boot            reiserfs    defaults         1   2
/dev/sda2        /home            reiserfs    defaults         1   2
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
Or did you mean 'mtab' like you asked the information on?

Yes, I'd already been to that site and tried those instructions.

Last edited by irgunII; 11-16-2013 at 02:50 AM.
 
Old 11-16-2013, 03:36 AM   #10
metageek
Member
 
Registered: Jun 2007
Location: manchester, uk
Distribution: Slackware
Posts: 121

Rep: Reputation: 24
yes, you should do the change on /etc/fstab which is where the settings for the mount points are stored. /etc/mtab shows the currently mounted volumes, but you want to change how the volume is mounted at startup, so that is done in /etc/fstab
 
Old 11-16-2013, 07:55 AM   #11
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Original Poster
Rep: Reputation: 71
Okay, I changed my fstab to the suggestion and rebooted. Using my browser I went to delete the printer and try a new entry. The window pops up asking for username and password...I tried with root and user again and both fail and give this message:

Code:
Unauthorized

Enter your username and password or the root username and password to access this page. If you are using Kerberos authentication, make sure you have a valid Kerberos ticket.
I'm almost beginning to think I need to re-install and try again.

Don't give up helping if there's anymore suggestions, please, heh. I'd much rather try to solve this problem and have the solution be here for others who might have the same thing happen, than re-install 14.1 and go through all that time to only have it still happen anyway again.
 
Old 11-16-2013, 08:05 AM   #12
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,770

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Do you have the cupsd daemon running? I suggest trying 'ps ax | grep cupsd'
As you manually started cupsd, it may not have been restarted after your reboot. To always start cupsd at startup, /etc/rc.d/rc.cups needs to be set executable. Does 'chmod +x /etc/rc.d/rc.cups' work for you now?
 
Old 11-16-2013, 10:13 AM   #13
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Original Poster
Rep: Reputation: 71
Quote:
Originally Posted by allend View Post
Do you have the cupsd daemon running? I suggest trying 'ps ax | grep cupsd'
As you manually started cupsd, it may not have been restarted after your reboot. To always start cupsd at startup, /etc/rc.d/rc.cups needs to be set executable. Does 'chmod +x /etc/rc.d/rc.cups' work for you now?
Hi allend,

Yes, the cupsd is running. I forgot to also mention that, sorry about that <embarrassed> (I put a .conf file in rc local to have cupsd start at every boot/reboot).

I just tried the chmod thing as root and it works now, but still nothing will print for me or root.

Some more information - when I go to ./ the cupswrapper from Brother (the one I had to rpm2txz, located here when installed /usr/local/Brother/Printer/HL2280DW/cupswrapper), I get this:

Code:
ERROR : Brother LPD filter is not installed.
chmod: cannot access '/usr/local/Brother/Printer/HL2280DW/inf/brHL2280DWrc': No such file or directory
chmod: cannot access '/usr/local/Brother/Printer/HL2280DW/inf': No such file or directory
cups: restarted scheduler.                                 [  OK  ]
 
Old 11-16-2013, 10:39 AM   #14
irgunII
Member
 
Registered: Jan 2012
Location: Directly above the center of the earth
Distribution: Slackware. There's something else?
Posts: 383

Original Poster
Rep: Reputation: 71
Okay, seems I screwed up in one aspect...I did *not* download and install the 'lpr' driver (in my defense I thought it was because it was for lprng printing, not cups <sigh>, hopefully I'll remember this). My apologies for this screwup and having you guys waste your time on me for this.

*BUT*...in a browser at the printer admin, I *still* cannot delete a/any printers using the user or root. Yet with the 'Print Settings from the KDE menu (command system-config-printer), which is a small window and not much to it, I can and did delete the extra printer that got added somehow earlier (no problem there, I think that happened when I'd kept trying to install the cupswrapper or something or maybe the ./ on the cupswrapper.sh).

So, the standard cups configuration abilities on a browser are no good to me until we can figure out why.
 
Old 11-16-2013, 06:56 PM   #15
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,770

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
The order of the installation of the LPR driver and cupswrapper driver is important.
You install the LPR driver then the cupswrapper driver.

If you followed the SlackDocs page, you will have created packages hl2280dwlpr-2.1.0-i386-1.txz and cupswrapperHL2280DW-2.0.4-i386-2.txz
I suggest uninstalling these packages, then reinstalling in the order:
1. hl2280dwlpr-2.1.0-i386-1.txz
2. cupswrapperHL2280DW-2.0.4-i386-2.txz

For further details see this. http://welcome.solutions.brother.com...ion_prn1a.html
Some comments on those instructions from Brother.
Step 2 - Not applicable as you are on Slackware 32bit
Step 4 - Obviously the dpkg and rpm commands are not applicable to Slackware. Use installpkg instead.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i write to a root:root 750 file with a non-root user? Droa Linux - Newbie 1 05-14-2012 07:49 PM
[SOLVED] how can i remount root filesystem as read/write after modify readonly-root file jcwkyl Linux - Newbie 3 12-21-2010 10:40 PM
why lftp command run failed when user isn't root, but ok when logining as root steven_yu Linux - Software 0 06-06-2007 08:36 PM
PCMCIA wifi card powerless Zaxor Fedora 12 09-09-2004 06:17 PM
root files: create as root:root or root:wheel? pcass Linux - Security 1 02-07-2004 04:14 PM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration