LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-30-2006, 07:11 PM   #1
cristianpaul
LQ Newbie
 
Registered: Nov 2006
Posts: 18

Rep: Reputation: 0
etho_not_see


Hi, I have a problem: my ethernet card is not deteched by kernel bare.i, every time I have tu run rc.hotplug script and after it works well. Why?

bye bye!
 
Old 12-01-2006, 02:24 AM   #2
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 917
Blog Entries: 5

Rep: Reputation: 148Reputation: 148
What kind of ethernet card are you using ? PCI slot or PCMCIA ?

Please provide information about the Slackware version (11.0) and its kernel (2.4.33.3 ?)

If the driver for your card is not compiled in the kernel (either as stock or as module), I guess, you need to run hotplug to have it detected.

Also could you post the following file /usr/src/linux/.config (it's the configuration file of the kernel).
 
Old 12-01-2006, 11:17 AM   #3
cristianpaul
LQ Newbie
 
Registered: Nov 2006
Posts: 18

Original Poster
Rep: Reputation: 0
Hi, I have a slack 10.2 and a pci ethernet card. I can't send my .config file because is too big, but I look in and I send jus this part, I think is enough:
# Ethernet (10 or 100Mbit)
#
CONFIG_NET_ETHERNET=y
# CONFIG_SUNLANCE is not set
CONFIG_HAPPYMEAL=m
# CONFIG_SUNBMAC is not set
# CONFIG_SUNQE is not set
CONFIG_SUNGEM=m
CONFIG_NET_VENDOR_3COM=y
CONFIG_EL1=m
CONFIG_EL2=m
CONFIG_ELPLUS=m
CONFIG_EL16=m
CONFIG_EL3=m
CONFIG_3C515=m
# CONFIG_ELMC is not set
# CONFIG_ELMC_II is not set
CONFIG_VORTEX=m
CONFIG_TYPHOON=m
CONFIG_LANCE=m
CONFIG_NET_VENDOR_SMC=y
CONFIG_WD80x3=m
# CONFIG_ULTRAMCA is not set
CONFIG_ULTRA=m
# CONFIG_ULTRA32 is not set
CONFIG_SMC9194=m
CONFIG_NET_VENDOR_RACAL=y
CONFIG_NI5010=m
CONFIG_NI52=m
CONFIG_NI65=m
CONFIG_AT1700=m
CONFIG_DEPCA=m
CONFIG_HP100=m
# CONFIG_NET_ISA is not set
# CONFIG_NET_PCI is not set
# CONFIG_NET_POCKET is not set


thank a lot for your help
 
Old 12-01-2006, 11:36 AM   #4
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 917
Blog Entries: 5

Rep: Reputation: 148Reputation: 148
Do you know which card you are using ?

please send the result of the following commands;

lspci -v

and after running hotplug

dmesg | less > dmesg.log

the last command will create a dmesg.log file and try to post the last part where hotplug should log what is detected
 
Old 12-01-2006, 12:08 PM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,753

Rep: Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336
A question that does not require so much output: is hotplug enabled on boot (i.e. is /etc/rc.d/rc.hotplug executable)?
Please be more specific about your hardware, and your Slackware configuration, if you want anyone to answer you with any relevancy to the problem.

Eric
 
Old 12-01-2006, 12:29 PM   #6
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 917
Blog Entries: 5

Rep: Reputation: 148Reputation: 148
Quote:
A question that does not require so much output: is hotplug enabled on boot (i.e. is /etc/rc.d/rc.hotplug executable)?
Having hotplug running on boot will solve the problem but I think it's a pity to use hotplug to have a PCI Ethernet card working. It may just be that the kernel is not load and an addition in /etc/rc.modules may be sufficient.
 
Old 12-01-2006, 06:33 PM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,753

Rep: Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336
Well... yeah, that is exactly what hotplug's function is - to automatically load drivers for your hardware.
The kernel does not "do" that for you; if you disable hotplug you will have to load the drivers yourself - like, by adding a "modprobe" line to /etc/rc.d/rc.modules.
So, don't complain that your card does not work because you have to run run rc.hotplug manually.

I really don't understand what it is you're trying to convey here.

Eric
 
Old 12-02-2006, 05:09 AM   #8
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 917
Blog Entries: 5

Rep: Reputation: 148Reputation: 148
Alien Bob,

Quote:
I really don't understand what it is you're trying to convey here.
I don't know if your comment was addressed to me or to cristianpaul.

As cristianpaul is a newbie, I assume that it was for me.

First I don't take any offense to your remark, so here I try to explain my point:

- if you don't want to have hotplug automatically running at boot time to detect a PCI card that is always here and at the same time to save boot time, it's better to add a line in /etc/rc.modules once and for all to load the driver.
- I hoped that cristianpaul would be more than happy to learn that tip (e.g. add a modprobe line in /etc/rc.modules to load a driver).

That's all.
 
Old 12-02-2006, 05:19 AM   #9
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,753

Rep: Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336Reputation: 6336
I did not mean to sound harsh, so I'll try to be a bit clearer on my part - no offense was intended indeed.
The term "hotplug" is a bit misleading since hotplug is also used for "coldplugging", i.e. discovering hardware during boot and loading the apropriate drivers for it.
So, although disabling hotplug can make your system boot up faster (because the hardware discovery phase is skipped) you will have to do the hardware "discovery" yourself, and add commands to the rc scripts that load the drivers for your hardware. This is usually a one-time job: the time when you install Slackware.
Hotplug, and now udev, were designed to make running linux easier, but they are not required. They do have the potential to give you a computer where Linux will run out of the box with all hardware recognized and supported.

Eric
 
Old 12-02-2006, 06:16 AM   #10
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.2 64bit
Posts: 917
Blog Entries: 5

Rep: Reputation: 148Reputation: 148
Alien Bob,

I was sure your intentions were fine (Pat would not authorize a flame-thrower to have his own space on his site). Thank you for the explanation.

Now christianpaul, it's up to you:

- either you activate hotplug to run automatically at boot to detect your card. For that, type in a root: chmode +x /etc/rc.d/rc.hotplug
- or you prefer to load your driver using rc.modules, in this case provide the information requested.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration