LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-22-2003, 08:19 AM   #1
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
ethernet module errors


This is repeated 5 or 6 times during boot. My ethernet connection works, but I want to get rid of these errors:

insmod: lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz: init module: No such device
insmod: lib/modules/2.4.20/kernel/drivers/net/8139cp.o.gz: insmod 8139cp failed
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)

dmesg:
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)

Thanks in advance.
 
Old 05-22-2003, 09:15 AM   #2
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
You have a Realtek 8139 ethernet card and there are two kernel modules for these cards, 8139too and 8139cp. This error occurs because hotplug gets confused between the two, just add 8139cp to /etc/hotplug/blacklist to make the error go away.
 
Old 05-22-2003, 09:32 AM   #3
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Original Poster
Rep: Reputation: 30
Now that you mention it I remember 8139too being the one used for setup/install. Thank you very much.
 
Old 05-22-2003, 07:00 PM   #4
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Your welcome.

PS: I have an 8139 card and saw the same message :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet module Pipedream Linux - Newbie 2 02-06-2005 06:57 PM
Arch 0.7 via-velocity ethernet module? shoddy Arch 3 08-31-2004 02:37 PM
Which Module Do I need For Onbord Ethernet Adapter? Nukem Slackware 2 04-09-2004 12:25 PM
need a module for nforce2 ethernet compatible with 2.4.22 fixxxer0101 Slackware 10 10-14-2003 07:19 PM
Module Errors mikeyt_333 Linux - General 2 01-29-2002 04:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration