-   Slackware (
-   -   eth0 in slackware (

leeman_s 07-31-2003 09:55 AM

eth0 in slackware
I'm trying to configure my network to acess the internet. I used netconfig and can acess other machiens on my network, but not the internet. I think the gateway isn't set.

I type route:

Destination | Gateway *

1) What is the destination? (What is it for?)

2) How do I put in a gateway?

I tried 'route add default dev eth0'

doesn't work.


neenee 07-31-2003 09:59 AM

try running 'netconfig' as root, and after that 'ifconfig'
to check if it's up.

leeman_s 07-31-2003 10:09 AM

Ok, it works now!

route add -net 0/0 gw netmask

but now i have a bunch of entries i don't want

1) How do I delete the other entries?

2) Why didn't netconfig do this for me? It asked for my gateway and netmask.....?

leeman_s 07-31-2003 10:27 AM

Ok actually that didn't work, but the entry that works is the one with for the netmask...go figure.

Now, how do I delete entries?

jharris 07-31-2003 11:06 AM

netconfig should have asked you for the details of your gateway that should be all thats needed so long as the gateway is setup with NAT/IP-Masq to allow you out onto the web.

Post the output of ifconfig, route -n and tell us what the IP address of your gateway is.



Evilone 08-01-2003 03:28 AM

edit the file /etc/rc.d/rc.inet1

Thats where all your entries IP related go

edit /etc/resolv.conf thats where your dns and search paths are

edit /etc/hosts this is your hosts file where it names your pc

All times are GMT -5. The time now is 06:32 PM.