LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-02-2018, 02:25 PM   #1
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 42

Rep: Reputation: 7
Question Eth0 change from dhcp to static IP: rc.inet1 eth0_restart leaves the old IP and add the new one


Hello all,
I'm playing with a remote computer (well, only few steps from my chair): I'm connected via ssh and I changed rc.inet1.conf to change from a dhcp assigned IP to a static IP address and viceversa. In both cases I noticed that, after the change and a call to rc.inet1 eth0_restart, the interface holds two IP addresses: the old one and the new and I also did not loose the ssh connection. A check with ifconfig eth0 showed me only the new IP address, but calling ip address show had display both.
After a reboot only the new address is available.
I do not think this is the correct behaviour of the thing but I'm not able to see what I made the wrong way.
Any suggestion?

Thanks

Edit: the machine is running 14.2 64

Last edited by VicFer; 02-02-2018 at 02:27 PM. Reason: slackware version
 
Old 02-02-2018, 08:28 PM   #2
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,633

Rep: Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925
The outputs of ifconfig eth0 & ip ad sh eth0 & ip ro sh will be helpful. Clean/Edit the MAC Addresses before you post them.
Increasing the sleep time to 2 or 3 seconds in the rc.inet1 script might help, even adding a sleep timer between if_up $INTERFACE
and gateway_up can help if you have a lazy DHCP server(router):
Code:
*_restart) # Example: "wlan0_restart" will take 'wlan0' down and up again
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  sleep 1
  if_up $INTERFACE
  gateway_up
  ;;
Just to make sure it's the rc.inet1 script and not your network/router, try changing the ip address manually and locally (you might loose the ssh link) with:
Code:
/sbin/dhclient eth0
 
Old 02-03-2018, 06:37 AM   #3
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 7
Thank you abga,
today I did not have much time to test. I tried to increase the sleep time (5 seconds) between the if_down and the if_up commands and I also added a sleep(5) between if_up and gateway_up, but when I switch from static IP to dhcp assigned IP the machine still holds the static IP address.
I did not clean the MAC address, I don't know how to do this, but I will search for info and next monday I will make other tests.

Thanks again
 
Old 02-03-2018, 07:28 AM   #4
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 7
I think it is better to clarify what I've done so far.
first of all: the machine has an IP address and I was connected to it via ssh
I edited rc.inet1
Code:
*_restart) # Example: "wlan0_restart" will take 'wlan0' down and up again
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  sleep 5
  if_up $INTERFACE
  sleep 5
  gateway_up
  ;;
then I changed rc.inet1.conf to assign a static IP address to eth0 and then ran a script that executed
Code:
/etc/rc.d/rc.inet1 eth0_restart
killall dhcpcd
I lost the ssh connection so I reconnected and the only valid IP was the dhcp assigned, so far so good.
After that I changed rc.inet1.conf again to set eth0 for a static IP address and I ran again
Code:
/etc/rc.d/rc.inet1 eth0_restart
This time I did not loose the ssh connection, I saw the messages of the dhcpcd in the console and I was able to start ssh connection to both IP addresses.

Hope this is more clear.
Bye
 
Old 02-03-2018, 05:56 PM   #5
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,633

Rep: Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925
Quote:
Originally Posted by VicFer View Post
Thank you abga,
today I did not have much time to test. I tried to increase the sleep time (5 seconds) between the if_down and the if_up commands and I also added a sleep(5) between if_up and gateway_up, but when I switch from static IP to dhcp assigned IP the machine still holds the static IP address.
I did not clean the MAC address, I don't know how to do this, but I will search for info and next monday I will make other tests.

Thanks again
- I was asking for the output of some commands and suggested to clean the MAC before you post the output on this forum, you don't need to clean any MAC address on your system.


Quote:
Originally Posted by VicFer View Post
I think it is better to clarify what I've done so far.
first of all: the machine has an IP address and I was connected to it via ssh
I edited rc.inet1
Code:
*_restart) # Example: "wlan0_restart" will take 'wlan0' down and up again
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  sleep 5
  if_up $INTERFACE
  sleep 5
  gateway_up
  ;;
then I changed rc.inet1.conf to assign a static IP address to eth0 and then ran a script that executed
Code:
/etc/rc.d/rc.inet1 eth0_restart
killall dhcpcd
- I guess you wanted to write that the machine had a static IP address and you were able to connect on ssh to it, then edited the rc.inet1.conf to asign a dynamic IP address and ran:
Code:
/etc/rc.d/rc.inet1 eth0_restart
killall dhcpcd
Quote:
Originally Posted by VicFer View Post
I lost the ssh connection so I reconnected and the only valid IP was the dhcp assigned, so far so good.
Indeed, so far so good.

Quote:
Originally Posted by VicFer View Post
After that I changed rc.inet1.conf again to set eth0 for a static IP address and I ran again
Code:
/etc/rc.d/rc.inet1 eth0_restart
This time I did not loose the ssh connection, I saw the messages of the dhcpcd in the console and I was able to start ssh connection to both IP addresses.

Hope this is more clear.
Bye
Here is were things are getting a little messy. In my first reply I specifically asked for the output of the following commands (and suggested to clean the MAC address before you post them - protecting your privacy):
Code:
ifconfig eth0
ip ad sh eth0
ip ro sh
- I suspect that you get an IP alias in your second example, an eth0:0 interface, that will explain why you have two IP addresses and why you were still able to stay connected on ssh after the DHCP address assignation. Note that ifconfig eth0 won't show you the eth0:0 interface( only ifconfig -a ), but ip ad sh eth0 will, and will also show you the two IP addresses. I also suspect that in your second example you have both a static IP and the DHCP enabled in rc.inet1.conf and while this is not a normal/standard configuration, when you issue:
Code:
/etc/rc.d/rc.inet1 eth0_restart
the alias is created - eth0:0 with the second IP address.

P.S. I just hope that you don't use NetworkManager and don't have it running while playing with rc.inet1

Last edited by abga; 02-03-2018 at 06:00 PM. Reason: added - P.S.
 
Old 02-03-2018, 07:35 PM   #6
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,633

Rep: Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925
To make sure that however "non-standard" you configure your rc.inet1.conf the DHCP will be stopped/flushed, edit the rc.inet1 and use this restart version:
Code:
*_restart) # Example: "wlan0_restart" will take 'wlan0' down and up again
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  /sbin/dhcpcd -k $INTERFACE
  #or simpler, affecting all interfaces that might have a DHCP lease: /sbin/dhcpcd -k 
  sleep 1
  if_up $INTERFACE
  gateway_up
  ;;
 
Old 02-05-2018, 04:54 AM   #7
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 7
Hello abga,
sorry for my incomplete/erroneous answers.
Today I try to be more clear.

First of all: no NetworkManager.
My system need to change from static IP to dhcp assigned IP via a simple script. I have two files for the configuration, see below the relevant parts:
rc.inet1.conf.static
Code:
# Config information for eth0:
IPADDR[0]="192.168.2.24"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY="192.168.2.1"
rc.inet1.conf.dhcp
Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""
The script I use to change from static to dhcp, and vice versa, is shown below. Please note it need one parameter, either "static" or "dhcp" to do its job
Code:
#!/bin/bash

if [ -z "$1" ]; then
	exit 1
else
	if [[ "$1" == "dhcp" || "$1" == "static" ]]; then
		rm /etc/rc.d/rc.inet1.conf
		if [ "$1" == "dhcp" ]; then
			/usr/bin/ln -s /etc/rc.d/rc.inet1.conf.dhcp /etc/rc.d/rc.inet1.conf
		else
			/usr/bin/ln -s /etc/rc.d/rc.inet1.conf.static /etc/rc.d/rc.inet1.conf
		fi
		/etc/rc.d/rc.inet1 eth0_restart
		exit 0
	else
		exit 1
	fi
fi
As you suggested I also modified rc.inet1 as
Code:
*_restart) # Example: "wlan0_restart" will take 'wlan0' down and up again
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  /sbin/dhcpcd -k $INTERFACE
  sleep 1
  if_up $INTERFACE
  gateway_up
  ;;
Today I turn on the machine with a static IP configured, and these are the output of the commands you suggested.
I did ifconfig -a because you wrote
Quote:
Note that ifconfig eth0 won't show you the eth0:0 interface( only ifconfig -a )
and I wanted to give you as more informations as possible
Code:
root@darkstar ~ #  /sbin/ifconfig -a
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.24  netmask 255.255.255.0  broadcast 192.168.2.255
        ether xx:xx:xx:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 5007  bytes 433525 (423.3 KiB)
        RX errors 0  dropped 100  overruns 0  frame 0
        TX packets 4937  bytes 6237215 (5.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 55  base 0xb000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 2  bytes 140 (140.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2  bytes 140 (140.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Code:
root@darkstar ~ #  /sbin/ip address show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.24/24 brd 192.168.2.255 scope global eth0
Code:
root@darkstar ~ #  /sbin/ip route show       
default via 192.168.2.1 dev eth0  metric 1 
127.0.0.0/8 dev lo  scope link 
192.168.2.0/24 dev eth0  proto kernel  scope link  src 192.168.2.24
When I executed my script with the parameter "dhcp" I did not loose the ssh connection, I saw this on the console (last week I disabled the ipv6 via the kernel command line, to check if this was part of the problem)
Code:
 root@darkstar ~ #  ./myscript.sh dhcp
dhcpcd not running
Polling for DHCP server on interface eth0:
all: IPv6 kernel autoconf disabled
eth0: adding address xxxx::xxxx:xxxx:xxxx:xxx
if_addaddress6: Operation not supported
eth0: waiting for carrier
eth0: carrier acquired
all: IPv6 kernel autoconf disabled
DUID xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx
eth0: IAID xx:xx:xx:xx
eth0: soliciting a DHCP lease
eth0: offered 192.168.2.23 from 192.168.2.1
eth0: leased 192.168.2.23 for 21600 seconds
eth0: adding route to 192.168.2.0/24
eth0: adding default route via 192.168.2.1
forked to background, child pid 2976
the output of the commands were
Code:
root@darkstar ~ #  /sbin/ifconfig -a
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.24  netmask 255.255.255.0  broadcast 192.168.2.255
        ether xx:xx:xx:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 5773  bytes 520393 (508.1 KiB)
        RX errors 0  dropped 160  overruns 0  frame 0
        TX packets 5117  bytes 6260241 (5.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 55  base 0xb000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 2  bytes 140 (140.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2  bytes 140 (140.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Code:
root@darkstar ~ #  /sbin/ip address show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.24/24 brd 192.168.2.255 scope global eth0
    inet 192.168.2.23/24 brd 192.168.2.255 scope global secondary eth0
Code:
root@darkstar ~ #  /sbin/ip route show
default via 192.168.2.1 dev eth0  metric 202 
127.0.0.0/8 dev lo  scope link 
192.168.2.0/24 dev eth0  proto kernel  scope link  src 192.168.2.23  metric 202
Then I re-run my script with the parameter "static" and I still remained connected but the situation changed
Code:
root@darkstar ~ #  /sbin/ifconfig -a
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.2.24  netmask 255.255.255.0  broadcast 192.168.2.255
        ether xx:xx:xx:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 6893  bytes 622334 (607.7 KiB)
        RX errors 0  dropped 207  overruns 0  frame 0
        TX packets 5300  bytes 6293179 (6.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 55  base 0xb000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 2  bytes 140 (140.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2  bytes 140 (140.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Code:
root@darkstar ~ #  /sbin/ip address show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.24/24 brd 192.168.2.255 scope global eth0
Code:
root@darkstar ~ #  /sbin/ip route show
default via 192.168.2.1 dev eth0  metric 1 
127.0.0.0/8 dev lo  scope link 
192.168.2.0/24 dev eth0  proto kernel  scope link  src 192.168.2.24
I hope this is more clear, thank you for the help

Last edited by VicFer; 02-05-2018 at 04:58 AM. Reason: NetworkManager
 
Old 02-06-2018, 01:48 AM   #8
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,633

Rep: Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925
Quote:
Originally Posted by VicFer View Post

Code:
 root@darkstar ~ #  ./myscript.sh dhcp
dhcpcd not running
Polling for DHCP server on interface eth0:
all: IPv6 kernel autoconf disabled
eth0: adding address xxxx::xxxx:xxxx:xxxx:xxx
if_addaddress6: Operation not supported
eth0: waiting for carrier
eth0: carrier acquired
all: IPv6 kernel autoconf disabled
DUID xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx
eth0: IAID xx:xx:xx:xx
eth0: soliciting a DHCP lease
eth0: offered 192.168.2.23 from 192.168.2.1
eth0: leased 192.168.2.23 for 21600 seconds
eth0: adding route to 192.168.2.0/24
eth0: adding default route via 192.168.2.1
forked to background, child pid 2976
the output of the commands were

Code:
root@darkstar ~ #  /sbin/ip address show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.24/24 brd 192.168.2.255 scope global eth0
    inet 192.168.2.23/24 brd 192.168.2.255 scope global secondary eth0
The two sections above helped me to understand the problem and finally get a solution for it, you've got me what I was needing now

Your two IP Addresses assignation was confusing, because you stated that you use Slackware 64 14.2 and not -current, only the latter having the rc.inet1 using ip instead of ifconfig. ifconfig is not able to assign a second IP Address to an interface without an alias (eth0:0 for example), but ip address add can and it will add a temporary IP Address to an interface without using the alias eth0:0, available until a reboot, exactly like in the above section and in your initial reporting. The DHCP client dhcpcd presumably is using the "ip address add" internally and assigned a temporary IP address because the interface configuration was never flushed - although in rc.inet1 - the function if_down should do that, even bringing down the interface (action that will flush the existing interface configuration).

My first hint, to manually add (it is already contained in the function if_down from rc.inet1, but I thought it's not properly applied/executed) the "/sbin/dhcpcd -k $INTERFACE" flushed the primary IP Address but not the secondary (temporary one):
https://wiki.archlinux.org/index.php...asing_IP_first

Resolution:
- the dhcpcd has a configuration file that apparently is missing a key option (WHY?) that will not allow dhcpcd to assign a temporary IP Address on an interface that already has an IP Address assigned. This option called " noalias" will instruct dhcpcd to flush the existing IP Address and assign a new one, thus resolving your reported issue.
Reference:
https://www.daemon-systems.org/man/dhcpcd.conf.5.html
- edit /etc/dhcpcd.conf and add somewhere the directive:
Code:
noalias
- stop dhcpcd (kill), remove your temporary address "ip addr del XXX.XXX.XXX.XXX dev eth0" or "ip addr flush dev eth0" and test your script again

Last edited by abga; 02-06-2018 at 02:47 AM. Reason: typo x 2
 
1 members found this post helpful.
Old 02-06-2018, 06:15 AM   #9
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 7
Thank you very much abga.
Your suggestions solved the issue.
I modified /etc/dhcpcd.conf and added the noalias option.
I also modified rc.inet1 as follow
Code:
*_restart) # Example: "wlan0_restart" will take 'wlan0' down and up again
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  /sbin/dhcpcd -k $INTERFACE
  /sbin/ip address flush dev eth0
  sleep 1
  if_up $INTERFACE
  gateway_up
  ;;
and now my box change IP address the right way.
Thanks again, bye
 
Old 02-06-2018, 07:31 AM   #10
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,633

Rep: Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925
Quote:
Originally Posted by VicFer View Post
Thank you very much abga.
Your suggestions solved the issue.
I modified /etc/dhcpcd.conf and added the noalias option.
I also modified rc.inet1 as follow
You're welcome!
Adding noalias in /etc/dhcpcd.conf should suffice, no need for other editing of rc.inet1
 
Old 02-06-2018, 10:13 AM   #11
VicFer
Member
 
Registered: Sep 2012
Location: Italy
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 7
OK, thank you
 
Old 02-06-2018, 03:28 PM   #12
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,633

Rep: Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925Reputation: 925
Raised the issue in the Requests for -current thread. That thread is pretty busy touching a lot of subjects, but I hope it will get looked at and eventually resolved:
https://www.linuxquestions.org/quest...ml#post5816535
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware Devs: Please add no-MTU setting for DHCP in rc.inet1 SiegeX Slackware 3 05-31-2010 04:32 PM
Eth0 using DHCP and eth1 using static ip: eth0 receive internal ip not the router ip geraldomanaus Linux - Networking 3 04-23-2008 04:00 PM
How do I change from DHCP to static IP? walterbyrd Debian 3 05-11-2006 07:58 PM
eth0 can't get IP with DHCP, static config. attempts can't ping pdt677 Linux - Networking 6 03-06-2005 10:53 PM
Eth0 set up for Static, obtaining DHCP address?! IndustrialGeek Linux - Networking 2 01-03-2005 01:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration