LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   /etc/udev/permissions.d on Slack ? (https://www.linuxquestions.org/questions/slackware-14/etc-udev-permissions-d-on-slack-385023/)

Kocil 11-20-2005 11:00 PM

/etc/udev/permissions.d on Slack ?
 
Hi Slackers.

I'm trying to install jack audio connection kit and oss2jack on Slack 10.2,
unfortunatelly, using the HOWTO for Gento/Ubuntu.

http://fort.xdas.com/~kor/oss2jack/install.html


The howto said, we need to put a permission file for fusd
in the /etc/udev/permissions.d folder.

I can't find it on Slack. So where is the proper place ?


Thanks.

P.S.
I could make the system works by manually using:
chgrp audio /dev/fusd/*

The permission file is suppossed to do it automatically.

keefaz 11-21-2005 06:33 AM

Try add in yout /etc/udev/rules.d/udev.rules or better in a custom
rules file, with a number in filename so it is loaded before any rules,

for example : /etc/udev/rules.d/10_kocil.rules
Code:

SUBSYSTEM="fusd", GROUP="audio"
KERNEL="control", NAME="fusd/%k", MODE="0660"
KERNEL="status", NAME="fusd/%k", MODE="0660"


PDock 11-21-2005 06:51 AM

Pretty sure permission.d files are used by PAM which Slackware does not use. Have absolutely no experience with your device or messing with udev but if you have a rescue disk handy in the event the following fubars your system try:

Quote:

Most modern distributions have a special directory that is searched for udev rules. This path (and the permissions path) is specified in the udev configuration file. On Ubuntu, this is at /etc/udev/rules.d/. Rather than editing the main rules file (which could be overwritten by the distribution), it is better to create a new file in the rules directory. Create a file named fusd.rules in your rules directory, containing the following line:
The next section refers to control and status so try adding two lines to your new file /etc/udev/rules.d/fusd.rules :
Code:

SUBSYSTEM="fusd" , KERNEL="control" , NAME="fusd/%k" , GROUP="audio" , MODE="660"
SUBSYSTEM="fusd" , KERNEL="status" , NAME="fusd/%k" , GROUP="audio" , MODE="660"

Keep that rescue disk handy cause I'm winging it here

good luck

Youdaman 11-29-2005 03:57 AM

I'm running CRUX 2.1 (converted from devfs to udev) and I have fusd subsystem working using the following in /etc/udev/rules.d/fusd.rules:
Code:

# /etc/udev/rules.d/fusd.rules

SUBSYSTEM=="fusd", NAME="fusd/%k", GROUP="users"
KERNEL=="control", NAME="fusd/%k"
KERNEL=="status", NAME="fusd/%k"

It's basically a mix of the line from the oss2jack page, the posts above, and the format of the existing /etc/udev/rules.d/50-udev.rules on my system (note the "==" for the first entry on each line).
I added
Code:

modprobe kfusd
to my /etc/rc.local to load the fusd module at boot time, and commented out
Code:

#modprobe sound-service-0-3
because on my system sound-service-0-3 is an alias for the snd-pcm-oss module and according to the oss2jack installation you shouldn't have it loaded.
I then run:
Code:

jackd -d alsa &
oss2jack &

as a regular user (note the "GROUP" is set to "users" above) which creates a /dev/dsp device. I can play quake3 whilst listening to mp3s now! I have noticed using oss2jack is that there are momentary pauses when accessing menus in firefox and things like that which might require some extra processing power and thus interrupt oss2jack a little. One thing I still have to get working is ventrilo or teamspeak. oss2jack was supposedly a solution to the game+voip problem with dodgy sound cards (mine's a intel8x0, otherwise known as an ac97). At the moment I can't hear any output from ventrilo (I can without fusd/jackd/oss2jack -- with the old oss/alsa pcm drivers, but not now). It's probably something simple in the settings of one of the above, so I'll keep trying.


All times are GMT -5. The time now is 09:02 PM.