-   Slackware (
-   -   Errors loading modem drivers (

salted 11-12-2003 10:55 PM

Errors loading modem drivers
Hey all, I'm kinda new here. I've been a user of linux for around a year now I suppose, so I'm not new to this, but I am new to this error. I just bought a new hard drive (Seagate 80GB) and decided to put Slackware 9.1 on it to see how it is. On my old hard drive I had Slackware 8.1. Anyway, I tried to load my lucent winmodem drivers (it sucks, but I have to use it), and when I run ./checkout I get the following error:

/dev/ttyLT0 does not EXIST!

Earlier it had me run the command rm -f /dev/modem; ln -s /dev/ttyS0 /dev/modem2

On my 8.1 box it always had me do this and everything ran perfectly, so I'm curious as to how I may get the drivers to either point to /dev/modem2 or something else that will make it work. When I query modem in KPPP it says "Unable to open modem" under /dev/modem and /dev/ttyS0, but on /dev/ttyS1 - /dev/ttyS* it seems to say "The modem is busy."

Any help is appreciated, and I can't post output logs as I'm on my mom's XP machine upstairs, but I can try and get the general idea to you guys.

I just found to run minicom -s. That didn't work either when I changed the serial port settings to /dev/modem2 and /dev/ttyS0. I also tried changing the port and then reinstalling the drivers, but it keeps installing /dev/ttyLT0 and making a symlink to /dev/modem.


adz 11-13-2003 06:27 AM

Can't you use /dev/ttyLT0? It says that the device does not exist. Is this your problem? That the driver tries to use ttyLT0 but it doesn't exist? Have you made sure the module is loaded? Try going to /dev and do a ./MAKEDEV ttyLT0. That should create the device. Although the installer should do this for you. Since it didn't, it may be a clue that something else is wrong. Did you get any other errors or warnings throughout the entire installation process? What is involved in the installation process.

Btw, I've tried helping someone else with some sort of ltmodem. They seem to like to use non-standard ports. This other one wanted to make a /dev/ttyS14 device. They seem to be just generally wierd.

salted 11-13-2003 03:15 PM

Ok, I went to /dev and did ./MAKEDEV ttyLT0, but I get the error message

"./MAKEDEV: Don't know how to make device "ttyLT0."

After this I decided to try ./autoload (the program's make and make install loaded into one) and it tells me that there's already an entry for "ttyLT0," but it is going to overwrite the file. It then changes permissions of the file to uucp, and continues loading fine as normal.

The problem comes up when I type ./checkout (I'm guessing like a make check), and that's when I get the error. Oh, and that's the only error I'm getting.

I also tried dmesg |grep ppp; dmesg |grep ttyLT0 and didn't get any messages.


salted 11-13-2003 07:05 PM

Sorry, I also tried to change the serial port in minicom to /dev/ttyLT0, and after I exited, it said cannot find /dev/ttyLT0

adz 11-13-2003 07:34 PM

Hmmm... yeah it's not a standard port so it wouldn't know how to make it. I was kinda hoping for some luck. Could you post the autoload and checkout scripts? We'll see what they do.

salted 11-13-2003 08:01 PM

This may take awhile. I have a Win2kPro partition, but that also doesn't have my drivers for this modem. Right now I'm on my mom's XP box, but I can try to do this.

Also, now I'm getting all kinds of errors. When I set the serial port to /dev/ttyLT0 and save, terminal says

"minicom: error loading device /dev/ttyLT0: no such device"

Which is odd because I've loaded it (I think) and it shows up linked to /dev/modem when I ls- l /dev/ttyLT0. Another thing I've tried are the following commands, but I'm sure it didn't do anything.

mknod /dev/ttyLT0 c 62 64
chgrp uucp /dev/ttyLT0
chmod 666 /dev/ttyLT0

Anyway, I'll try and get this script up, but I'm not sure how logn it'll take.

salted 11-13-2003 09:26 PM

Yeah...I can't get the logs up here, no floppy or CD burner. I opened up X and saw that I do have a /dev/ttyLT0, but everytime I try to run the checkout script it says it doesn't exist. So...I'm a bit lost; it says it's not there, but it is.


adz 11-14-2003 01:05 AM

The only other thing I can think of is check the module. Type lsmod as root and look for the name of the module in the output. If it's NOT there then type modprobe <module name>. You do not include the path to the module nor do you include the ".o" extension. If you still have problems try modinfo <module name> to see what parameters you can specify while loading the module.

salted 11-16-2003 03:55 PM

Ahh...didn't work. Any more ideas? Sorry for the late reply; I've been gone. Is there a way I can create /dev/modem and /dev/ttyLT0 at all or am I just pretty much done?

I went and tried it again, and for some reason it actually gave me an error that could help out. It said that the driver I'm using was compiled using Gcc 2, and that 9.1 uses GCC 3, but this is known to cause errors. After that it listed the path name and then said initialization of driver failed. So, is there anything I can do now?


salted 11-16-2003 06:32 PM

I just tried insmod -f lt_modem and the other one to force the load. I then rebooted and typed in lsmod, and the module still wasn't listed. I also downloaded a newer version (8.26 as opposed to 6.00) from my friend's house, but that didn't work either. Any more help is appreciated.


adz 11-16-2003 06:59 PM


I just tried insmod -f lt_modem and the other one to force the load. I then rebooted and typed in lsmod, and the module still wasn't listed.
You can't try to insert a module and reboot and expect it to still be there.


It said that the driver I'm using was compiled using Gcc 2, and that 9.1 uses GCC 3, but this is known to cause errors.
The gcc version thing could indeed be the problem. Do a cat /proc/version to find out the version of gcc that was used to compile your kernel. Then do a gcc --version to find out what version of gcc you currently have. If they don't match then get yourself a copy of the gcc that was used on your kernel. You can have more than one version of gcc on your computer if you like. Make sure, though that the gcc symlink points to the version that you want to use.


Is there a way I can create /dev/modem and /dev/ttyLT0 at all or am I just pretty much done?
Well /dev/modem is just a symlink. That's easy. You need to get the installation program to create the /dev/ttyLT0 somehow. The gcc thing looks promising.

shepper 11-16-2003 09:48 PM

Your are making this way too hard.

There is a linux ltmodem driver right here that works well. You must have kernel sources installed for this to work. For Slackware get the *tar.gz file, uncompress the file and follow the instructions.

Linux LTmodem

There is basically an installation script "./build-module" that will walk you through the installation steps. The author put alot of time into writing this script as he believed newbie's needed to get an internet connection rather than a RTFM. This script compiles the modules, installs the modules and sets up /dev/modem to link to /dev/ttyLT0 and writes your modules.conf to autoload the modem modules.

DonLuis 11-16-2003 11:05 PM

Shepper's right, that fellow did an outstanding job.

You may want to do a search on " Tecra 8100 Windmodem " and see how I did it and what's needed.

I should have titled it Lucent LT Modem (for search purposes).

salted 11-17-2003 08:50 PM

Well, I'm making the 2.* gcc right now.

I realize that there is a script out there that automatically does this. I'm almost positive that this is what I have right now. I ./build_module, ./ltinst2, ./autoload, and ./checkout which worked beautifully on my 8.1 box. I realize that it should be working and building /dev/modem and /dev/ttyLT0, but it's not. However, these may not be the same scripts, but I do not know because I keep getting an Internal Server error on the page (500). Thanks for the help, but if it's the same thing I have (ltmodem-6.00.tar.gz and ltmodem-8.29a.tar.gz) then it's not working with 9.1.

Thanks, I'll search for that now; I just haven't had time. I'll post back and see if it works.

Finished making and installing gcc 2.95. Now, when I try to load the modules via ./build_module, ./ltinst2, ./autoload, it spits out an error on autoload that the gcc version I'm using is 2.x, and that the kernel runs a 3.x, so it automatically stops itself from going any further. I've tried gcc -V 3.2.3 (the version that came installed) and gcc- c <pathtodriver>, and gcc -S <pathtodriver>, but it hasn't done anything.

Also, while at a friend's house I downloaded a slightly newer script of ltmodem, and it has a 2.4.22 kernel folder, and I think that that may be useable, but I have no idea how to reset my gcc back to 3.2.3. I dunno, I'm really confused now.


adz 11-17-2003 09:25 PM

/usr/bin/gcc is usually a symlink. Do a ls -l gcc* in /usr/bin to check. When I do so I get:

lrwxrwxrwx 1 root root 8 Oct 19 12:51 gcc -> gcc-2.95
-rwxr-xr-x 1 root root 74088 Oct 15 17:23 gcc-2.95
-rwxr-xr-x 1 root root 84748 Oct 17 21:23 gcc-3.3
-rwxr-xr-x 1 root root 49004 Apr 1 2001 gcc272
lrwxrwxrwx 1 root root 10 Oct 19 01:33 gccbug -> gccbug-3.3
-rwxr-xr-x 1 root root 15986 Oct 17 21:12 gccbug-3.3

You'll notice I have both gcc-2.95 and 3.3 but I use 2.95 by default. However if I want to use 3.3 then I type gcc-3.3 <arguments>.

PS: Are you sure you don't have/can't get an external modem from somewhere? They're brilliant. No drivers, no bullshit, no worries.

All times are GMT -5. The time now is 05:01 PM.