-   Slackware (
-   -   Errors after upgrading to current, can't start X, slackpkg or vim (

Miranden 07-19-2013 07:22 PM

Errors after upgrading to current, can't start X, slackpkg or vim

I just tried upgrading to 64-current on my laptop, which has successfully run it before (about a month ago). I added a current mirror and then did this:


slackpkg update
slackpkg install-new
slackpkg upgrade-all

Then I did slackpkg upgrade-all again.

When I came out of the upgrade, things were broken. The first thing I did was rerun lilo and reboot to get to the new kernel, but when it came to the login screen, nothing I typed was input. I pressed letter keys and nothing happened. I did a hard reset and came back to the login screen again. This time I could type.

Once inside, I tried to use vim to open /etc/lilo.conf and it would not work. I got an error that said:


vim: error while loading shared open shared object file: No such file or directory
I tried to start slackpkg again to see if it saw missing packages on my system, and it said that I had not chosen a mirror (which of course I had, because I had used it before). So I used nano to go back and uncomment my mirror again.

But when I tried to run slackpkg update again, it said


wget: error while loading shared libraries: cannot open shared object file:No such file or directory
grep: /tmp/slackpkg.a6WX9Y/ChangeLog.txt: No such file or directory

Then just to see I tried to start X. It didn't work.

Does anyone know what went wrong? Thank you!

willysr 07-19-2013 08:11 PM

You had a partial upgrade
Try downloading pcre and gpm manually and perform upgradepkg on those two packages first

Miranden 07-19-2013 09:11 PM

Thank you. Do you mean the ones from here?

I found these by doing a google search for "gpm slackware current" (or pcre), finding some links from that show where the respective packages are in the directory structure (like this one, showing pcre is in "l":, and then going to the Slackware file tree on and looking in those locations. But somehow I don't think this roundabout process is what people who know what they are doing usually do. What would have been the best way to find them?

And would you mind telling me what about my errors told you I should go get these specific packages? I don't really understand.

Thank you very much! :)

willysr 07-19-2013 09:36 PM

Yes, those are the files missing on your system
you can try to use the official mirror at OSUOSL

Miranden 07-19-2013 10:31 PM

It worked! I downloaded the packages in Links (finally had a use for a text only browser), and slackpkg is over there slacking away right now, finishing upgrading the rest of my packages. From the looks of things it wants to reinstall almost my entire system. So thanks! I still wish I knew how you arrived at that, though . . .

And I don't actually understand what happened. Why would a partial upgrade break libraries I already had in the system? I get how a partial upgrade could happen if my internet cut out for some reason (it is indeed wireless), but why, then, would the packages that were in there before stop working? Vim worked fine before the upgrade, so I don't see why I would need the upgraded package for it to work afterwards. Do the packages get removed before they are downloaded? That seems unlikely.

And why wouldn't my keyboard work? That seems like a kernel thing . . .

I don't get it. :(

willysr 07-20-2013 12:42 AM

The packages are linked to the new libraries and your system doesn't have that new libraries (probably caused by the partial upgrade or any other reason), so it will not work anymore unless you satisfy the dependencies.

That's why slackpkg was rebuilt to enable DOWNLOAD_ALL=ON in the configuration file to prevent this situation to happen in the future.

Another solution is to have a local slackware mirror on your system and point slackpkg to that mirror instead of pointing to mirror on the public server. That way, you will not have any problem suppose your Internet connection was cut, since you already have all the packages in your local machine first. I would suggest to use AlienBOB's rsync script.

Miranden 07-20-2013 02:03 PM

Okay, I see. Thank you for explaining. I guess I didn't really understand what libraries were before. I found a good explanation here, though.

Now when I execute


ldd /usr/bin/vim
I can see all of the libraries that are required, including I understand better now.

I do think I will use Alien's rsync script to put up a local mirror of the Slackware tree. That will make things a lot smoother I think.

All times are GMT -5. The time now is 02:00 PM.