LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-20-2011, 08:04 PM   #1
gonzalezeb
LQ Newbie
 
Registered: Jan 2004
Location: Virginia
Posts: 5

Rep: Reputation: 0
Error with VI


I'm getting an awkward error with VI...


skipping 1 old session file
reading {file name}
Read {filename}, 160 lines, 3724 chars


Now this only comes up when I ssh into my system and run vi. If I run vi from the console I do not get this error.

Any suggestions would be appreciative

Last edited by gonzalezeb; 07-20-2011 at 08:37 PM.
 
Old 07-20-2011, 08:46 PM   #2
flamelord
Member
 
Registered: Jun 2011
Distribution: Arch Linux
Posts: 151

Rep: Reputation: 34
take a look at http://www.linuxquestions.org/questi...n-file-133190/, I don't know about why it only happens over ssh, but this thread is related to the same error message.
 
1 members found this post helpful.
Old 07-20-2011, 09:00 PM   #3
gonzalezeb
LQ Newbie
 
Registered: Jan 2004
Location: Virginia
Posts: 5

Original Poster
Rep: Reputation: 0
So, I actually tried that first...removing the elvis files did get rid of the "1 old session" error, but not the next two lines....

Here's is what I get, when I vi:



reading monthly_bgp_report.sh-2
Read monthly_bgp_report.sh-2, 42 lines, 1663 chars
#!/bin/bash

Note the first line in my script (#!/bin/bash) is indented....and that is all I can see. Can't even navigate the file.

Last edited by gonzalezeb; 07-20-2011 at 09:04 PM.
 
Old 07-21-2011, 02:27 PM   #4
Gavin Harper
Member
 
Registered: Feb 2010
Location: Finland
Distribution: Slackware
Posts: 169

Rep: Reputation: 24
Not being picky as I am sure you have your reasons, but why not Vim instead?

I am also assuming Vi and Vim are not being used interchangably.
 
1 members found this post helpful.
Old 07-21-2011, 07:41 PM   #5
gonzalezeb
LQ Newbie
 
Registered: Jan 2004
Location: Virginia
Posts: 5

Original Poster
Rep: Reputation: 0
That is correct.

Though, I have started to use vim, due to the issues with vi - unfortunately, crontab -e defaults to vi and not vim...so this is a real pain...
 
Old 07-21-2011, 07:51 PM   #6
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,833
Blog Entries: 1

Rep: Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229Reputation: 1229
Quote:
Originally Posted by gonzalezeb View Post
... unfortunately, crontab -e defaults to vi and not vim...so this is a real pain...
see this:
http://www.linuxquestions.org/questi...editor-395750/
 
1 members found this post helpful.
Old 07-21-2011, 08:49 PM   #7
Diantre
Member
 
Registered: Jun 2011
Distribution: Slackware
Posts: 515

Rep: Reputation: 228Reputation: 228Reputation: 228
Quote:
Originally Posted by gonzalezeb View Post
Though, I have started to use vim, due to the issues with vi - unfortunately, crontab -e defaults to vi and not vim...so this is a real pain...
Have a look at the crontab manpage:


Code:
Generally  the  -e  option is used to edit your crontab.  crontab will use the
editor  specified  by  your  EDITOR  or  VISUAL   environment   variable   (or
/usr/bin/vi) to edit the crontab.
I set vim as the default editor in my ~/.bashrc:

Code:
EDITOR=vim
VISUAL=$EDITOR
export EDITOR VISUAL
 
1 members found this post helpful.
Old 07-21-2011, 09:07 PM   #8
gonzalezeb
LQ Newbie
 
Registered: Jan 2004
Location: Virginia
Posts: 5

Original Poster
Rep: Reputation: 0
I've pretty much given up....

and have started to restore my system. Prior to deciding to rebuild, I kept running into other applications that use vi for their editor (i.e. mutt)...which ultimately was the deciding point to rebuild.

Upon rebuilding this system, I'll likely try Diantre suggestion in my bashrc file...I've never really played with vim, tell this occurred...I could definitely get used to it.

Thanks for all the help.

(BTW, I figured it out...at first I thought it was my 4yr old - early i caught him banging on the keyboard - But it turns out after upgrading my mac to OSX Lion yesterday, I needed to change the default terminal settings...)

Last edited by gonzalezeb; 07-21-2011 at 09:32 PM.
 
Old 07-22-2011, 03:20 AM   #9
gapan
Member
 
Registered: Feb 2007
Posts: 370

Rep: Reputation: 142Reputation: 142
vi is just a symlink to elvis. You can just point the symlink to vim instead.
Code:
# cd /usr/bin
# ln -sf vim vi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Google-Chrome Error (Error 9 (net::ERR_UNEXPECTED): Unknown error) smoooth103 Slackware 4 12-04-2010 07:42 PM
[SOLVED] php5 ./configure error: (FILENAME=- FNR=27) fatal error: internal error richinsc Linux - Software 2 07-08-2010 09:20 AM
Memory error: extended error chipkill ecc error rajivdp Linux - Hardware 1 12-07-2009 08:26 AM
Sendmail: eocket wedge , 504 error , dsn error, mail relay connection error djcs Debian 0 03-03-2009 12:41 AM
Suse CUPS error: cups(File)DoRequest error:client-error-bad-request smdonelan Linux - Hardware 6 04-17-2007 06:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration