-   Slackware (
-   -   error while loading shared libraries: cannot open shared object file (

coolrock 12-05-2006 11:03 PM

error while loading shared libraries: cannot open shared object file

I think there's a problem with my shared libraries, is there any way to troubleshoot it? Anyone can help? I was trying to make install on graphviz when this happened

Same thing happened when I was trying to run the net-snmp daemon as well.

Thanks in advance.


gilead 12-06-2006 03:51 PM

Sounds like there's a missing library. I don't use graphviz, but is there a README or INSTALL file with the sources that details the dependencies?

coolrock 12-06-2006 07:20 PM

I doubt it's the graphviz problem, more like unable to retrieve nor access the shared lib problem.

gilead 12-06-2006 08:11 PM

I didn't say it was a problem with graphviz - I said that the docs that come with graphviz should have information about what needs to be installed on your system for you to be able to compile it.

gani 12-07-2006 01:34 AM

If you compiled a program from source usaully it has a default --prefix=/usr/local and the dirctory name of the application will be appended when you installed the system at that prefix to become /usr/local/appname. Then all of the binaries (bin and sbin) and including libraries & includes are all there with 'lib' and 'include' directory names.

Even they are there installed, you will still need to add that path in /etc/ to enable the dynamic linker to find it on the cache.

# echo /usr/local/appname/lib >> /etc/
# ldconfig

xjlittle 12-13-2006 09:37 PM

Try ldd /path/to/ and check to make sure that it is in /etc/ If you need to add it to run ldconfig afterwards. Run ldconfig -p to see what libraries are linked.

wheaties_box 01-17-2007 05:10 PM

I don't know if you're still trying to get around this problem, but I ran into the same thing. In order to fix it, I had to make some symlinks. Once I did that, the make install worked fine.

Here are the symlinks I had to make:


ln -s /usr/local/lib/ /usr/lib/
ln -s /usr/local/lib/ /usr/lib/
ln -s /usr/local/lib/ /usr/lib/
ln -s /usr/local/lib/ /usr/lib/

All times are GMT -5. The time now is 10:18 PM.