-   Slackware (
-   -   Error when building texlive package from SlackBuild site (

mariner53 08-09-2013 10:55 AM

Error when building texlive package from SlackBuild site
I am running Slackware 14.0 and was wanting to install the ffmpeg package to handle some audio files. When I started to build the ffmpeg package it told me I needed to have tetex or texlive installed and texi2html in my path. I have tetex installed on my machine, but the only place I could find the texi2html file was as a part of the texlive downloads. So I decided to install texlive. I installed the libsigsegv package listed as a dependency and then tried to build the texlive package.

I get the following error messege:
-Wdeclaration-after-statement -Wno-unknown-pragmas
checking for clisp... clisp
checking for perl... perl
checking for latex... no
checking for elatex... no
checking for lambda... no
checking for pdflatex... no
configure: error: LATEX is required to build xindy rules
=== configuring in xindy failed
make[2]: *** [subutils] Error 1
make[2]: Leaving directory `/tmp/SBo/texlive-20120701-source/build/utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/texlive-20120701-source/build/utils'
make: *** [all-recursive] Error 1

Since tetex is installed I don't know why I am getting this message. Any assistance would be appreciated.

ponce 08-09-2013 11:11 AM

you don't need texlive to build ffmpeg: have a look at the faq and at the howto

Alien Bob 08-09-2013 11:13 AM

How did you become root? Using "su" or using "su -"? First is wrong, second is right.

Perhaps you need to read and then


Edit: ponce was faster this time ;-)

ponce 08-09-2013 11:14 AM

it was a matter of seconds :D

mariner53 08-09-2013 06:50 PM

Thanks I was using "su " as I normally do. Using "su -" worked for both ffmpeg and texlive.

All times are GMT -5. The time now is 02:51 PM.