LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-10-2015, 11:02 AM   #1
Sefid par
Member
 
Registered: Jul 2013
Location: Iran, Shiraz
Distribution: Slackware Current, Ubuntu server 18.04, Debian 9
Posts: 127

Rep: Reputation: 26
error: no (-I/usr/include -L/lib -lxc)


I want to install Octupus. I faced this error while configure stage.

Code:
no (-I/usr/include -L/lib -lxc)
configure: error: Could not find required libxc library ( >= v 2.0.0).
Octopus 4.1 needs libxc 2.0.x or 2.1.x;
I have tested with libxc 2.0.3 and 2.1.2.
libxc was installed successfully. But at installing Octopus (configure stage) by both versions got the same error.
Installed libxc with:
Code:
./configure
make
make install
I want to know the solution or more about error in order to find the solution.

Thanks a lot.

Last edited by Sefid par; 05-10-2015 at 11:11 AM.
 
Old 05-10-2015, 05:17 PM   #2
Keith Hedger
Senior Member
 
Registered: Jun 2010
Location: Wiltshire, UK
Distribution: Linux From Scratch, Slackware64, Partedmagic
Posts: 2,684

Rep: Reputation: 669Reputation: 669Reputation: 669Reputation: 669Reputation: 669Reputation: 669
could be the configure command, ./configure defaults to using /usr/local ( usully ) so the command from the octopus configure is looking in the wrong place for the include/lib files try using
Code:
./configure --prefix=/usr --libdir=/lib
to libxc
 
1 members found this post helpful.
Old 05-10-2015, 11:15 PM   #3
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Run:

Code:
./configure --help | less
Scroll and see options for libxc. 'q' to exit.
 
1 members found this post helpful.
Old 05-11-2015, 02:43 AM   #4
Sefid par
Member
 
Registered: Jul 2013
Location: Iran, Shiraz
Distribution: Slackware Current, Ubuntu server 18.04, Debian 9
Posts: 127

Original Poster
Rep: Reputation: 26
Good
I found that I should do "./configure --with-libxc-prefix=/opt/etsf"
Thanks Keith Hedger and veerain.
 
  


Reply

Tags
configure, library


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OPENNMS INSTALLATION ERROR -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 4 07-11-2011 12:06 PM
opennms installation error -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 2 07-08-2011 10:51 AM
please difference between /usr/include & /usr/local/include baxzius Linux - Software 2 07-09-2010 05:19 AM
repeated message (tty1): ASSERT: "i <= nodes" in /usr/lib/qt-3.1.2/include/qvaluelist megahard Linux - General 4 01-17-2006 10:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration