-   Slackware (
-   -   Error in Installing bluefish 2.2.3 on Slackware 14.0 (kernel 3.2.29) (

aherrys 12-23-2012 03:57 AM

Error in Installing bluefish 2.2.3 on Slackware 14.0 (kernel 3.2.29)
Hi all,

I have issue when I am trying to install bluefish 2.2.3 on the latest Slackware 14.0 (with custom kernel 3.2.29). Basically I downloaded the Bluefish 2.2.3 tar file and after untar it I did ./configure and make, however the make failed with the following error:


make[5]: Entering directory `/root/bluefish-2.2.3/src/plugin_about'
/bin/sh ../../libtool --tag=CC  --mode=compile gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DPKGDATADIR=\"/usr/local/share/bluefish\" -I. -I../../src    -g -O2 -Wall -pipe -I/usr/include/python2.7  -MT about.lo -MD -MP -MF .deps/about.Tpo -c -o about.lo about.c
libtool: compile:  gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/local/share/locale\" -DPKGDATADIR=\"/usr/local/share/bluefish\" -I. -I../../src -g -O2 -Wall -pipe -I/usr/include/python2.7 -MT about.lo -MD -MP -MF .deps/about.Tpo -c about.c  -fPIC -DPIC -o .libs/about.o
about.c:22:21: fatal error: gmodule.h: No such file or directory
compilation terminated.

I have installed both glib-1.2.10 and glib2-2.32-4 so the gmodule.h exist in both /usr/include/glib-1.2 and /usr/include/glib-2.0 but somehow the compile command cannot find them. If I manually copy one of the gmodule.h to /usr/include, it seemed that the compiler could find it but it again stuck at some other missing header ( I think it was glib.h) So I don't think keep copying header files into /usr/include is the right solution here. So what am I missing here ? Is it the problem on my slackware system configuration ? or is it something wrong with the directive on the make file ? This is the first time I try to compile anything on this brand new slackware 14.0.


Hangdog42 12-23-2012 05:55 AM

Just out of curiosity, did you do a full install? Bluefish really doesn't have any dependencies, so it missing gmodule.h is odd.

Also, are you aware of and sbopkg? Between those and src2pkg, I almost never compile by hand anymore.

knudfl 12-23-2012 06:37 AM

No issues with bluefish-2.2.3 on any OS :
Slackware 14 (i686), Slackware64 - 14 (x86_64), etc. etc.:
$ ./configure && make : OK.

A corrupt source ? Or a corrupt OS ?


As already said, please always use Slackbuilds, if available :

! And : The required glib2 (-2.32.4) is always installed by default.
( 'glib-1.2.10' is for (very) old applications only.)


aherrys 12-23-2012 10:13 AM

@knudfl & @Hangdog42,

I have tried to use slackbuilds for installing bluefish, I downloaded the slackbuild for bluefish and downloaded the bz2 source, put it in the same directory and run ./bluefish.Slackbuild. It gives me the same error exactly at the same place (see part of the process of ./bluefish.Slackbuild below. if you need more I can post the whole thing).

@Hangdog42, No I didn't do full install. I try to optimize my build, even the kernel is customized specifically for my machine...
@knudfl, I downloaded the bluefish from two different sources (tar.bz2 and tar.gz) and they both gave the same error. So my OS is corrupt here ? It seems to run OK. I even use it to write this thread. I think there may be some path that is not correct here ? so the -I directive or some other directive that supposed to include everything under /usr/include sub-directories did not work ?
I installed bluefish 2.0 before on customized 13.37 and no issue there.


config.status: creating Makefile
config.status: creating data/Makefile
config.status: creating data/bflang/Makefile
config.status: creating data/bflib/Makefile
config.status: creating data/templates/Makefile
config.status: creating desktop-data/Makefile
config.status: creating images/Makefile
config.status: creating man/Makefile
config.status: creating po/
config.status: creating src/Makefile
config.status: creating src/pixmaps/Makefile
config.status: creating src/plugin_about/Makefile
config.status: creating src/plugin_about/po/
config.status: creating src/plugin_charmap/Makefile
config.status: creating src/plugin_charmap/po/
config.status: creating src/plugin_entities/Makefile
config.status: creating src/plugin_entities/po/
config.status: creating src/plugin_htmlbar/Makefile
config.status: creating src/plugin_htmlbar/pixmaps/Makefile
config.status: creating src/plugin_htmlbar/po/
config.status: creating src/plugin_htmlbar/ui/Makefile
config.status: creating src/plugin_infbrowser/Makefile
config.status: creating src/plugin_infbrowser/po/
config.status: creating src/plugin_snippets/Makefile
config.status: creating src/plugin_snippets/po/
config.status: creating src/plugin_zencoding/Makefile
config.status: creating src/plugin_zencoding/po/
config.status: creating src/
config.status: creating ui/Makefile
config.status: creating macosx/Makefile
config.status: creating win32/Makefile
config.status: creating win32/Makefile.mingw
config.status: creating src/config.h
config.status: executing depfiles commands
config.status: executing default-1 commands
config.status: executing po-directories commands
config.status: creating po/POTFILES
config.status: creating po/Makefile
config.status: creating src/plugin_about/po/POTFILES
config.status: creating src/plugin_about/po/Makefile
config.status: creating src/plugin_charmap/po/POTFILES
config.status: creating src/plugin_charmap/po/Makefile
config.status: creating src/plugin_entities/po/POTFILES
config.status: creating src/plugin_entities/po/Makefile
config.status: creating src/plugin_htmlbar/po/POTFILES
config.status: creating src/plugin_htmlbar/po/Makefile
config.status: creating src/plugin_infbrowser/po/POTFILES
config.status: creating src/plugin_infbrowser/po/Makefile
config.status: creating src/plugin_snippets/po/POTFILES
config.status: creating src/plugin_snippets/po/Makefile
config.status: creating src/plugin_zencoding/po/POTFILES
config.status: creating src/plugin_zencoding/po/Makefile
config.status: executing libtool commands
config.status: executing po/stamp-it commands
Making all in data
make[1]: Entering directory `/tmp/pkg/bluefish-2.2.3/data'
Making all in bflang
make[2]: Entering directory `/tmp/pkg/bluefish-2.2.3/data/bflang'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/tmp/pkg/bluefish-2.2.3/data/bflang'
Making all in bflib
make[2]: Entering directory `/tmp/pkg/bluefish-2.2.3/data/bflib'
gzip bflib_css2.xml -c > bflib_css2.xml.gz
gzip bflib_dom.xml -c > bflib_dom.xml.gz
gzip bflib_php4.xml -c > bflib_php4.xml.gz
gzip bflib_php5_with_examples.xml -c > bflib_php5_with_examples.xml.gz
gzip bflib_php5.xml -c > bflib_php5.xml.gz
gzip bflib_python_2.3.xml -c > bflib_python_2.3.xml.gz
gzip bflib_xhtml.xml -c > bflib_xhtml.xml.gz
gzip bflib_XHTML_1_0_Strict.xml -c > bflib_XHTML_1_0_Strict.xml.gz
gzip bflib_XHTML_1_0_Transitional.xml -c > bflib_XHTML_1_0_Transitional.xml.gz
gzip bflib_XHTML_1_0_Frameset.xml -c > bflib_XHTML_1_0_Frameset.xml.gz
gzip bflib_XHTML_1_1.xml -c > bflib_XHTML_1_1.xml.gz
gzip bflib_SVG_1_0.xml -c > bflib_SVG_1_0.xml.gz
gzip bflib_SVG_1_1_Full.xml -c > bflib_SVG_1_1_Full.xml.gz
gzip bflib_SVG_1_1_Basic.xml -c > bflib_SVG_1_1_Basic.xml.gz
gzip bflib_SVG_1_1_Tiny.xml -c > bflib_SVG_1_1_Tiny.xml.gz
gzip bflib_XHTML_1_0_W3C.xml -c > bflib_XHTML_1_0_W3C.xml.gz
gzip bflib_DocBook_4_5.xml -c > bflib_DocBook_4_5.xml.gz
gzip bflib_DocBook_5_0.xml -c > bflib_DocBook_5_0.xml.gz
make[2]: Leaving directory `/tmp/pkg/bluefish-2.2.3/data/bflib'
Making all in templates
make[2]: Entering directory `/tmp/pkg/bluefish-2.2.3/data/templates'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/tmp/pkg/bluefish-2.2.3/data/templates'
make[2]: Entering directory `/tmp/pkg/bluefish-2.2.3/data'
make[2]: Nothing to be done for `all-am'.
make[2]: Leaving directory `/tmp/pkg/bluefish-2.2.3/data'
make[1]: Leaving directory `/tmp/pkg/bluefish-2.2.3/data'
Making all in desktop-data
make[1]: Entering directory `/tmp/pkg/bluefish-2.2.3/desktop-data'
LC_ALL=C /usr/bin/intltool-merge -d -u -c ../po/.intltool-merge-cache ../po bluefish.desktop
Generating and caching the translation database
Merging translations into bluefish.desktop.
LC_ALL=C /usr/bin/intltool-merge -x -u -c ../po/.intltool-merge-cache ../po bluefish.xml
Found cached translation database
Merging translations into bluefish.xml.
CREATED bluefish.xml
make[1]: Leaving directory `/tmp/pkg/bluefish-2.2.3/desktop-data'
Making all in images
make[1]: Entering directory `/tmp/pkg/bluefish-2.2.3/images'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/pkg/bluefish-2.2.3/images'
Making all in man
make[1]: Entering directory `/tmp/pkg/bluefish-2.2.3/man'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/tmp/pkg/bluefish-2.2.3/man'
Making all in po
make[1]: Entering directory `/tmp/pkg/bluefish-2.2.3/po'
file=`echo bg | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file bg.po
file=`echo ca | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file ca.po
file=`echo cs | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file cs.po
file=`echo da | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file da.po
file=`echo de | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file de.po
file=`echo el | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file el.po
file=`echo es | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file es.po
file=`echo eu | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file eu.po
file=`echo fi | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file fi.po
file=`echo fr | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file fr.po
file=`echo gl | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file gl.po
file=`echo hu | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file hu.po
file=`echo it | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file it.po
file=`echo ja | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file ja.po
file=`echo ko | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file ko.po
file=`echo nb | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file nb.po
file=`echo nl | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file nl.po
file=`echo nn | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file nn.po
file=`echo pl | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file pl.po
file=`echo pt | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file pt.po
file=`echo pt_BR | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file pt_BR.po
file=`echo ro | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file ro.po
file=`echo ru | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file ru.po
file=`echo sk | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file sk.po
file=`echo sr | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file sr.po
file=`echo sv | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file sv.po
file=`echo ta | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file ta.po
file=`echo tr | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file tr.po
file=`echo uk | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file uk.po
file=`echo zh_CN | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file zh_CN.po
file=`echo zh_TW | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file zh_TW.po
make[1]: Leaving directory `/tmp/pkg/bluefish-2.2.3/po'
Making all in src
make[1]: Entering directory `/tmp/pkg/bluefish-2.2.3/src'
make  all-recursive
make[2]: Entering directory `/tmp/pkg/bluefish-2.2.3/src'
Making all in pixmaps
make[3]: Entering directory `/tmp/pkg/bluefish-2.2.3/src/pixmaps'
gdk-pixbuf-csource --raw --extern --build-list pixmap_bluefish_icon1 ./bluefish_icon1.png pixmap_bookmarks ./bookmarks.png pixmap_filetree ./filetree.png pixmap_view_in_browser ./view_in_browser.png > toolbar_icons.c
make  all-am
make[4]: Entering directory `/tmp/pkg/bluefish-2.2.3/src/pixmaps'
make[4]: Nothing to be done for `all-am'.
make[4]: Leaving directory `/tmp/pkg/bluefish-2.2.3/src/pixmaps'
make[3]: Leaving directory `/tmp/pkg/bluefish-2.2.3/src/pixmaps'
Making all in plugin_about
make[3]: Entering directory `/tmp/pkg/bluefish-2.2.3/src/plugin_about'
/bin/sh: line 8: test: too many arguments
make  all-recursive
make[4]: Entering directory `/tmp/pkg/bluefish-2.2.3/src/plugin_about'
Making all in po
make[5]: Entering directory `/tmp/pkg/bluefish-2.2.3/src/plugin_about/po'
make[5]: Leaving directory `/tmp/pkg/bluefish-2.2.3/src/plugin_about/po'
make[5]: Entering directory `/tmp/pkg/bluefish-2.2.3/src/plugin_about'
/bin/sh ../../libtool --tag=CC  --mode=compile i486-slackware-linux-gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/share/locale\" -DPKGDATADIR=\"/usr/share/bluefish\" -I. -I../../src    -O2 -march=i686 -pipe -fomit-frame-pointer -I/usr/include/python2.7  -MT about.lo -MD -MP -MF .deps/about.Tpo -c -o about.lo about.c
libtool: compile:  i486-slackware-linux-gcc -DHAVE_CONFIG_H -DLOCALEDIR=\"/usr/share/locale\" -DPKGDATADIR=\"/usr/share/bluefish\" -I. -I../../src -O2 -march=i686 -pipe -fomit-frame-pointer -I/usr/include/python2.7 -MT about.lo -MD -MP -MF .deps/about.Tpo -c about.c  -fPIC -DPIC -o .libs/about.o
about.c:22:21: fatal error: gmodule.h: No such file or directory
compilation terminated.
make[5]: *** [about.lo] Error 1
make[5]: Leaving directory `/tmp/pkg/bluefish-2.2.3/src/plugin_about'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/tmp/pkg/bluefish-2.2.3/src/plugin_about'
make[3]: *** [all] Error 2
rm about_rev.h.tmp
make[3]: Leaving directory `/tmp/pkg/bluefish-2.2.3/src/plugin_about'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/pkg/bluefish-2.2.3/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/pkg/bluefish-2.2.3/src'
make: *** [all-recursive] Error 1

knudfl 12-23-2012 12:21 PM

Well, then please reinstall the package glib2-2.32.4-<arch>-1.txz

It is on your install DVD : slackware/l/
Or, if it's a 64bits OS : slackware64/l/

aherrys 12-23-2012 03:44 PM

Yeah I have reinstalled the glib and the gcc multiple times but still the same... well this is the latest update of what I found. I have added manually the /usr/include/glib-2.0 into the C_INCLUDE_PATH directive and the compile went through that part only to be stuck in some other missing headers files. So I can go on and keep adding manually all the sub directories under the /usr/include in the C_INCLUDE_PATH and I think that the compilation will go through fine eventually. However that indicates that something is seriously wrong with my system. I have done some searching and found that one of gcc default search paths for headers files is /usr/include as described here:

And as I said in the beginning of the thread that if I manually copy the 'missing' header files into the directory /usr/include then it will find it. So it seems that the gcc will only find the header files if it is directly placed on the usr/include directory and not all other numerous sub directories under it. I am not sure whether the /usr/include path that is defined as the default path for the gcc search directory means searching only in that directory or means also searching in all the sub directories under it. The link I gave above doesn't say anything about it.
But I am sure that the need to add all the sub directories under the /usr/include path manually is not a normal way that the gcc and linux should work, so there is something is missing here. I am not sure what, I will search around some more for answers. If I cannot find anything in a couple of days, I just gonna nuke my system and reinstall it from scratch again and retrace where I had gone wrong... :)

Thank you for your help.

andrew.46 12-26-2012 12:07 AM

Might not be much help to you but I have just recompiled Bluefish 2.2.3 under Slackware -current (not too much difference with 14.0 atm) and on a 64bit multilib system it compiled cleanly. I suspect a full install of Slackware might be part of the solution here, hdds are cheap these days after all...

All times are GMT -5. The time now is 09:53 PM.