-   Slackware (
-   -   Error compiling Term:ReadKey (

piacentini 05-24-2013 10:09 AM

Error compiling Term:ReadKey
I am getting the following error while trying to compile/install the perl module Term:ReadKey, which is required by git-svn.

/usr/bin/perl5.16.3 /usr/share/perl5/ExtUtils/xsubpp -noprototypes -typemap /usr/share/perl5/ExtUtils/typemap ReadKey.xs > ReadKey.xsc && mv ReadKey.xsc ReadKey.c
Warning: Found a 'CODE' section which seems to be using 'RETVAL' but no 'OUTPUT' section. in ReadKey.xs, line 1805
cc -c -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -fPIC -DVERSION=\"2.30\" -DXS_VERSION=\"2.30\" -fPIC "-I/usr/lib64/perl5/CORE" ReadKey.c
In file included from /usr/include/bits/posix1_lim.h:157:0,
from /usr/include/limits.h:145,
from /usr/lib64/gcc/x86_64-slackware-linux/4.7.1/include-fixed/limits.h:169,
from /usr/lib64/gcc/x86_64-slackware-linux/4.7.1/include-fixed/syslimits.h:7,
from /usr/lib64/gcc/x86_64-slackware-linux/4.7.1/include-fixed/limits.h:34,
from /usr/include/sys/param.h:27,
from /usr/lib64/perl5/CORE/perl.h:676,
from ReadKey.xs:4:
/usr/include/bits/local_lim.h:39:26: fatal error: linux/limits.h: No such file or directory
compilation terminated.

Notice that the error occurs both with the SlackBuild (from and also when using cpan (install Term:ReadKey). To try with cpan

install Term:ReadKey

I *think* it is an error within the module and not in slackware64, but some confirmation would be good so I can file a bug report or attempt to solve it. Thanks!

willysr 05-24-2013 10:17 AM

there are some packages that contains limits.h

willysr@desktop:~$ slackpkg file-search limits.h

Looking for limits.h in package list. Please wait... DONE

The list below shows the packages that contains "limits\.h" file.

[ installed ] - dev86-0.16.17-i486-1
[ installed ] - gcc-4.8.0-i486-3
[ installed ] - gcc-g++-4.8.0-i486-3
[ installed ] - kernel-headers-3.8.13_smp-x86-1
[ installed ] - llvm-3.2-i486-4
[uninstalled] - kernel-source-3.8.13_smp-noarch-1
[ installed ] - glibc-2.17-i486-3
[ installed ] - tetex-3.0-i486-8

piacentini 05-24-2013 10:31 AM

Thanks for your file-search tip. I ran it and got:

The list below shows the packages that contains "limits\.h" file.

[uninstalled] - kernel-headers-3.2.45-x86-2
[ upgrade ] - kernel-source-3.2.29-noarch-1 --> kernel-source-3.2.45-noarch-2
[ installed ] - dev86-0.16.17-x86_64-2
[ installed ] - gcc-4.7.1-x86_64-1
[ installed ] - gcc-g++-4.7.1-x86_64-1
[ installed ] - llvm-3.0-x86_64-2
[ installed ] - glibc-2.15-x86_64-7
[ installed ] - tetex-3.0-x86_64-8

So what happened is that I had to manually remove the kerne* packages, and reinstalled from the DVD, as my machine was hit by the i915 driver issue. I forgot to reinstall the kernel-headers after downgrading the kernel :( Now I got them from the installation DVD and the compilation proceeds fine. Solved!

All times are GMT -5. The time now is 01:51 PM.