-   Slackware (
-   -   Erase char for remote SSH session (

Gleylancer 01-29-2013 06:58 AM

Erase char for remote SSH session
I'm on Slackware 14 (without X, just plain Bash) and I am connecting via SSH to some Alcatel switches. These have set the erase char to ^H, thus my backspace key is not working when I am connected. When I use PuTTY, I have the option to just change the backspace key from Control-? to Control-H. Where do I do this in Slackware?

pan64 01-29-2013 07:33 AM

usually it is the stty command. See man page for details. Probably:
stty erase ^H

Gleylancer 01-29-2013 07:47 AM

No, that doesn't work, it changes the erase char for the local console, but it has no effect when I connect via SSH to the alcatel switch.

pan64 01-29-2013 08:16 AM

it do have effect, at least I tried it using linux and bash. But it has no effect using tcsh (in the same terminal). It was not related to the host, it worked exactly the same way on the local and remote environmment.
using tcsh I could redefine delete by:
bindkey "^G" backward-delete-char

I do not know what kind of shell is running on the alcatel switch, probably you need to config its key bindings.

All times are GMT -5. The time now is 02:31 AM.