-   Slackware (
-   -   Epson XP 200 drivers (

waddles 06-17-2013 05:19 AM

Epson XP 200 drivers
I went to the Epson sight to download drivers but there are apparently 2 different drivers that could possibly be used.
One is for their ESCP-R which is apparently the generic version and I see 2 possibilities: epson-inkjet-printer-escpr-1.2.3-1fsb3.2.tar.gz and/or ...lsb3.2.src.rpm (where I would convert the rpm to tar and compile)
the "full feature" version ESCP(no R here)
and/or ...lsb3.2.src.rpm (both requiring at least a conversion).

I have seen SlackBuild recommendation (out of date) but what I want to know is can I run the scanner driver (that is another thread later) with either one on Slackware 13.37 and which would be more ideal the full feature or generic and in which form??? Please identify which driver I should use by name. Hopefully, I won't need to add to my lib library, compile & etc. supplicate to the Linux gods to get this one to function like I did on the HP 1000 inkjet which will soon suck air from the Puget Sound.

shane25119 06-17-2013 12:38 PM

Check to see what Opening Printing suggests:

Failing that, just try both. If one doesn't work you should use the other.

waddles 06-19-2013 12:41 AM

Epson XP 200 drivers
Looks like they think it is the eson-201204w and will try that if I don't find a better suggestion. Don't want to go thru what I did with that crappy HP.

aus9 08-20-2013 04:08 AM


crappy hp?
did you look for the drivers in your distro?

most hp printers work with hplip

waddles 08-20-2013 11:29 PM

I validated that the current hplip was for the printer (HP 1009 jxx series). That one over printed all pages after the first one. I exchanged the printer with HP and after they lied to me about including the cables that also failed likewise. I wrote a script to get around it (aka kludge). Then I gave up and tried the hpijs. The overprinting went away!! Then it started giving me backend problems which were not worth my time to fix. I went to Epson XP200. Now I have to get sane/xsane to work with the scanner because their scanner stuff does nothing but sit there and hum. Recently I had the joyous discovery that it too overprints pages when documents are over 1 page. I tried ctrl-V,L insertion into the document but that resulted similarly. Since it too uses CUPS I am beginning to think the problem is there.

All times are GMT -5. The time now is 10:20 PM.