LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-18-2005, 05:01 AM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.2 (multilib)
Posts: 1,268

Rep: Reputation: 61
Epson USB printer just stops


Running Slack 9.1 and CUPS 1.1

My Brother laser printer works fine on the parralel port.

My problem is the Epson Stylus 740 printer which is on USB

I install it via the 631/administration pages and it prints the first 23% of the test page and just stops. The only way to get it going again is to turn it off and disconnect and reconnect the USB connection.

Trying to print a page other than a few lines of simple text and it will always stop a short way into the page.

Frustrating especially as it all works so easily on Suse
 
Old 09-20-2005, 09:46 AM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: Sway or Xfce
Posts: 5,509

Rep: Reputation: Disabled
hmmm. don't use slack anymore but until you get a better answer, me thinks that as it starts to print.....there is some file/program interfering.

open a console and run the command
top
then start your printer and see if any file grabs lots of ram that might then give you a clue?
 
Old 09-20-2005, 10:17 AM   #3
chemdawg
Member
 
Registered: Jan 2005
Distribution: Mandriva
Posts: 206

Rep: Reputation: 31
I don't have the solution, but I, too have seen this with my Stylus CX5400 using Mandriva. Although mine only happens occasionally, it is annoying when it does. I will watch this thread to see the solution!
 
Old 09-22-2005, 02:36 PM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.2 (multilib)
Posts: 1,268

Original Poster
Rep: Reputation: 61
Tried top. Did not find it helpful.
 
Old 09-23-2005, 12:01 AM   #5
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: Sway or Xfce
Posts: 5,509

Rep: Reputation: Disabled
fair enough.....do you have any other usb devices being used on slack?

I ran top twice.....
top > top1.txt
then started my usb epson printer and then
top > top2.txt

the only output of interest was this
6535 lp 16 0 4500 2952 984 S 3.7 0.3 0:01.05 ijsgimpprint
4806 root 15 0 150m 19m 3816 S 0.3 2.2 0:14.81 X
6534 lp 15 0 18356 9924 3620 S 0.3 1.1 0:00.29 gs

with the X line no change but just showing % mem use of X was 2.2
hope that helps when you do a compare?

Last edited by aus9; 09-23-2005 at 12:10 AM.
 
Old 09-23-2005, 02:19 AM   #6
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.2 (multilib)
Posts: 1,268

Original Poster
Rep: Reputation: 61
I have a wacom tablet on usb and occasionally connect a digicam or flash drives to usb. No problems noticed there but I occasionally have problems copying files to my mp3 player.

I have found another way around this. I installed slack 10.1 on another partition (currently running 9.1) and managed to print ok on the Epson. So I will probably migrate to 10.1
 
Old 09-25-2005, 03:03 PM   #7
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.2 (multilib)
Posts: 1,268

Original Poster
Rep: Reputation: 61
Curous thing.

I have just installed Mepis on another partition and it gives exactly the same problem with the Epson printer.
 
Old 09-25-2005, 04:10 PM   #8
lagartoflojo
Member
 
Registered: Sep 2004
Location: Santiago de Chile
Distribution: Slackware 10.2
Posts: 46

Rep: Reputation: 15
I used to have this same problem. My Epson Stylus Photo R300 would randomly stop when it was printing, but not always. The problem is solved now, but don't ask me how I did it (I don't really know what did the trick). What I can tell you is that I am on Slackware 10.0. I upgraded CUPS to version 1.1.23, and as a driver I use the Gutenprint 5.0.0 beta4 drivers (http://sourceforge.net/projects/gimp-print). My kernel is 2.6.11.8.
So the only thing I can recommend is to upgrade the packages.. and maybe even Slackware itself.
 
Old 09-25-2005, 05:30 PM   #9
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware
Posts: 1,286

Rep: Reputation: 103Reputation: 103
Quote:
Originally posted by lagartoflojo
So the only thing I can recommend is to upgrade the packages.. and maybe even Slackware itself.
Or try a different driver. I use cups and have an Epson Stylus Color 760 (not much different from the 740) and mine has worked well in both USB and LPT ports in Slack 10.0, 10.1, 10.2 as well as Debian. What driver are you using?

I think SuSE uses a different driver IIRC. I must say that YaST did do a very nice job setting up the printers. I'm in windows at the moment. I'll boot slack and let you know what driver I use.

edit:

My driver is CUPS + Gimp-Print v4.2.7
CUPS v1.1.x

Same driver is indicated for the 740

Last edited by Franklin; 09-25-2005 at 05:50 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Epson C84 USB Printer mdg Linux - Hardware 14 11-11-2004 02:05 PM
Epson C60 USB Printer not recognized jrgalan Linux - Newbie 0 08-21-2003 01:44 PM
how can i install my Epson C41UX - USB Printer in RH 8? kublador Linux - Hardware 2 03-02-2003 11:10 AM
epson usb printer j-charles Linux - Newbie 8 03-17-2002 03:38 PM
I install my Epson 880(usb) printer in RH 7.2 but nothing happens oudent Linux - Software 4 12-19-2001 01:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration