-   Slackware (
-   -   Epson DX4400 scanner poor quality on Slack 14.1 (

commandlinegamer 04-28-2014 06:46 AM

Epson DX4400 scanner poor quality on Slack 14.1
I'm not using the printer part of the DX4400 but I know that works ok having tested it previously.

Scanner is detected with "sane-find-scanner":


found USB scanner (vendor=0x04b8 [Language Error], product=0x083f [Language Error]) at libusb:002:013
And "scanimage -L" gives the following output:


device `snapscan:libusb:002:013' is a Acer Color MFP01 flatbed scanner
xsane allows me to preview and scan, but the output is pretty much inverted, save that although the background is black, foreground objects are all the same shade of green.

I'm assuming at this stage it's a driver issue given the "Acer" model detected above.

I've tried installing the iscan-proprietary-drivers and iscan-firmware SlackBuilds for 14.1, and editing "/etc/sane.d/dll.conf", commenting out "epson, epson2" and inserting "epkowa". But it doesn't appear to load the other drivers.

At one point I did get "invalid argument" when trying to use the epkowa backend.

I'm just wondering whether using a older version of Slackware might work (12.2 for example)?

There are numerous examples online of people using this MFP - it's listed as supported and I've made various adjustments suggested online via other forums (which, to be fair, were usually other distros such as Ubuntu or Arch).

Anyone had success using the DX4400 on up-to-date Slack?

allend 04-28-2014 08:11 AM

From /lib/udev/rules.d/80-libsane.rules

# EPSON Stylus CX4300 | EPSON Stylus CX4400 | EPSON Stylus CX5500
# EPSON Stylus CX5600 | EPSON Stylus DX4400
ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="083f", MODE="0660", GROUP="lp", ENV{libsane_matched}="yes"
So your device should be correctly recognised.
Do you have any custom udev rules in /etc/udev/rules.d/ that are overriding the default udev rules?

commandlinegamer 04-28-2014 08:52 AM

Only the rules 70-persistent-net and -cd.

allend 04-28-2014 09:13 AM

Perhaps try editing out snapscan in /etc/sane.d/dll.conf.

With my Brother scanner, sane-find-scanner fails but scanimage -L works.
I have never had an Epson scanner, so I think I should butt out here.

commandlinegamer 04-29-2014 04:54 AM

Disabling the snapscan backend simply results in it not finding the scanner at all. Thanks for your suggestion though.

ljb643 04-29-2014 07:31 PM

According to and your scanner will not work with any Sane-provided backend, and must use the Epson "epkowa" backend. (I have no idea why the "snapscan" backend is being selected, but it obviously doesn't work.)

If I remember right, the iscan packages from Epson includes both a scanning application (iscan), and a backend/device driver (epkowa). If you like using Sane's xscan or scanimage, you can use them with the epkowa backend; if you want to try a "simpler" interface, you can use iscan.

Did you try the iscan program itself? It might be a good test. If it does work, but you don't like it, you can then work on getting the epkowa driver it includes working with Sane.

I'm running Slackware 14.1, and although my Epson scanner works fine with Sane's own drivers, it is supported by iscan, so I think I'll give it a try and see what happens.

ljb643 04-30-2014 06:31 PM

To follow up, I built (from source) and installed Epson's scanner support: iscan-2.29.3-1 and iscan-data_1.28.0-2, under Slackware 14.1. It does work with my Epson scanner - both using iscan and xsane. It should work with your scanner too.

To correct one thing I wrote above, though, I found that iscan required setting up SANE (/etc/sane.d/dll.conf and /etc/sane.d/epkowa.conf) before it would work. So forget about trying iscan first, then "you can work on getting the epkowa driver it includes working with Sane" as I wrote above.

commandlinegamer 05-04-2014 07:40 AM

Got a bit further by building the iscan core (required a patch) and data packages, and installing the CX4400 plugin.

Scanner detected now as


device `epkowa:usb:005:003' is a Epson (unknown model) flatbed scanner
Trying "scanimage >out.pnm" seems to result in the scanner turning off after 20-30 seconds.

My epkowa.conf is simply:


usb 0x04b8 0x83f
I've tried changing it to:


interpreter usb 0x04b8 0x83f /usr/lib/iscan/libesint7E
But when I do that the scanner is no longer detected. The mystery continues...

All times are GMT -5. The time now is 05:10 AM.