LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   EPSON 680 will not print (https://www.linuxquestions.org/questions/slackware-14/epson-680-will-not-print-217850/)

gavinbeatty 08-15-2004 09:21 AM

EPSON 680 will not print
 
Using a full install of slack 10.0 with no updates yet, printing will not work

I received this error after the test print:

--------------------------Quote-----------------------------

A print error occurred. Error message received from system:

/usr/bin/lpr -P 'EPSON-Stylus_680' '-#1' '/tmp/kde-root/kdeprint_5eJqbO3g' : execution failed with message:
Status Information, attempt 1 of 3: sending job 'root@localhost+684' to EPSON-Stylus_680@localhost connecting to 'localhost', attempt 1 cannot open connection to localhost - No such file or directory Make sure the remote host supports the LPD protocol Waiting 10 seconds before retry Status Information, attempt 2 of 3: sending job 'root@localhost+684' to EPSON-Stylus_680@localhost connecting to 'localhost', attempt 1 cannot open connection to localhost - No such file or directory Make sure the remote host supports the LPD protocol Waiting 10 seconds before retry sending job 'root@localhost+684' to EPSON-Stylus_680@localhost connecting to 'localhost', attempt 1 cannot open connection to localhost - No such file or directory Make sure the remote host supports the LPD protocol

--------------------------End Quote-------------------------

I used the localhost:631 to set up the printer.

coryrc 08-23-2004 04:11 PM

Slackware: Make sure the remote host supports the LPD protocol
 
Hi,
I just solved this problem myself, after reviewing a couple websites. Since the package lprng is alphabetically after cups, it writes over the symlink /usr/bin/lpr. I would recommend uninstalling package lprng, then either: reinstall cups (sure to work) or symlink /usr/bin/lpr to /usr/bin/lpr-cups (should work.)

Hope this helps!

gavinbeatty 08-24-2004 05:53 PM

Actually I tried using the USB with /dev/usb/lp0 and it was all gravy.

Seems stupid but I'm not arguing now that I never need to reboot.

Funny thing is I actually can't get USB printing to work on windows with same but now all I need is to get printing to work right out of Opera with CUPS!

Thanks all the same since that actually will solve a lot of other people's problems even though I don't need it.

shilo 08-24-2004 06:04 PM

Quote:

Thanks all the same since that actually will solve a lot of other people's problems even though I don't need it.
Maybe you do

Quote:

now all I need is to get printing to work right out of Opera with CUPS!
'cause it'll probably fix this.

Summary for anyone following along:

1) Choose either CUPS or lprng.
2) "removepkg" the one you don't want
3) "upgradepkg --reinstall" the one you do want
4) Enjoy printing that works.

Franklin 08-24-2004 06:32 PM

I have also found the folowing to be true:

When I received this message, I went to the print manager in the kde control center. You should see your printer listed in the top portion of the window. At the bottom you will see a drop-down menu titled "print system currently used". This defaults to lpr/lprng or unix (can't remember which) change this to cups and save settings. This fixed my problem (in KDE) and perhaps will help you. Gnome will still be borked untill you do the other stuff listed in the other responses.

HTH


All times are GMT -5. The time now is 05:06 PM.