-   Slackware (
-   -   Epson 200 overprints page 2 with page 1 (

waddles 08-18-2013 04:06 PM

Epson 200 overprints page 2 with page 1
My Epson 200 has started doing what the HP 1000 was doing before I changed to the HPIJS, that is overprinting 2nd page with 1st.
I am using ESCP/R. Would using ESCP make this go away? If so what is the best way to remove stuff or do I just follow the bouncing ball from the directories where I untarred them from?

aus9 08-18-2013 07:18 PM


I am not sure of you mean you are using the closed src driver for epson from

or something from your package manager?

epsons generally are supported by the gutenprint driver set with cups

waddles 08-19-2013 06:05 AM

ESCP & ESCPR are the 2 drivers made available by EPSON but not supported by them. They do keep them up to date.
I am aware of gutenprint but have not investigated it as others have had luck using the ESC* drivers. Personally, I have had absolutely no luck downloading from sourceforge as each attempt ended with different size for different objects.
BTW, yes, the ESC* drivers work with CUPS.

aus9 08-19-2013 06:48 AM



have not investigated it as others have had luck using the ESC* drivers
by that logic I could say...others have had luck with gutenprint drivers or with foomatic drivers.

Since you are telling me, your closed source driver has a problem, why not consider a open source?

Your package manager should have gutenprint and / or foomatic drivers. Unfortunately epson 200 is not exact enough for me to link directly to the foomatic driver database or a gutenprint.

2) I am using closed src drivers for nvidia....but thats not the issue. You have an issue with a closed src and appear unwilling to investigate open src

waddles 08-19-2013 02:17 PM

Since the problem has just been noted, I would prefer to find a solution to the problem rather than skirting the issue by jumping into another situation which may have equal or more problems.
Thanx 4 UR input.
Added: Had same overprinting problem with hplip driver designed for their HP 1000 jxxx printer. Because it used CUPS as a backend too I suspect CUPS because that printer was removed due to backend problems not worth time to reslove them.

ljb643 08-19-2013 08:51 PM


Originally Posted by aus9 (Post 5011809)
...Since you are telling me, your closed source driver has a problem, why not consider a open source?

His printer is an Epson XP-200 small/home all-in-one inkjet. According to the recommended driver is one distributed by Epson. That is, there is no driver for this printer in Gutenprint (gimp-print) or bundled with CUPS. See

For the record, the Epson-distributed Linux drivers are open source, more-or-less. The reason for the qualifier is there are some contradictions. Their ESC/P-R driver is downloaded as source, and per its README is covered by GPL. Except that if you look through the source files, some have a restrictive Epson copyright notice at the top.

Having said all that, I have no idea at all why page 2 is overprinting page 1. I don't even know how that is possible - is it printing page one, then rolling the paper back and printing page 2 on the same sheet? Or is it happening during the raster conversion? (I use my Epson printer 99% for photos, and never even tried multi-page documents.)

aus9 08-20-2013 04:04 AM

ahh I won't annoy the OP on this post any longer now that I know he meant xp-200 will post on his other post instead

waddles 08-21-2013 12:11 AM

FWIW note my change to my last reply.
Thanks to both of U and for catching the XP200 error, humble apologies.
This is strictly text which when it exceeds 66 lines (letter mode) the next line is printed and then overprinted, then it seems to recover and continues printing 2nd page then is overprinted a few lines later. Sometimes overprinting is more than 1 line and more than a couple of places on second page. When I write a book chapter it really gets lengthy so this is going to be a mess if I can't resolve it.
It is NOT rolling a whole page back. As far as I can tell it is only a line or 2 of roll back if it rolls back. It appears like it is part of a previous line (just the beginning in some cases) which is overprinting but may be multiple previous lines doing the overprinting, hard to read one line from the other. This could be a line cached from the previous page as it appears like the overprinting is from the last lines of the 1st page.

ljb643 08-21-2013 07:31 PM

I don't really have any idea. Could it be a paper size mismatch? Margins error?
What program or application are you printing from, and/or what format is the original?

waddles 08-22-2013 02:26 AM

Am printing a file as: lp -d epb filename
where epb is the printer defined in CUPS as epb that uses only black ink to print black text which how the file is composed.
The file is created using vi in a terminal window (XFCE > SYSTEM > TERMINAL).
That printer was defined in CUPS as black ink, letter size.
As to format it is text controlled by <LF> for end of line not <CR><LF>.

ljb643 08-22-2013 06:54 PM

OK, a plain text file. (You may be surprised to find out what Cups does with that: converts it to PostScript, then uses Ghostscript to convert the postscript to raster, then uses the Epson filter to convert it to Epson raster.)

You might try this instead, which uses a different text-to-Postscript converter:

enscript --printer=epb --no-header filename
Also make sure the printer default paper size (as set via the Cups web interface, for example) and the DefaultMedia set in /etc/enscript.cfg match your paper size, else you need to override it on the command line.

waddles 08-22-2013 07:31 PM

like I said earlier, I suspect CUPS. I long for the days of printer ribbons. Re-ink was simple, the heads lasted a year or 2.
Can U say more about the Epson raster filter?
Had checked the printer's page size in cups and verified with lpoptions:
PageSize/Paper Size: 4X6FULL T4X6FULL 2L T2L *Letter TLetter A4 TA4 8x10 T8x10 L TL 4X7 T4X7 ENV10 Legal A6 HLT
* indicates selected option.
Tried the command but still 1st page OK, 2nd page same junk. Tried also limiting lines/page to 60 and same junk.
Would it be of value to create 2 pages of ghostscript?
Just in case UR thinking about it there are no lines longer than 69 characters.

waddles 09-01-2013 02:58 PM

Tried: enscript --printer=epb --no-header -L 60 -a 1-2 filename
It handled the number of pages 1 & 2 OK but when it printed page 2 it still overprints and ignores the line count (line count was restricted to 60 on page 1).
I confirmed it is overprinting from page 1.
It is difficult to tell because of the way the lines are laid out and spaced between the 2 pages but am able to tell that it is the later lines of page 1 being overprinted onto page 2 at the beginning of page 2 and again in exactly the same line position on page 2 that were used on page 1.

Did a search with CUPS causes overprint and found:
where people with Canon, HP, EPSON et. al. are having the same problem. Many have upgraded Ghostscript, HPLIP, changed to HPIJS (that worked for me), and other packages. Many seem to point at ghostscript as the problem but seems few uniquely identified what the problem was. One suggestion was to provide bus id but didn't say where.

All times are GMT -5. The time now is 11:23 PM.