-   Slackware (
-   -   Enlightenment: Installed? (

trashbird1240 11-30-2006 09:19 AM

Enlightenment: Installed?

Last night I went through compiling Enlightenment from source and a few funny things happened:

(yes I installed imlib2 and imlib2_loaders, and freetype)

1. First I tried to install DR17. Once I got it all done, in the order specified in the instructions, I got errors on the last compile (enlightenment itself): it said edje directories were not found. I surely installed edje first.
2. After editing an xinitrc file by adding

exec enlightenment_start

to the last line of the file, I ran xwmconfig and selected the new xinitrc.dr17 as the default configuration for X. Then when I did startx all I eventually got was a white screen with a mouse pointer and a slight shadow, with a small black line perpendicular to the bottom of the screen. Mouse clicks did not raise any menus or do anything else.

3. So I said "I'd rather have a functional window manager and they said it was not even alpha, so screw it," and I tried to install DR16. So I untarred and all that and then did

make install
make clean

like the README said. This time when I starated X even less happened, so I uninstalled DR17 thinking there might be a conflict: I went to the directory I installed from and did

make uninstall

The terminal spewed a bunch of messages and was done. Then I did the same in the DR16 directory and then redid the whole installation process from gunzip|tar to make clean.

4. Still nothing: the README says that it should install to "...enlightenment/bin/enlightenment" and that's the binary to start the window manager. The only problem is that there is no such directory.

So, two questions:
a. How do I do this to make it work? (I'd be satisfied with DR16)
b. Once I've gone through all this installation stuff and have an error, how do I get rid of all the crap that "make install" copies all over the place? Am I going to have dependency problems and conflicts from all that? I'd really prefer to have things clean.

Thanks for any suggestions,
Slackware 11.0 running huge 2.6 kernel from Slackware CD (installed from binary)

gnashley 11-30-2006 03:46 PM

You should be configuring with --prefix=/usr. And running 'make clean' may be fouling up 'make uninstall'.
Try using my PkgBuild/src2pkg program for tracking your build and installation:

sunman 12-01-2006 01:01 PM

I'm not sure if it's a viable option for you or not but linuxpackages has a package already made for DR17. Maybe if you check out the slacke17 project's homepage you could find something useful for doing your own install.

This is the link to the package details page at linuxpackages.

And if you're just trying to get it to compile and install on your own much luck to you :)

trashbird1240 12-01-2006 04:56 PM

Actually, that's exactly what I was looking for: thanks, I'll let you know how it goes.


trashbird1240 12-01-2006 09:49 PM

I installed E17 and it is wicked cool.

Thanks for suggesting the download.


All times are GMT -5. The time now is 02:13 AM.