-   Slackware (
-   -   Encrypted Root Filesystem (dm-crypt/loopAES +ext3fs) - Problem (

dragoncity99 07-29-2005 03:48 AM

Encrypted Root Filesystem (dm-crypt/loopAES +ext3fs) - Problem
Hi everyone,

I'm trying to install an encrypted root filesystem originally using loopAES with the following tools:

1. Slackware 10.1
2. Kernel
3. util-linux-2.12q.tar.bz2
4. loop-AES-v3.0d.tar.bz2

However, i found that, it reboots when my ramdisk trying to run "init" command:

If i run the program manually myself on the console:
exec /usr/bin/chroot current-parition new-partition

i.e. : exec /usr/bin/chroot . loader

It shows error:
/usr/bin/chroot: cannot run command 'loader/': Permission denied

When i switched to the next screen. The error shows:
-sh: /dev/null: Read-only file system
stderr is not a tty - where are you?

The ramdisk im using busybox 1.0 :)

I believe that it could be a bug in loopAES, therefore, i reimplement this encrypted root file system with dm-crypt which is readily available in kernel with the following tools:

1. cryptsetup-0.1.tar.bz2
2. device-mapper.1.01.03.tgz
3. hashalot-0.3.tar.gz
4. busybox 1.0

Any thing that i could have missed out?

New update:
It seems like the problem lies int the /sbin/init belonging to my real root filesystem. Once it's executed, it seems to do some processing 4 a while and KAPOOF-->
My system restarts AFTER MOUNTING /dev/loop0 to /mnt directory.

Kind regards,

Matir 07-29-2005 09:33 PM

It just reboots with no error messages during ramdisk execution?

dragoncity99 07-31-2005 08:27 AM

Yes , it just reboots.

Guys, i think this is obviously the patch(loop-AES-v3.0d.tar.bz2) i tried out is problematic on kernel

I tested the loop-AES-v3.0b.tar.bz2 with Kernel 2.6.10. These works perfectly fine. No a scratch of problem at all. Hmm, how am i gonna deal wiff this kernel encryption....

dragoncity99 08-01-2005 12:29 AM

Hahaha, boys and girls, ladies and gents,

I found the answer the problem. The problem actually lies in the encrypted root filesystems' /dev directory.

When i run cp -avx / /mnt/efs

This command copys all the files except the block devices files. That's why it reboots. This is becoz the kernel can't file the block devices to load. How stupid of me.

Now Kernel 2.4.29, 2.6.10, 2.6.12. is all capable of doing loopAES as well as dm-crypt + LVM2.

Awesome man.... ;)

Matir 08-01-2005 12:39 AM

Very nicely done. cp doesn't handle devs well. Of course, one really ought to be using udev anyway, so the only real devs you need are /dev/null and /dev/console (needed for initial kernel boot before udevd is started)

dragoncity99 08-01-2005 01:07 AM

Please tell me more bout this udev Matir. Im interested :)

Kind Regards,

Matir 08-01-2005 01:14 AM

Heh. udev is awesome. I have udev setup so that each of my jumpdrives ALWAYS gets the same symlink in /dev. For example, my blue jumpdrive can ALWAYS be called /dev/jumpdrives/blue. This makes it much easier to mount them in predictable places, and keep fstab simple. Check out for more info.

All times are GMT -5. The time now is 02:01 AM.