LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-17-2011, 03:36 PM   #1
disco_slack
Member
 
Registered: Apr 2011
Posts: 44

Rep: Reputation: 1
Enable mic in Skype. Using Alsa sound. Please help.


Hello everyone,

I wiped my Redhat partition in my work laptop, Dell Inspiron 1420 and installed Slack. 13.37. Everything went fine. I installed ndwisrappper, wicd, Libreoffice and Skype. So far so good.

I have two problems that I gave up after searching a lot on web. My main one is I can't enable mic in Skype. I created a sond.conf file in /etc/modprobe.d/ with this content

options snd-hda-intel model=dell-m26
# options snd-hda-intel model=5stack
#options snd-hda-intel model=dell-3stack
#options snd-intel8x0 ac97_quirk=1 buggy_irq=1 enable=1 index=0
#options snd-hda-intel model=3stack enable=yes
#options snd-hda-intel model=auto position_fix=1 enable=yes
#options snd-hda-intel model=auto

and I tried every single line, one by one but I never managed to make it work. The maximum was hearing my voice very low. I added the Pream tip from Alien Bob, but still no gain.

My device is :

Card: HDA Intel, Chip: SigmaTel STAC9228

Anyone willing to help please?
Thank you
Attached Thumbnails
Click image for larger version

Name:	alsamixer.png
Views:	39
Size:	161.3 KB
ID:	7046  

Last edited by disco_slack; 05-23-2011 at 03:54 PM.
 
Old 05-18-2011, 07:53 AM   #2
mlpa
Member
 
Registered: May 2008
Location: Aveiro
Distribution: Slackware
Posts: 524

Rep: Reputation: 45
Have you tried run alsaconf without using the config file?

P.S. in my skype, for my mic to function correctly, i select the speaker device in skype options.
 
Old 05-18-2011, 09:02 AM   #3
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,141

Rep: Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820
According to this, http://davestation.wordpress.com/200...in-ubuntu-804/ , you may need to change your Input Source 1 to Mic.

You may also need to try different settings in Skype.

P.S. I suggest that you use the 'options snd-hda-intel model=auto'. My googling suggests that this hardware should be autodetected without problem.
 
Old 05-22-2011, 02:31 AM   #4
disco_slack
Member
 
Registered: Apr 2011
Posts: 44

Original Poster
Rep: Reputation: 1
After several tries I have the best mic output with the settings

options snd-hda-intel model=dell-bios

Still the quality of sound output from mic in skype is low.
Is anyone here using a dell inspiron laptop?

Cheers
disco_slack


P.s.I tried to install skype in archlinux and I got better results with the same settings. Maybe I should install some libraries?
 
Old 05-22-2011, 04:49 AM   #5
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,141

Rep: Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820Reputation: 1820
Have you seen this, especially post#52 and post #76?
https://bugs.launchpad.net/dell/+bug/153963
 
Old 05-23-2011, 02:43 PM   #6
disco_slack
Member
 
Registered: Apr 2011
Posts: 44

Original Poster
Rep: Reputation: 1
I am about to scream from anger/joy. After one week of reading and trying I was able to find the correct settings for my mic. it was simply:
options snd-hda-intel model=dell

Only with this settings I could see a digital option in alsamixer which impacted the sound of mic. At least I refreshed my vey basic knowledge in linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is ALSA giving you no sound at all, when adding mic or other hardwares, at reboot? frenchn00b Linux - General 1 05-26-2010 09:50 AM
Skype - Logitech USB headset. No sound, no mic peteyperson Linux - Software 4 06-26-2009 04:57 AM
Skype sound problem with Alsa Mandriva 2009.0 Gnome moshebagelfresser Mandriva 1 02-06-2009 11:56 AM
SoundBlaster Audigy..ALSA drivers... mic works but cant hear any sound. punk Linux - Newbie 1 03-25-2004 06:29 PM
how do i enable 4CH sound with cm8738 with ALSA on slack9.1 hypermegachi Linux - Hardware 2 10-29-2003 04:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration