LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-07-2018, 09:19 AM   #1
interndan
Member
 
Registered: Aug 2004
Location: near Marion, Ill
Distribution: Slackware 14.2 64bit on Desktop Slackwarearm on Raspberry PI v1b
Posts: 348

Rep: Reputation: 29
Empty /home/user directory


I just finished a fresh install of Slackware. After adding my user account and logging back in, my user /home directory is empty. i.e no home/user/ /Pictures, /Downloads, etc.

Was this an error during install, or something due to recent updates?

I did update the system with slackpkg after the install and before adding my user account.
 
Old 11-07-2018, 09:23 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,850

Rep: Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118
No, it's normal behaviour
you need to fill it by yourself as needed
 
1 members found this post helpful.
Old 11-07-2018, 09:35 AM   #3
interndan
Member
 
Registered: Aug 2004
Location: near Marion, Ill
Distribution: Slackware 14.2 64bit on Desktop Slackwarearm on Raspberry PI v1b
Posts: 348

Original Poster
Rep: Reputation: 29
I'm a bit confused. I've been using Slackware for a long time now, and this is the first time I have ever seen this. My /home/user directory has always had /Pictures, /Music, /Downloads, etc created. They are of course empty until I populate them, but the directories have always been there.

I'm using Slackware 14.2 64 bit.
 
Old 11-07-2018, 09:55 AM   #4
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 802
Blog Entries: 1

Rep: Reputation: 689Reputation: 689Reputation: 689Reputation: 689Reputation: 689Reputation: 689
Quote:
Originally Posted by willysr View Post
No, it's normal behaviour
you need to fill it by yourself as needed
Not in my experience. I've done many installs of 14.2 like OP and /Downloads, /Documents, /Pictures, /Videos and /God-knows-what-else are always there. If it were me, I would be tempted to reinstall just in case anything else didn't go to plan while laying undiscovered for some time.
 
Old 11-07-2018, 10:01 AM   #5
Gerard Lally
Senior Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware, Crux, NetBSD
Posts: 1,452

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
Quote:
Originally Posted by interndan View Post
I just finished a fresh install of Slackware. After adding my user account and logging back in, my user /home directory is empty. i.e no home/user/ /Pictures, /Downloads, etc.

Was this an error during install, or something due to recent updates?

I did update the system with slackpkg after the install and before adding my user account.
Check /etc/fstab and mount to make sure /home has been mounted properly.
 
Old 11-07-2018, 10:11 AM   #6
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 833

Rep: Reputation: 704Reputation: 704Reputation: 704Reputation: 704Reputation: 704Reputation: 704Reputation: 704
Quote:
Originally Posted by interndan View Post
I just finished a fresh install of Slackware. After adding my user account and logging back in, my user /home directory is empty. i.e no home/user/ /Pictures, /Downloads, etc.

Was this an error during install, or something due to recent updates?

I did update the system with slackpkg after the install and before adding my user account.
The directories ~/Desktop, ~/Download, etc.. are created by xdg-user-dirs-update which is run at the start of a user session (this requires to run an XDG compliant desktop environment) and according to the configuration in /etc/xdg/user-dirs.conf (or ~/.config/user-dirs.conf when present).

To force installation of these directory, simply run the command :

Code:
$ xdg-user-dirs-update

Note that auto-creation of these directories (which I personnally don't like) can be deactivated.

at system level: edit the configuration file /etc/xdg/user-dirs.conf then change the line Enabled=True to Enabled=False

at user level: create the file ~/.config/user-dirs.conf and add the line Enabled=False to it.

--
SeB

Last edited by phenixia2003; 11-07-2018 at 10:13 AM.
 
6 members found this post helpful.
Old 11-07-2018, 10:11 AM   #7
interndan
Member
 
Registered: Aug 2004
Location: near Marion, Ill
Distribution: Slackware 14.2 64bit on Desktop Slackwarearm on Raspberry PI v1b
Posts: 348

Original Poster
Rep: Reputation: 29
I think I may have found the problem. I know! I'm a dummy! Always before I have selected XFCE as the default wm. I was trying Fluxbox on this install. So as an experiment I logged out, ran xwmconfig and switched to XFCE and after startx the Home directory was populated with the expected folders. Apparently XFCE creates them on first run.

After changing back to Fluxbox the expected folders were still in place.
 
1 members found this post helpful.
Old 11-07-2018, 10:15 AM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro / Parrot
Posts: 7,201

Rep: Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441Reputation: 1441
that is exactly why, it depends on what WM/DT you start up first. well it looks like you've learned something today, go buy yourself something, and smile.
 
1 members found this post helpful.
Old 11-07-2018, 08:36 PM   #9
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,850

Rep: Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118
i was assuming you just created the user, not when logging in to a DE.
Some DE (I used MATE) did create those folders for you when you logged in for the first time.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't automatically create an empty directory when new user is created. jimb.smith CentOS 2 04-02-2017 12:02 PM
User does int getting home directory in root home in ubuntu 10.04 lucid lynx sunrised24 Linux - Server 2 03-07-2012 10:21 AM
[SOLVED] 'Could not chdir to home directory /home/[user]: Permission denied' arashi256 Linux - Newbie 25 11-11-2011 10:29 AM
Creating new user gives empty /home directory rkfb Slackware 8 12-28-2005 12:17 PM
installed new kernal - now my /home directory is empty ! websinger Debian 6 05-07-2005 09:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration