-   Slackware (
-   -   Emacs Trouble, Meta key not working ( 07-13-2005 03:55 AM

Emacs Trouble, Meta key not working

I'm using,

Slackware 10.1
bash 3.0

When I'm editing a file in emacs the functions which requrie the Meta and shift keys to be pressed simultaneously are not working.

For example,

M-< (Move to beginning of buffer)
M-> (Move to end of buffer)
M-! (Execute shell command)

I tried both Alt and two consecutive escapes as meta key.

However, there is no problem when emacs runs under X.

Please help me!

keefaz 07-13-2005 04:39 AM

maybe create a ~/.inputrc with the content :

set meta-flag on
set convert-meta off
set input-meta on
set output-meta on 07-13-2005 05:53 AM

Please explain
Can u please explain about this ".inputrc"??

Is it used by Emacs or is it used by Bash??

keefaz 07-13-2005 07:09 AM

Note that I said 'maybe' ;)
More infos : 07-13-2005 10:38 PM

Sorry!!! Did not work

I tried what you said, but that did not help.

The ~/.inputrc file had a strange effect on my console input. The DELETE key started inserting tilde(~) instead of deleting the succeding character. However, this was corrected after removing ~/.inputrc. However, there is not change in the behavior of meta under emacs. 07-15-2005 12:17 AM

Some one please help me out.

I'm having to define my own keys for the common actions. 07-18-2005 04:53 AM


Can someone please provide a solution!!

I'm badly in need of it. Plz do not take this offensively. I'm just in urgent need.

All times are GMT -5. The time now is 08:09 PM.