LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-18-2005, 04:47 AM   #1
chandru.in
Member
 
Registered: Jun 2005
Posts: 167

Rep: Reputation: 30
Emacs, slow startup


Hi,

I'm using slackware 10.1.

When I start emacs(both console & X), it takes a long time to start. Can anyone tell me how I can make it start faster??
 
Old 07-18-2005, 12:51 PM   #2
GlowGlow
Member
 
Registered: Jun 2005
Posts: 111

Rep: Reputation: 15
Is your hostname resolvable?
 
Old 07-19-2005, 12:35 AM   #3
chandru.in
Member
 
Registered: Jun 2005
Posts: 167

Original Poster
Rep: Reputation: 30
I'm sorry!

I'm a newbie.

Can u explain this to me??
 
Old 07-19-2005, 03:41 AM   #4
GlowGlow
Member
 
Registered: Jun 2005
Posts: 111

Rep: Reputation: 15
Can you ping your hostname (use the 'hostname' command to see your hostname). If not, you have to add your IP plus hostname to /etc/hosts. Some people who have a problem with EMACS loading slowly do not have a resolvable hostname.
 
Old 07-19-2005, 05:40 AM   #5
chandru.in
Member
 
Registered: Jun 2005
Posts: 167

Original Poster
Rep: Reputation: 30
My system is not on a network.

Now I remember changing the contents of my /etc/HOSTNAME file.

Its present content is,

Quote:
Penguin_splendor
Is this what is creating the problem??

If so what would be the ideal content of /etc/HOSTNAME?
 
Old 07-19-2005, 06:02 AM   #6
GlowGlow
Member
 
Registered: Jun 2005
Posts: 111

Rep: Reputation: 15
That is not a legal hostname, hostnames can only consist of 'a-z' and '-' characters (and of course a '.', to make FQDNs like node.example.net). Try changing the hostname to 'penguin-splendor', and adding a line to /etc/hosts that says:

Code:
127.0.0.1          penguin-splendor
You can also use the IP address of an external interface of the machine. After making the changes the hostname should be resolvable, you can test this with

Code:
ping `hostname'
(Be sure to use backticks, this will fill in the output of the hostname command.)
 
Old 07-19-2005, 06:33 AM   #7
chandru.in
Member
 
Registered: Jun 2005
Posts: 167

Original Poster
Rep: Reputation: 30
Y should I give a IP address in /etc/hosts while I'm not on a network??

Also, can I give any number for IP??
 
Old 07-19-2005, 07:26 AM   #8
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 53
127.0.0.1 is the ip address of your loopback interface.
if you connect to it, you're just connecting to your own pc.

so , adding the line that GlowGlow posted to /etc/hosts
should solve it.

egag

Last edited by egag; 07-19-2005 at 07:27 AM.
 
Old 07-19-2005, 08:18 AM   #9
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,552

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
There is a warning commented in /etc/hosts though...
Code:
# By the way, Arnt Gulbrandsen <agulbra@nvg.unit.no> says that 127.0.0.1
# should NEVER be named with the name of the machine.  It causes problems
# for some (stupid) programs, irc and reputedly talk. :^)
#
 
Old 07-19-2005, 09:06 AM   #10
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 53
that brings the Q. : is emacs using the name in /etc/HOSTNAME or " localhost "

i have for my loopback in /etc/hosts :

127.0.0.1 localhost

i think that should be ok then.

egag
 
Old 07-19-2005, 09:34 AM   #11
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,552

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
and another Q : is emacs a stupid program ?
Sorry for kidding, but why a text editor would need
to know the hostname in order to work ?...
 
Old 07-19-2005, 10:07 AM   #12
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 53
well...i could imagine you could give a "host=" option to edit files on another machine,
but i didn't find anything like that.

but maybe you were not kidding, the makers of the doc.'s are...

see:
/usr/share/emacs/21.3/etc/condom.1
/usr/share/emacs/21.3/etc/COOKIES
----maybe more---

egag
 
Old 07-20-2005, 12:49 AM   #13
chandru.in
Member
 
Registered: Jun 2005
Posts: 167

Original Poster
Rep: Reputation: 30
Not did this thread solve my problem. It has also given me a basic understanding of hostname.

Emacs is a really cool editor. In fact I use it even on the windoze systems in my college.

Last edited by chandru.in; 07-20-2005 at 12:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Startup is very slow darknails Fedora 2 07-08-2007 02:51 PM
Slow startup Dosenwurst Debian 3 06-15-2005 07:09 AM
Slow startup sdat1333 Mandriva 2 11-24-2004 09:38 AM
mouse slow on startup..? marlor Slackware 4 07-10-2004 06:21 PM
X startup really slow ryedunn Mandriva 2 03-05-2004 04:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration