LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-19-2016, 01:48 PM   #1
zlin50
Member
 
Registered: Jan 2006
Location: Munich
Distribution: Slackware-14.x
Posts: 32

Rep: Reputation: 15
emacs kills xsession


Hi,

I got a problem with my freshly installed 14.2-system:
Quote:
cd 201605_Sächsische_Schweiz ; emacs
kills my xsession (I'm running xfce4), but
Quote:
cd 201605_Saechsische_Schweiz ; emacs
doesn't!

Actually, starting emacs in any directory, whose name contains a german umlaut,shows the same result, i.e. killing my xsession.

During installation, I changed 90-keyboard-layout.conf to
Code:
Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "us,de"
        Option "XkbVariant" ",nodeadkeys"
        Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:ralt,te
rminate:ctrl_alt_bksp,eurosign:e"
Any hint appreciated
 
Old 11-20-2016, 12:06 PM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,313

Rep: Reputation: Disabled
Probably has to do with locales. I don't have Slackware installed, so I cannot give details.
 
Old 11-20-2016, 01:21 PM   #3
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora, NetBSD
Posts: 1,061

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
I just tested this and it resulted in no crash:

Code:
$ mkdir 201605_Sächsische_Schweiz
$ cd 201605_Sächsische_Schweiz ; emacs
Can you try it without X, just to see if you get errors in your console about what emacs might be running into? It may report nothing since X is not started, but it might be worth looking at.
 
Old 11-21-2016, 06:21 AM   #4
zlin50
Member
 
Registered: Jan 2006
Location: Munich
Distribution: Slackware-14.x
Posts: 32

Original Poster
Rep: Reputation: 15
Thanks notKlaatu!

If it works for you while running X, I'll have to find the mistake within my configuration. :-(

Running
Code:
cd 201605_Sächsische_Schweiz ; emacs
without X-server is working without error-message.

Cheers
 
Old 11-21-2016, 03:27 PM   #5
zlin50
Member
 
Registered: Jan 2006
Location: Munich
Distribution: Slackware-14.x
Posts: 32

Original Poster
Rep: Reputation: 15
Update:

strace -o dump emacs
tail dump
Quote:
read(7, "\1\3\0\1\1\0\0\0", 8) = 8
read(7, "\1\0\0\0002645", 8) = 8
stat(".", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("/Vol2/home/zlin50/test/t\344st", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
write(7, "\1\f\1\0007\0\0\0\5\0\0\0\0\0\0\0\f\0\0\0CloneCommand"..., 448) = 448
write(7, "\1\10\1\0\0\0\0\0", 8) = -1 EPIPE (Broken pipe)
--- SIGPIPE {si_signo=SIGPIPE, si_code=SI_USER, si_pid=28465, si_uid=1000} ---
close(7) = 0
strace: Process 28465 detached
I can prevent the described issue by deleting ~/.ICEauthority.
This doesn't solve the problem, because .ICEauthority is re-created with each new login.

Last edited by zlin50; 11-22-2016 at 02:59 PM.
 
Old 12-31-2016, 02:01 PM   #6
zlin50
Member
 
Registered: Jan 2006
Location: Munich
Distribution: Slackware-14.x
Posts: 32

Original Poster
Rep: Reputation: 15
Solution:

move to utf-8
Quote:
cat >> ~/.profile <<EOD

export LANG=de_DE.utf8
EOD
Quote:
(cd ; convmv -r -f iso-8859-1 -t utf-8 * --notest)
 
  


Reply

Tags
emacs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] what are files .xsession-errors and .xsession-errors.old can they be deleted? cliffm Linux - Newbie 2 10-20-2012 12:30 PM
How can I get emacs -nw when I call emacs from a terminal but GUI emacs elsewhere? Blackened Justice Linux - Newbie 4 09-08-2011 08:57 AM
emacs + auctex - opening output PDF inside emacs buffer coenvh Linux - Newbie 1 04-29-2010 06:52 AM
edb (emacs database) won't open file - emacs 20 & 21 tip184 Linux - Software 0 04-03-2004 08:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration