-   Slackware (
-   -   emacs in run level 3 then switch to X (level 7) then back to level 3 (

dsoliver 08-31-2006 03:21 PM

emacs in run level 3 then switch to X (level 7) then back to level 3
This is a frustrating problem for me. I like to sometimes use the iso-8859-3 font set in Emacs for writing in Esperanto. It works well in a text console in run level 3; however, as soon as I start an X session something happens such that if I return to run level 3 either by ending X completely or by <ctl><alt><F3>, I can no longer see the iso-8859-3 characters correctly in run level 3. After creating a file in emacs with Esperanto characters, I can display them on my text terminal with for example "less filename". After starting X, I can never again return to a text console outside of X and see the Esperanto characters correctly without rebooting the system. If I reboot, everything's back to normal in run level 3; that is until I start an X session again. It should be said that I can see the characters correctly in X even when they aren't showing correctly in run level 3. So I guess I have two questions. 1) what's happening? and 2) How can I reset my run level 3 session without a reboot?

Another tidbit: I tried creating an Esperanto document in emacs in level3; I left it on the screen; then switched to a second level 3 virtual terminal (<alt><F2> and from there started X (startx). From X I switched to my first level 3 terminal that had emacs still running on it, and I find my Esperanto characters all boogered up. Other text is fine though.

Any ideas would be welcomed. I'm running Slac 10.2 with the kernel. I've updated packages to 10.2/current. Everything else seems to be running really well. I'm using a Dell i8600. Thanks --Douglas

drkstr 08-31-2006 08:50 PM

Does this happen when you actually switch run levels? 'init 4' to open up X, 'init 3' to switch back to console. Not an ideal solution, but might narrow down the problem.


dsoliver 09-01-2006 01:59 AM

The problem occurs from the switch from run level 3 (text console) to X. Once I've entered X, it doesn't matter what changes I make in run levels or consoles. I've tried keeping virtual terminal 1 with emacs still running with text on the screen, then switching to console 2, where I run startx to start console 7. From that point I use ctrl alt F1 to return to the text console with emacs running. The characters for the international letters have changed to new strange characters. The rest of the text is normal. Stopping X makes no difference. Using only X makes no difference; however I can see the intl characters in X ok. In other words I can switch to my text terminals and exit each one (log out of them) and return to X with alt F7. I can log into a new text terminal (leaving X of course) but the character stay messed up. I use less to view a file with text I've written earlier. I've been trying every permutation I can think of to see what happens. Nothing but a reboot will allow my original run level 3 terminal to display those characters.

gnashley 09-01-2006 03:31 AM

Probably get better results running X from tty1 as usual. Try running emacs on tty2 first, then return to tty1 and run startx from there. Note that you are not changing runlevel by running startx -you are still in runlevel 3 unless you are running init 4.

You might also try opening emacs on tty6 and using runlevel 4.

Also, once you have started X you should use CTRL-ALT-F? to switch between consoles. The terminal you startx from is basically unreachable while x is running. If you starx from tty1 x appears on tty7 leaving tty2-6 available for use.

All times are GMT -5. The time now is 12:20 PM.